Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th January 2006, 18:41
AlexanderTheGr AlexanderTheGr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Statistics admin Bug????

I thing this could be a bug.

I have create a new site with 200MB disk space

I loged as user admin to this site and i have uploaded (By using FTP) the site's file (Many pics and sounds available for donwloads) almost 150MB

I checked how many disk space i used to this site. It said me 150MB. All work fine hire.

Now i have changed the permitions to dowloaded directories to 717 and to all downloaded files to 644.

I checked again how many disk space i used to this site. It said me 29MB!!!!. This is not right because i am using 150MB and not 29MB.

I noticed the problem is cause i have chaged the permision specialy the group perimetions. The group permition should be 5 (read and execute) to get the right report.

Off course the quota works fine and it does not allow me to extend the storage limit space... but the report of using space is wronk

I am sure but i think the bandwith report is wronk also.....

PS: Sory about my bad english

Alexander
Reply With Quote
Sponsored Links
  #2  
Old 14th January 2006, 23:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

There is no bug. If you want to change the permissions of files manually you have to configure the "du" command to be executed with root priveliges by sudo.

Then add the line:

$go_info["server"]["sudo_du_enabled"] = true;

to the file /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th January 2006, 03:29
AlexanderTheGr AlexanderTheGr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

And how can I do it this step by step? I am using debian
Reply With Quote
  #4  
Old 15th January 2006, 12:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Sudo installation on debian:

http://www.debianhelp.co.uk/sudo.htm
http://www.linuxmanpages.com/man5/sudoers.5.php

The user admispconfig must be enabled to run the "du" command. I dont have more detailed instructions here for the moment.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 15th January 2006 at 12:52.
Reply With Quote
  #5  
Old 15th January 2006, 15:29
AlexanderTheGr AlexanderTheGr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It worked thx a lot
Reply With Quote
  #6  
Old 9th March 2006, 08:54
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

I already had found that setting for the du sudo :-) but I did not think further so I did not insert admispconfig into sudoers :-(

Now that I read the post you linked to I tried modifying my sudoers like this:
Quote:
admispconfig ALL=NOPASSWD: /usr/bin/du *
I added that line using visudo and tried su admispconfig then du -s -c -h web2/ and here is the output:

Quote:
admispconfig@h5810:/var/www$ du -c -s -h web2
du: ,,web2/web/brasov/php/poll/lang": Keine Berechtigung
du: ,,web2/web/bucuresti/php/poll/lang": Keine Berechtigung
du: ,,web2/web/cluj/php/poll/lang": Keine Berechtigung
du: ,,web2/web/sibiu/php/poll/lang": Keine Berechtigung
du: ,,web2/web/timisoara/php/poll/lang": Keine Berechtigung
du: ,,web2/user/web2_tibi/Maildir": Keine Berechtigung
du: ,,web2/user/web2_info/Maildir": Keine Berechtigung
du: ,,web2/user/web2_info/.spamassassin": Keine Berechtigung
du: ,,web2/user/web2_info/tmp": Keine Berechtigung
du: ,,web2/user/web2_info/.pyzor": Keine Berechtigung
du: ,,web2/user/web2_dark/Maildir": Keine Berechtigung
du: ,,web2/user/web2_timisoara/Maildir": Keine Berechtigung
du: ,,web2/tmp": Keine Berechtigung
du: ,,web2/.spamassassin": Keine Berechtigung
du: ,,web2/.pyzor": Keine Berechtigung
3,9G web2
3,9G insgesamt
admispconfig@h5810:/var/www$
BUT I can get this output even without putting admispconfig into sudoers , strange...

so now that this works, shouldn't ispcfg display the corect values?
well I tried again, the details about the folders file usage is now there, BUT it still says:

Quote:
Storage space: 6000 MB
used: 11015.09k
meaning the folder sizes do not get added up to the total, total still only shows the size of the databases...

###edit###

I noticed it does not work for the largest site, the smaller ones display correct values.
here is the one that does not comply:

Quote:
Storage space: 6000 MB
used: 11015.27k



/web 1,6G
/user 640K
/log 768M
/cgi-bin 4,0K
/ssl 4,0K
/phptmp 4,0K
/backup 1,6G
/tmp 4,0K
/.spamassassin 40K
/.pyzor 8,0K
DB::MySQL 11012.3k

Last edited by Ovidiu; 9th March 2006 at 09:53.
Reply With Quote
  #7  
Old 12th March 2006, 13:59
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

anymore ideas? it seems like the total DB space does not add to the total web space and logs are growing over the fixed size I set in ISPCFG panel
Reply With Quote
  #8  
Old 10th May 2006, 19:35
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

Seems to me that the sudo-check is broken in ispconfig =(

Even though sudo is enabled in /etc/sudoers for admispconfig it doesnt seem to show all the directories in statistics when I've run chmod 701 /var/www/web*

I dont want other users snooping in eachothers directories, and I dont want to have to chroot everyone. Too much overhead.
__________________
http://www.xh.se
Reply With Quote
  #9  
Old 27th May 2006, 23:00
AlexanderTheGr AlexanderTheGr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

try this to the sudoers

Code:
admispconfig ALL=NOPASSWD: /usr/sbin/du *
Reply With Quote
  #10  
Old 5th October 2006, 13:55
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
 
Default

its /usr/bin/du on Debian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistics not compiling. thevinster Installation/Configuration 137 11th November 2010 10:54
Multiple Admin Users esadmf General 2 10th May 2006 19:39
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
ISPConfig admin Password linuxuser1 Installation/Configuration 2 21st October 2005 13:38
Webalizer - Usage by Country statistics leno Installation/Configuration 3 28th April 2005 18:12


All times are GMT +2. The time now is 05:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.