Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th August 2008, 17:37
vidalster vidalster is offline
Junior Member
 
Join Date: Aug 2008
Posts: 6
Thanks: 6
Thanked 0 Times in 0 Posts
Default Trying to install joomla, php dont rules

I used the the perfect ubuntu server 8.04 guide and the manual installation of ispconfig.
My problem is it, when i´m trying to install joomla, my firefox(kubuntu installed in the server) http://localhost/www.example.com/joomla only show php code(in plain html) , and not execute php on apache server, this only show the text content of index.php.
I´m too newbie and i dont´t understand what´s the problem, why apache don´t rules if it´s running and ok?

Pd: Sorry for my english
Reply With Quote
Sponsored Links
  #2  
Old 20th August 2008, 11:46
oriongr oriongr is offline
Member
 
Join Date: Nov 2007
Posts: 38
Thanks: 28
Thanked 3 Times in 3 Posts
Default

When you created the virtual site did you check the PHP option for that site in ISPconfig?
Reply With Quote
The Following User Says Thank You to oriongr For This Useful Post:
vidalster (22nd August 2008)
  #3  
Old 20th August 2008, 13:45
vidalster vidalster is offline
Junior Member
 
Join Date: Aug 2008
Posts: 6
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Yes i´ve checked the option when i have created the website. I follow the guides step by step, at the moment ispconfig are running ok, the problem are int he php-apache configuration.
Reply With Quote
  #4  
Old 20th August 2008, 14:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must use www.example.com/joomla in your browser, not http://localhost/www.example.com/joomla.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
vidalster (22nd August 2008)
  #5  
Old 20th August 2008, 18:10
vidalster vidalster is offline
Junior Member
 
Join Date: Aug 2008
Posts: 6
Thanks: 6
Thanked 0 Times in 0 Posts
Default

i must to use a real domain or i can to use a virtual domain name??, i was created a virtual host www.example.com, i use this direction in the internet browser :

www.example.com/joomla and the results are the same

edit: i only want to use it on localhost at the moment

Last edited by vidalster; 20th August 2008 at 18:13.
Reply With Quote
  #6  
Old 21st August 2008, 19:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must use the FQDN that you see as ServerName or ServerAlias in that vhost in the Vhosts_ispconfig.conf file because the vhosts are name-based.

You can do this: http://www.howtoforge.com/forums/sho...s+file+windows
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
vidalster (22nd August 2008)
  #7  
Old 22nd August 2008, 12:11
vidalster vidalster is offline
Junior Member
 
Join Date: Aug 2008
Posts: 6
Thanks: 6
Thanked 0 Times in 0 Posts
Default

This is my site-enabled in a virtual host on apache

Code:
<VirtualHost *:80>
	ServerAdmin webmaster@anet
        ServerName www.anet.es	
	DocumentRoot /var/www/www.anet.es
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/www.anet.es>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
And it is my Vhosts_ispconfig.conf

Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 192.168.1.100:80
<VirtualHost 192.168.1.100:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
  <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
    RewriteRule .* - [F]
  </IfModule>
</VirtualHost>
#
#
######################################
# Vhost: www.anet.es:80
######################################
#
#
<VirtualHost 192.168.1.100:80>
ServerName www.anet.es:80
ServerAdmin webmaster@anet.es
DocumentRoot /var/www/web11/web
ServerAlias anet.es
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web11/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode Off
Alias /error/ "/var/www/web11/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
  RewriteRule .* - [F]
</IfModule>
</VirtualHost>
#
#
#
The site is running but www.anet.es only shows a directory structure of the web, and www.anet.es/joomla (directory installation) only shows this

Code:
<?php
/**
* @version		$Id: index.php 10381 2008-06-01 03:35:53Z pasamio $
* @package		Joomla
* @copyright	Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
* @license		GNU/GPL, see LICENSE.php
* Joomla! is free software. This version may have been modified pursuant
* to the GNU General Public License, and as distributed it includes or
* is derivative of works licensed under the GNU General Public License or
* other free or open source software licenses.
* See COPYRIGHT.php for copyright notices and details.
*/

// Set flag that this is a parent file
define( '_JEXEC', 1 );

define('JPATH_BASE', dirname(__FILE__) );

define( 'DS', DIRECTORY_SEPARATOR );

require_once ( JPATH_BASE .DS.'includes'.DS.'defines.php' );
require_once ( JPATH_BASE .DS.'includes'.DS.'framework.php' );

JDEBUG ? $_PROFILER->mark( 'afterLoad' ) : null;

/**
 * CREATE THE APPLICATION
 *
 * NOTE :
 */
$mainframe =& JFactory::getApplication('site');

/**
 * INITIALISE THE APPLICATION
 *
 * NOTE :
 */
// set the language
$mainframe->initialise();

JPluginHelper::importPlugin('system');

// trigger the onAfterInitialise events
JDEBUG ? $_PROFILER->mark('afterInitialise') : null;
$mainframe->triggerEvent('onAfterInitialise');

/**
 * ROUTE THE APPLICATION
 *
 * NOTE :
 */
$mainframe->route();

// authorization
$Itemid = JRequest::getInt( 'Itemid');
$mainframe->authorize($Itemid);

// trigger the onAfterRoute events
JDEBUG ? $_PROFILER->mark('afterRoute') : null;
$mainframe->triggerEvent('onAfterRoute');

/**
 * DISPATCH THE APPLICATION
 *
 * NOTE :
 */
$option = JRequest::getCmd('option');
$mainframe->dispatch($option);

// trigger the onAfterDispatch events
JDEBUG ? $_PROFILER->mark('afterDispatch') : null;
$mainframe->triggerEvent('onAfterDispatch');

/**
 * RENDER  THE APPLICATION
 *
 * NOTE :
 */
$mainframe->render();

// trigger the onAfterRender events
JDEBUG ? $_PROFILER->mark('afterRender') : null;
$mainframe->triggerEvent('onAfterRender');

/**
 * RETURN THE RESPONSE
 */
echo JResponse::toString($mainframe->getCfg('gzip'));
If apache execute ispconfig without problem, why directory installation only sows the content of index.php
Reply With Quote
  #8  
Old 23rd August 2008, 16:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I get a 404 error when Itry to access joomla. What's the output of
Code:
ls -la /var/www/web11/web
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
vidalster (25th August 2008)
  #9  
Old 25th August 2008, 09:20
vidalster vidalster is offline
Junior Member
 
Join Date: Aug 2008
Posts: 6
Thanks: 6
Thanked 0 Times in 0 Posts
Default

The output of: ls -la /var/www/web11/web

total 20
drwxrwxr-x 4 web11_vidalster web11 4096 2008-08-06 04:00 .
drwxr-xr-x 9 web11_vidalster web11 4096 2008-08-22 11:06 ..
drwxrwxr-x 2 web11_vidalster web11 4096 2008-08-05 21:08 error
-rw-rw-r-- 1 web11_vidalster web11 1115 2008-08-05 21:08 index.html
drwxr-xr-x 2 web11_vidalster web11 4096 2008-08-23 04:00 stats


I trying to make it only in local network, i only need that itś works in my local server, i dont have anyone domain name in the internet web

Thanks for you atention Falko
Reply With Quote
  #10  
Old 25th August 2008, 11:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
 
Default

There is no joomla installed in the website. Maybe you forgot to enable the "administrator" checkbox of the user that you used to upload the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
vidalster (25th August 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 03:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.