Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st August 2008, 17:48
paguira paguira is offline
Junior Member
 
Join Date: Aug 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default a backup server by RSYNC + SSH in a chrooted environment

Good morning,
I try to set up a backup server by RSYNC + SSH in a chrooted environment.
Only SCP, SFTP and RSYNC will be used and usable for users.
And I want to establish quotas for these users.
I use CentOS5 note Fedora
I tested script:

http://www.howtoforge.com/chroot_ssh_sftp_fedora7_p2

But in both cases, when I connect with the user's account I have an immediate disconnection

I tested the script "make_chroot_jail.sh" according to the following procedure:
http://www.howtoforge.com/chroot_ssh_sftp_fedora7_p2

I had the following problem:
Quote:
sudo: user: sorry, you must have a tty to run sudo; TTY = unknown; PWD = /home/chroot/home/user; USER = root ...
What I set like this:
comment "requiretty Defaults" in "/etc/sudoers"

ld-lsb.so.1 is replaced by ld-lsb.so.3 in the script "make_chroot_jail.sh" REDHAT

Nevertheless I find it impossible to connect me with ssh and WinSCP, I have an immediate disconnection, my logs:

Quote:
Aug 13 15:49:24 rsync sshd[2797]: Accepted password for utilisateur from 192.168.23.199 port 1116 ssh2
Aug 13 15:49:24 rsync sshd[2797]: pam_unix(sshd:session): session opened for user utilisateur by (uid=0)
Aug 13 15:49:24 rsync sshd[2799]: subsystem request for sftp
Aug 13 15:49:24 rsync sudo: utilisateur : TTY=unknown ; PWD=/home/chroot/home/utilisateur ; USER=root ; COMMAND=/usr/sbin/chroot /home/jail /bin/su - utilisateur -c /usr$
Aug 13 15:49:24 rsync sshd[2797]: pam_unix(sshd:session): session closed for user utilisateur

P.S: excused my English, I'm french Reply With Quote
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2008, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you get any errors when you ran the script?
Is the chrooted user listed in /home/chroot/etc/passwd and /home/chroot/etc/shadow?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd August 2008, 14:46
paguira paguira is offline
Junior Member
 
Join Date: Aug 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have no error.

Except with "libxcrypt"
But according to the tutorial "HowForge" This is not a problem

I forget to say that I'm on CentOS 5

/home/chroot/etc/passwd


Code:
root:x:0:0:root:/root:/bin/bash
utilisateur:x:500:500::/home/utilisateur:/bin/bash
/home/chroot/etc/shadow

Code:
utilisateur:$1$3lXATEfy$.ttLr/IFf.3VPXo4qjgTq0:14112:0:99999:7:::
Reply With Quote
  #4  
Old 23rd August 2008, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Not sure if this is the problem, but did you disable SELinux?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
cacti problem - graphs have huge gaps Chip Installation/Configuration 7 7th February 2008 23:24
Public and private network + High Availability Apache Cluster teleted HOWTO-Related Questions 11 28th January 2008 14:29
Mail Server Backup nibb General 3 6th June 2007 15:52
Backup routine for ISPConfig-equipped server IntnsRed General 4 5th May 2006 17:29


All times are GMT +2. The time now is 00:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.