Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th April 2008, 03:21
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default upgrade 2.2.16 -> 2.2.22 PTR problem (Bugs?)

Hi there,
I have upgraded from version 2.2.16 to 2.2.22. Now I have a problem with DNS.

I have defined several records for one domain/zone which I use as IP "shortcuts", i.e. which resolve to IPs not under my control, for example backup.mydomain.com which resolves to the backup server of my ISP.

The first problem now is, for each of those IPs a reverse zone is created, which makes no sense. As a consequence (or as an additional bug) the entries in those files are not correct either: while the forward declaration is "bla.mydomain.com" the PTR entry is generated as "bla.one-of-my-other-domains.com".

Maybe one should simply not generate reverse zones for IPs that ISPConfig is not responsible for.

The second thing is, I have one hostname which resolves to 127.0.0.1, for that it creates a second reference to 0.0.127.in-addr.arpa in named.conf, which effectively breaks the BIND configuration, as the named.conf.master already contains a static entry for the loopback interface at the top. Bind does not start with two entries for the same zone.

Best regards,
jmroth

Last edited by jmroth; 10th April 2008 at 03:29.
Reply With Quote
Sponsored Links
  #2  
Old 10th April 2008, 10:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

The creation of the PTR records that ISPConfig does is correct in my opinion and it fixes a bug in pror versions were the ptr records had not been created for the A-Records correctly.

To your second problem, either remove the static configuration for 127.0.0.1 from your named.conf or dont configure the A record for the IP 127.0.0.1 in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th April 2008, 15:56
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by till
The creation of the PTR records that ISPConfig does is correct in my opinion and it fixes a bug in pror versions were the ptr records had not been created for the A-Records correctly.
Well everything is wrong, but if you say so...

Quote:
Originally Posted by till
To your second problem, either remove the static configuration for 127.0.0.1 from your named.conf or dont configure the A record for the IP 127.0.0.1 in ISPConfig.
I figured that out by myself already
Although I don't think it's a real solution.
Reply With Quote
  #4  
Old 16th April 2008, 16:32
the_spy the_spy is offline
Member
 
Join Date: May 2007
Posts: 91
Thanks: 20
Thanked 6 Times in 6 Posts
Default

same problem here.

I have for example 2 domains, say domain1.com and domain2.com

on domain1.com , I have configured home1.domain1.com in the DNS which have my fixed IP at home.

but ispconfig create an arpa file in Bind, with a PTR of my home IP with the wrong reverse home1.domain2.com (instead of home1.domain1.com)

appart creating a PTR of an IP which is not really usefull and may cause problem in some other applications (like SSH which now does not really like the wrong reverse of my home IP and says in the log "possible break-in attempt") , it should at least put the "right PTR" home1.domain1.com and not home1.domain2.com

for now, since I'm not using PTR actually, I have deactivated the "reverse" bloc in the named.conf customised template to avoid these problems.
Reply With Quote
  #5  
Old 17th April 2008, 19:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

I've added this to the bugtracker.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 16th July 2008, 20:30
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

Hmmm ok, I can register for the bugtracker but not post any comments :-\
Here we go then:


Concerning the "Bugfix for PTR records: only one PTR record per IP address; PTR zones are now created correctly" (ISPC 2.2.22). Where was this initial bugfix discussed, I would like to look that up?

I can elaborate more on this BTW.

I have a zone/domain called "blubbi.com" in ISPConfig (both as a web and in DNS).
(The domain does not actually exist/is not mine, it is just for internal testing.)

Now it generates the following PTR records:

/etc/bind# grep blubbi * | grep PTR
pri.0.0.127.in-addr.arpa:1 PTR mysql.blubbi.com.
pri.239.239.213.in-addr.arpa:xx PTR sm.blubbi.com.
pri.245.135.213.in-addr.arpa:xx PTR mde.blubbi.com.
pri.42.198.88.in-addr.arpa:xx PTR hb.blubbi.com.
pri.43.46.78.in-addr.arpa:xx PTR mark5.blubbi.com.
pri.44.198.88.in-addr.arpa:xx PTR a.ns.blubbi.com.
pri.54.11.217.in-addr.arpa:xx PTR m1.blubbi.com.
pri.54.11.217.in-addr.arpa:xx PTR m2.blubbi.com.
pri.54.11.217.in-addr.arpa:xx PTR m3.blubbi.com.
pri.54.11.217.in-addr.arpa:xx PTR m4.blubbi.com.
pri.64.186.195.in-addr.arpa:xx PTR old.blubbi.com.
pri.88.177.195.in-addr.arpa:xx PTR blubbi.com.
pri.90.177.195.in-addr.arpa:xx PTR cs.blubbi.com.

1) My DNS is not authoritative for those networks: only generate (correct) records when the IP of the corresponding A record is also listed in Management->Server->Settings.

If you do that maybe you don't even need the second point (which also does not matter if the initial bugfix had only fixed the bug of "only one PTR record per IP address"):

2) Those are all hosts that I have configured A records for, but NOT in the domain blubbi.com! (except for the root of the domain "blubbi.com." itself of course) I do not know why it chooses blubbi.com!
Reply With Quote
  #7  
Old 20th August 2008, 00:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

I've completely rewritten the PTR part. Instead of having ISPConfig create the PTR records automatically, there's now a web form (similar to the slave records) where you can define PTR records one by one. This should fix all the problems.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
suPHP problem after PHP upgrade - ubuntu SupuS Installation/Configuration 6 21st May 2008 21:36
network_setup problem after upgrade 2.2.3 -> 2.2.14 rhl2000 General 6 17th February 2008 22:28
This line keeps on showing up in my bind record yurtboy1 Installation/Configuration 5 30th November 2007 12:19
Upgrade 2.3.3 -> 2.2.5 NOT Working on VMWare Image pesja Installation/Configuration 6 7th August 2006 14:28


All times are GMT +2. The time now is 23:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.