Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2008, 05:57
RiskySeven RiskySeven is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Roundcube package can't open HTML emails

Hi. I've been grinding on this for many, many hours. I'm a former 42Go admin, and I've just done a fresh ispconfig build / roundcube package install on Ubuntu 8.04 (using the perfect setup). Everything seems to be working fine, except I can't open HTML emails! I get a http 500. Below is the error message out of roundcube/log/error. If anyone can provide some help/direction I'd greatly appreciate it...pulling my hair out here.

[16-Aug-2008 22:41:55] PHP Warning: include_once(DOMDocument.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/web/roundcubemail/program/include/iniset.php on line 80
[16-Aug-2008 22:41:55] PHP Warning: include_once() [<a href='function.include'>function.include</a>]: Failed opening 'DOMDocument.php' for inclusion (include_path='/home/admispconfig/ispconfig/web/roundcubemail/:/home/admispconfig/ispconfig/web/roundcubemail/program:/home/admispconfig/ispconfig/web/roundcubemail/program/lib:/home/admispconfig/ispconfig/web/roundcubemail/program/include:.:/usr/share/php:/root/ispconfig/php/include') in /home/admispconfig/ispconfig/web/roundcubemail/program/include/iniset.php on line 80
[16-Aug-2008 22:41:55] PHP Fatal error: Class 'DOMDocument' not found in /home/admispconfig/ispconfig/web/roundcubemail/program/lib/washtml.php on line 188
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2008, 17:08
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Code:
[16-Aug-2008 22:41:55] PHP Fatal error: Class 'DOMDocument' not found in /home/admispconfig/ispconfig/web/roundcubemail/program/lib/washtml.php on line 188
Thats the problem there is a file that needs to be included but its not being included.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 17th August 2008, 17:17
RiskySeven RiskySeven is offline
Junior Member
 
Join Date: Jan 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply topdog. It's my understanding that DOMDocument is part of the base php5 package....since the php5 directory is in the include_path, I don't understand why it can't find the class DOMDocument. ??
Reply With Quote
  #4  
Old 17th August 2008, 17:54
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Not entirely true or it is being overriden by roundcube because you can see this
Code:
[16-Aug-2008 22:41:55] PHP Warning: include_once(DOMDocument.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/web/roundcubemail/program/include/iniset.php on line 80
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 17th August 2008, 19:07
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
 
Default

Maybe this thread will Help. http://www.howtoforge.com/forums/sho...ight=roundcube
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transaction error Perfect FC6 setup ACDII HOWTO-Related Questions 1 6th July 2007 14:56
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14
open ports rayit General 6 18th January 2006 14:23


All times are GMT +2. The time now is 05:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.