Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th February 2009, 05:08
h8r h8r is offline
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Drop the web_host default value='www' ?

Hello,

I'm new to ispconfig.. I've just set up a server with CentOS, everything is working fine.. but I can't find from where I can drop out the default hostname for a site? This is very annoying problem because every time I update or insert a new site the hostname changes to its default value=www.

So If I don't want to use a hostname I had to clear the default value with firebug and then update the site settings. Maybe I'm wrong somewhere or I can't find this thing in the settings.. but if I have site with hostname www I have to change the username I use to log in squirrelmail..

here is the html I correct each time I save the site

<input class="text" type="text" value="www" maxlength="255" size="10" name="form[web_host]"/>

How can I drop this?

Thanks in advance,
h8R

P.S. I'm using ispconfig2
Reply With Quote
Sponsored Links
  #2  
Old 5th February 2009, 22:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I haven't experienced anything like that. Are you using the latest ISPConfig 2 release (2.2.29)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th February 2009, 12:37
h8r h8r is offline
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question

Yes, I'm using this ISPConfig-2.2.29.tar.gz packet and its very very annoying. Not sure what to do... I've tried searching the form template and modify it manually, but really can't find it.

The problem with the hosts comes when the user logs in squirrel by his username+domain. I found there lines with www. in /etc/postfix/virtusertable

Maybe I should upgrade to ispconfig3?

p.s. I've built the entire system using this howto http://www.howtoforge.com/centos-5.1...-ftp-ispconfig
Reply With Quote
  #4  
Old 6th February 2009, 16:01
h8r h8r is offline
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default mmm

I'm pretty sure the last message is spam.. admins please remove it, because of it nobody will help me :/
Reply With Quote
  #5  
Old 7th February 2009, 11:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

The hostname field of a website can not be empty, thats why it is filled in automatically in case that you did not enter a value.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 7th February 2009, 13:28
h8r h8r is offline
Junior Member
 
Join Date: Feb 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up thanks for the reply!

Hi, till! Thanks for the reply. So I understand.. I can't go without www. but my ispconfig doesn't creates server alias for the virtual host I setup. Also puts the hostname plus the domain in /etc/postfix/virtusertable and file looks like this

test@www.domain.org.uk web12_test
web12_test@www.domain.org.uk web12_test

So the user has to log with hostname+domain in squirrelmail. I will dig in the source code to make my modifications. Seems that howto is not finished, or nobody else happend to use squirrelmail with it

Have a nice weekend and thanks again!
h8R

Last edited by h8r; 7th February 2009 at 13:36.
Reply With Quote
  #7  
Old 7th February 2009, 13:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
 
Default

Thats all fine as ISPConfig adds automatically a co-domain with empty hostnam if you have not set the limuts too low.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 15:51
Admin Program for Virtual Users and Domains Postfix courier etc...(Ubuntu 8.04)? the1rob HOWTO-Related Questions 11 4th August 2009 05:54
Default Mail scan settings for new users timehost Installation/Configuration 3 26th October 2007 13:05
Exim MTA dazblade Server Operation 4 16th July 2007 19:42
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 18:54


All times are GMT +2. The time now is 06:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.