#1  
Old 12th December 2008, 13:45
dolmax dolmax is offline
Member
 
Join Date: Mar 2008
Posts: 33
Thanks: 2
Thanked 0 Times in 0 Posts
Default Apache directive related

Hi everyone,

I've been working on a problem for a day now.

I have two domains hosted on the same ISPConfig system.

example.com and example.de

I've a multi-language web site running on example.com web space. I would like to forward example.de inquiries to example.com/index.php?lang=german

I can create a forward using that URL, but my problem is, ISPconfig adds a "/" at the end of forwarded URL as a rule. Then my site does not recognize the language pointer. I would still get the English site.

I know that I can not edit the vhosts_ispconfig.conf manually, and the only way is to add an apache directive for example.de.

What do I insert in that text area?

I've tried both;

Solution 1:
Code:
RewriteEngine on
RewriteCond %{HTTP_HOST}   ^example\.de [NC]
RewriteRule ^/(.*)         http://www.example.com/index.php?lang=german$1 [
L,R]
Solution 2:
Copy paste the complete Virtual Host text.

Both did not work. Any suggestions or ideas?

Thanks,
Reply With Quote
Sponsored Links
  #2  
Old 13th December 2008, 19:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Quote:
What do I insert in that text area?
The apache directives that shall be inserted into the vhots. If you insert a apache directive there and it does not work, then there is an error in the directive that you entered.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th December 2008, 23:51
dolmax dolmax is offline
Member
 
Join Date: Mar 2008
Posts: 33
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Till thank you for the reply.

But I could not understand the problem with the directive.

Code:
RewriteEngine on
RewriteCond %{HTTP_HOST}   ^example\.de [NC]
RewriteRule ^/(.*)         http://www.example.com/index.php?lang=german$1 [
L,R]
This code is automatically created by ISPConfig into the vhost file, if I use the forward capability. Can you tell me what seems to be the problem in the code that I insert?
Reply With Quote
  #4  
Old 13th December 2008, 23:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
 
Default

Dont insert the code twice if the code has been inserted by ISPConfig already.

Also you code is broken as you have a newline after [
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
FTP cannot open remote folder!?! andysm849 Server Operation 23 16th October 2008 23:34
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 23:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.