#1  
Old 5th October 2006, 13:49
jang jang is offline
Junior Member
 
Join Date: Aug 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default Locale date setting

I've followed the perfect Ubuntu Dapper Drake server setup, with initially English localization.

Now I want to add support for Dutch dates in a Joomla site, but I can't work it out. It must be related to the server support; simply changing settings in Joomla for Country Locale to nl_NL or nld_NLD doesn't give anything but english dates.

When I do locale -a on the server I only get:
C
en_US.utf8
POSIX

How do I change it and add the possibility for dutch and english dates in my websites?

Thx

Jang
Reply With Quote
Sponsored Links
  #2  
Old 6th October 2006, 14:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,703 Times in 2,546 Posts
Default

You can run
Code:
dpkg-reconfigure locales
and add Dutch there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th October 2006, 14:50
jang jang is offline
Junior Member
 
Join Date: Aug 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have already tried that before, but I don't know how to add things:

dpkg-reconfigure locales

gives

Generating locales...
en_US.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Amsterdam'.
Local time is now: Fri Oct 6 14:47:02 CEST 2006.
Universal Time is now: Fri Oct 6 12:47:02 UTC 2006.
Run 'tzconfig' if you wish to change it.

But I don't want to change the time-zone
Reply With Quote
  #4  
Old 6th October 2006, 16:58
jang jang is offline
Junior Member
 
Join Date: Aug 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I've finally figured it out:

it seems that for dapper drake 6.06 you need to add the locale settings manually (nl_NL.UTF-8) to:

Code:
*/locales/supported.d/local
For all supported locales see:
Code:
vi  /usr/share/i18n/SUPPORTED
Then
Code:
dpkg-reconfigure locales
and restart apache:
Code:
/etc/init.d/apache2 restart
Set the Joomla Country Locale to:nl_NL.UTF-8

Working like a charm! )

Jang
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up SystemImager-client Hans Installation/Configuration 6 29th June 2006 13:02
ISP general manegement setting dont save new setting adrenalinic Installation/Configuration 13 25th May 2006 14:55
Problem setting external mailserver erk Installation/Configuration 4 18th May 2006 10:56
Date stamp problem with samba file sharing cioscott HOWTO-Related Questions 0 11th January 2006 19:29
Expire date for Sites, Customers and Resellers Prompt Feature Requests 3 12th November 2005 02:47


All times are GMT +2. The time now is 04:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.