Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th February 2006, 20:02
eoij1 eoij1 is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default samba domain controller - ubuntu

Hi,

I have been following the HOWTO on setting up a SAMBA primary domain controller for Ubuntu on the howtoforge.com site and I am having a little trouble. I searched the forums and found somebody that had similar trouble and they said they resolved it, but I am unsure how. I am on page 5 of the tutorial where you type smbpasswd -a tom and after I enter the password for user tom i get this error:

tdb_update_sam: failing to store a SAM_ACCOUNT for [tom] without a primary group RID
Failed to add entry for user tom.
Failed to modify password entry for user tom.

I came across this page on the forums with similar trouble, http://www.howtoforge.com/forums/sho...ain+controller
but I dont know what the fix is for it. If anybody can shed some light on how or what I might be doing wrong I would really appreciate it.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 18th February 2006, 21:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,387
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

You will have to change the domain in smb.conf to be the same then the hostname that you entered during the Ubuntu setup. Then restart samba.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th October 2006, 11:43
yohann yohann is offline
Junior Member
 
Join Date: Oct 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello

i've the same problem, so i did change the net-bios name in smb.conf to have the same as in /etc/hostname
but i still have the problem, what can i do?

PS: thank you for the help, and sorry about my bad english

EDIT: it looks likie it come from the command useradd -m -G tom because if if create the new user from the ubuntu graphical interface, it works fine

Last edited by yohann; 5th October 2006 at 11:54.
Reply With Quote
  #4  
Old 6th October 2006, 14:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by yohann
EDIT: it looks likie it come from the command useradd -m -G tom because if if create the new user from the ubuntu graphical interface, it works fine
Do you see any differences in /etc/passwd for a new user when you create it from the shell and from the gui?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA domain controller / CUPS gradedcheese HOWTO-Related Questions 14 8th March 2006 09:21
SAMBA (Domaincontroller) Server For Small Workgroups With Ubuntu 5.10 Dagur Server Operation 15 16th February 2006 03:56
Is there a testing procedure for ISPConfig? deezone Installation/Configuration 14 22nd January 2006 19:41
Samba as domain controller alex Suggest HOWTO 13 12th December 2005 14:00
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 11:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.