Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th December 2008, 10:59
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sending mail to non local host(but the host is on same domain)

Hi all!

Ispconfig works great.....but sending mail to users in my own domain does not work since the mx for this particular host is remote but ispconfig keep adding it to /etc/postfix/local-host-names.

- my ispconfig server is ns.domain.se
- Dns is handled elsewhere, mx points to other server.
- i have checked "remote mailserver" for site ns.domain.se
and other sites/subdomains on this domain.

If i remove all domain.se related entries /etc/postfix/local-host-names
it works sending mail to domain.se but if i don't.... => "Recipient address rejected: User unknown in local recipient table;"

ispconfig keeps adding to /etc/postfix/local-host-names and it seems that
other mail failswhen removing some entries from the file.

in /etc/hosts: 127.0.0.1 localhost.localdomain localhost only

in /etc/postfix/local-host-names:

localhost
ns.domain.se (the site use external mail)
localhost.ns.domain.se
localhost.domain.se
localhost.localdomain
www.somedomain1.se (the site use internal mail)
www.somedomain2.se (the site use internal mail)
www.somedomain3.se (the site use internal mail)

Relaying from my own subnet is allowed through $mynetworks.

I must be missing something trivial no?

Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 5th December 2008, 11:02
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

forgot. i am running 2.2.23 on fc8
Reply With Quote
  #3  
Old 5th December 2008, 12:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Set mailserver to external in the settings of the website AND the co-domain in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Berry (19th December 2008)
  #4  
Old 9th December 2008, 13:44
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi! Double checked. No co-domains anywhere BUT i have several subdomains
such as

d1.domain.se
d2.domain.se
test.domain.se

etc.

They are all set to external mailserver.

Still in local-host-names
ns.domain.se appears. Granted it IS the name of this host and it is a host in the domain.se but mail should be handled elsewhere.

The other subdmomains of this domain does not appear in local-host-names so i guess that works. It seems it appears just because it is the actual hostname of this ispconfig server. i.e
"# hostname"
gives
"ns.domain.se"

More to check?
Thanks!
Reply With Quote
  #5  
Old 10th December 2008, 13:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by olasamuelson View Post
The other subdmomains of this domain does not appear in local-host-names so i guess that works. It seems it appears just because it is the actual hostname of this ispconfig server. i.e
"# hostname"
gives
"ns.domain.se"
That is the problem. You should use another domain for the hostname, a domain that you don't use for web sites and emails.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 10th December 2008, 14:07
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Too bad. It is a perfectly logical setup.

No way to configure postfix to force all mails for domain.se to external mail regardless of everything else?

Thanks.
Reply With Quote
  #7  
Old 10th December 2008, 23:13
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

It's possible if you fiddle with external mailserver settings for all your co-domains and the actual site.
__________________
http://www.xh.se
Reply With Quote
  #8  
Old 11th December 2008, 06:03
patrick3853 patrick3853 is offline
Member
 
Join Date: Dec 2008
Posts: 30
Thanks: 3
Thanked 7 Times in 3 Posts
Default

I am having the same problem. I tried setting the mailserver to external (co-domains as well), but then I get Relay Access Denied when I try to send an email to any domain hosted at our server. Is there not any way to keep ISPConfig from writing certain domains to the local-host-names file?

Last edited by patrick3853; 11th December 2008 at 06:27.
Reply With Quote
  #9  
Old 11th December 2008, 10:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
Is there not any way to keep ISPConfig from writing certain domains to the local-host-names file?
Yes, set them to external mailserver Thats why this funtion exists.

But what you missed most likely is to enable smtp authentication in your email client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 11th December 2008, 11:02
olasamuelson olasamuelson is offline
Junior Member
 
Join Date: Aug 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

well as i know now that only works if your actual server hostname is NOT in the same domain as the external mailserver. Because if it is...it will turn up in local-host-names no matter what. sorry. could be fixed by either changing hostname or configuring postfix manually...i don't know enough to do the latter. ideas?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12
SMTP relay trouble DVS General 3 11th June 2007 09:56
internal domain error with mail matehortua Installation/Configuration 5 16th October 2005 18:31
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 03:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.