#1  
Old 19th February 2006, 05:34
isaac_golding isaac_golding is offline
Junior Member
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default compile crashes with TK errors?

IPSconfig seems to be crashing with tk errors?

"make[1]: Entering directory `/usr/local/src/install_ispconfig/compile_aps/uudeview-0.5.20/tcl'
gcc -c -g -O2 -I. -I/usr/include -I/usr/X11R6/include -I/usr/include -DHAVE_CONFIG_H -I../uulib uuwish.c
In file included from uuwish.c:33:
/usr/include/tk.h:96:23: X11/Xlib.h: No such file or directory
In file included from uuwish.c:33:"

The ENTIRE compile log is attached in zip format.
Attached Files
File Type: zip ISPConfig-log.zip (94.1 KB, 251 views)
Reply With Quote
Sponsored Links
  #2  
Old 19th February 2006, 07:03
isaac_golding isaac_golding is offline
Junior Member
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default update

I thought this error might be caused by the zlib.h file that the program reports its unable to find and I've installed the corresponding mandrake 10.2 libs that contain zlib.h

& I also installed the zlib library as mentioned in another thread.

At this point I now have zlib.h all over the place

[isaac@deepscout ~]$ locate zlib.h
/usr/include/linux/zlib.h
/usr/include/zlib.h
/usr/local/include/zlib.h
/usr/local/src/zlib-1.2.3/old/zlib.html
/usr/local/src/zlib-1.2.3/zlib.h
[isaac@deepscout ~]$

as of yet I've still not solved this riddle...


UPDATE:

I traced the errors down to the program uudview by trial and error and after reading for a while I discovered that uudview has a tcl/tk based front end... I'm running a headless servver so I went into the compile-apps directory and added the proper switch to uudview's configure line

./configure --prefix=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/uudeview --disable-tcl ||

and this appears to have fixed this problem...now to see how the rest of the setup goes...

Last edited by isaac_golding; 19th February 2006 at 07:47. Reason: UPDATE
Reply With Quote
  #3  
Old 19th February 2006, 08:05
isaac_golding isaac_golding is offline
Junior Member
 
Join Date: Feb 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default continued error

SO I worked through uudview and trhen started over

and now I get this
done
for d in uudeview.1 uuenview.1 ; do \
./install-sh -c -m 644 ./man/$d /home/admispconfig/ispconfig/tools/uudeview/man/man1/$d ; \
done
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/lib/config.inc.php': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/users': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/adminmail.txt': No such file or directory
All prerequisites are fulfilled.
Here we go...


Warning: main(config.inc.php): failed to open stream: No such file or directory in /usr/local/src/install_ispconfig/install.php on line 639

Warning: main(): Failed opening 'config.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /usr/local/src/install_ispconfig/install.php on line 639

Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /usr/local/src/install_ispconfig/install.php on line 649
Could not connect to db
Restarting some services...
Shutting down httpd2: [ OK ]
Starting httpd2: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
./setup2: line 974: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@deepscout install_ispconfig]#
Reply With Quote
  #4  
Old 19th February 2006, 10:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
 
Default

You have to remove the directorys: /home/admispconfig, /root/ispconfig, install_ispconfig after each setup attempt and unpack the installer again.

Also check if there is a directory with the name you chose for the mysql database in ISPCOnfig in /var/lib/mysql. If the directory is there, delete it too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Several errors and ideas for features jmroth Feature Requests 16 6th March 2006 06:39
Segmentation fualt error during compile kird03 Installation/Configuration 17 6th January 2006 11:29
PHP Errors in the "WEB-FTP" module crudolphy General 9 27th December 2005 21:17
FC3 Perfect Installation Make Errors solderboy HOWTO-Related Questions 3 2nd October 2005 17:55
Perfect Fedora Core 4 install (GPG key errors) linuxfast HOWTO-Related Questions 2 16th September 2005 20:54


All times are GMT +2. The time now is 08:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.