Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 23rd February 2011, 14:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by anubix View Post
so my stats dont work.
i updated the stats password via ispconfig 3 control panel:
the login is set at 'admin' and i used the correct password i set there also.

in the monitor module i get this for the ispconfig cron log

sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found
sh: repquota: command not found ...


when i go to domain.com/stats
and log in, i get a ERROR 403 - Forbidden!

root@***:~# webalizer
Webalizer V2.01-10 (Linux 2.6.32.16-linode28) locale: C
Using logfile /var/log/apache2/access.log.1 (clf)
Using default GeoIP database
Error Opening file /usr/share/GeoIP/GeoIP.dat

there is a .htaccess file in the web directory, but thats it.
Please post this in the ISPConfig 3 forum!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #32  
Old 23rd February 2011, 14:23
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Hi Falko, any idea for my problem?
Reply With Quote
  #33  
Old 23rd February 2011, 17:53
anubix anubix is offline
Member
 
Join Date: Aug 2008
Posts: 32
Thanks: 1
Thanked 0 Times in 0 Posts
Default posted in ispconfig 3 forum

sorry falko i now reposted in the correct forum, thanks.
Reply With Quote
  #34  
Old 24th February 2011, 09:33
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Unhappy

Dont know what else I can do. Can anyone help?
Reply With Quote
  #35  
Old 24th February 2011, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by esezako View Post
For any reason various websites not execute the webalizer.

If execute manually the webalizer work perfectly:


Code:
webalizer -n www.mydomain.info -s www.mydomain.info -r www.mydomain.info -q -T -o /home/www/www.mydomain.info/web/webalizer -c /root/ispconfig/scripts/shell/webalizer.conf /home/www/www.mydomain.info/log/web.log

Why webalizer.php exclude various websites?
So it works if you run it manually? Stats are created then?

Do you see any error messages when you run it manually?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #36  
Old 24th February 2011, 16:42
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Quote:
So it works if you run it manually? Stats are created then?
yes

Quote:
Do you see any error messages when you run it manually?
No errors
Reply With Quote
  #37  
Old 25th February 2011, 13:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's the output of
Code:
crontab -l
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #38  
Old 25th February 2011, 13:55
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Code:
30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
30 3 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php &> /dev/null
Reply With Quote
  #39  
Old 25th February 2011, 19:12
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Code:
30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
30 3 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php &> /dev/null
Reply With Quote
  #40  
Old 26th February 2011, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Looks ok. My guess is that for some reason, cron uses a wrong PATH and therefore cannot find webalizer.

Can you add this as the first line to your crontab (by running
Code:
crontab -e
)?

Code:
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HTTPS not working palkat Installation/Configuration 13 14th May 2007 17:19
Webconfig at port 81 not working anymore maxx Installation/Configuration 6 23rd October 2006 10:23
Sending mails to remote domains is not working. nandhu HOWTO-Related Questions 17 20th February 2006 20:27
UebiMiau stopped working after Apache reinstall shajazzi Installation/Configuration 6 18th February 2006 19:42
Internet/lan-only lan working Nejko Installation/Configuration 39 19th January 2006 15:32


All times are GMT +2. The time now is 00:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.