Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th December 2007, 00:04
rabrol rabrol is offline
Junior Member
 
Join Date: Sep 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default mod_rewrite & Silverstripe

I am in the process of installing Silverstripe CMS. Unfortunately I am running into trouble with mod_rewrite.

I get the following message :
# Creating 'mysite/_config.php'...
# Creating '.htaccess' file...
# Building database schema...
# Checking mod_rewrite works
# ERROR: mod_rewrite not working, redirecting to mod_rewrite test page

The mod_rewrite test page shows that it is enabled. Is there something I need to do to enable mod_rewrite on a per domain basis?

Rob
Reply With Quote
Sponsored Links
  #2  
Old 28th December 2007, 22:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Which distribution are you using? What's in the .htaccess file?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th December 2007, 19:33
rabrol rabrol is offline
Junior Member
 
Join Date: Sep 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Which distribution are you using? What's in the .htaccess file?
I'm on Ubuntu 6.06LTS.

When the Silverstripe CMS begins its install, it writes a new .htaccess file. This is all it creates (its no wonder the mod_rewrite doesn't work!).

### SILVERSTRIPE START ###

### SILVERSTRIPE END ###

That is the full content of .htaccess. I wrote another .htaccess myself which was copied from another Silverstripe user, but when the install process was started it was overwritten with this file.

Does ISPConfig support mod_rewrite on all sites by default?
Thanks,
Rob
Reply With Quote
  #4  
Old 30th December 2007, 17:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please try this:
Code:
a2enmod rewrite
/etc/init.d/apache2 force-reload
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 1st January 2008, 19:30
rabrol rabrol is offline
Junior Member
 
Join Date: Sep 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please try this:
Code:
a2enmod rewrite
/etc/init.d/apache2 force-reload
This is what I got when I entered a2enmod rewrite
"This module is already enabled!"

I did the forced reload anyway, but no change.
Reply With Quote
  #6  
Old 1st January 2008, 23:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by rabrol
I wrote another .htaccess myself which was copied from another Silverstripe user, but when the install process was started it was overwritten with this file.
Can you overwrite the .htaccess file with your own version after the Silverstripe installation?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th August 2008, 18:11
DruKe DruKe is offline
Junior Member
 
Join Date: Nov 2007
Posts: 25
Thanks: 3
Thanked 4 Times in 4 Posts
 
Cool

For anyone else looking to get a SilverStripe site going under ISPConfig you'll need this in the directives box:

<Directory "/path/to/site/web">
options followsymlinks MultiViews Includes ExecCGI
AllowOverride All
order allow,deny
Allow from all
</Directory>

In my installation on a SLES 10 SP1 box, it 'bombs' out on the rewrite test but I forced it to continue and it works fine anyway.
Reply With Quote
The Following User Says Thank You to DruKe For This Useful Post:
necromncr (13th November 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.