Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th August 2008, 23:32
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache will not load if SSL is enabled

I have a fresh install of ISPconfig on CentOS 4
I install an SSL certificate for my site and I went to restart apache. Apache will not start if I have the SSL enabled for the site.
Here is the output from the error log:

Code:
[Fri Aug 08 11:29:04 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:09 2008] [notice] caught SIGTERM, shutting down
[Fri Aug 08 11:29:10 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 08 11:29:10 2008] [notice] Digest: generating secret for digest authentication ...
[Fri Aug 08 11:29:10 2008] [notice] Digest: done
[Fri Aug 08 11:29:10 2008] [notice] Apache/2.0.52 (CentOS) configured -- resuming normal operations
[Fri Aug 08 11:29:15 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:15 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:20 2008] [notice] SIGHUP received.  Attempting to restart
[Fri Aug 08 11:29:20 2008] [notice] Digest: generating secret for digest authentication ...
[Fri Aug 08 11:29:20 2008] [notice] Digest: done
[Fri Aug 08 11:29:22 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 08 11:29:23 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 08 11:29:42 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 08 11:29:43 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 08 11:29:43 2008] [notice] Digest: generating secret for digest authentication ...
[Fri Aug 08 11:29:43 2008] [notice] Digest: done
[Fri Aug 08 11:29:44 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:44 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:44 2008] [notice] Apache/2.0.52 (CentOS) configured -- resuming normal operations
[Fri Aug 08 11:29:45 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:45 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:46 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:46 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:48 2008] [error] an unknown filter was not added: PHP
[Fri Aug 08 11:29:48 2008] [error] an unknown filter was not added: PHP
Reply With Quote
Sponsored Links
  #2  
Old 9th August 2008, 12:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Quote:
[Fri Aug 08 11:29:45 2008] [error] an unknown filter was not added: PHP
Take a look here: http://www.howtoforge.com/forums/sho...che2_php%22%5D

Are there any errors in the SSL error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th August 2008, 00:07
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you That did it.

I still seem to be having an issue with the certificate though. If I try to go to https://mydomain.com, I get a invalid security certificate warning.

I went through the install process several times in ISPconfig,but it doesn't seem to make a difference. It seems to be pulling the self-signed certificate, not the one I bought from Godaddy. How to I change the server config so that the IP is not shared and so it will use the specific certificate?
Reply With Quote
  #4  
Old 11th August 2008, 03:59
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I spoke too soon.

Code:
$go_info["server"]["apache2_php"] = 'both';

to:

$go_info["server"]["apache2_php"] = 'addtype';
Worked for a while, but I had to restart apache after changing my php.ini file and now my site won't load if I check SSL.

I rechecked the config.inc.php file and it hasn't changed.

Is there any hope for ISPconfig supporting SSL? I really like it but I need SSL support.
Reply With Quote
  #5  
Old 11th August 2008, 10:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Is there any hope for ISPconfig supporting SSL?
What a question ISPConfig supports SSL, otherwise there were not the SSL checkboxes.

Please post the exact error messages that you get in the error log of the website when you turn on SSL.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 11th August 2008, 19:45
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess I should have said "MY" install of IspConfig

Which error log, the httpd error log?

Last edited by cephlon; 11th August 2008 at 19:56.
Reply With Quote
  #7  
Old 11th August 2008, 23:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Yes, please look in the gloabl apache error log and in the error log of the website which is inside of the log directory in the website root.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 12th August 2008, 01:51
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I figured out from the log why the site wouldn't come up with ssl enabled. There was a private key mismatch error, so I deleted the certificate.

I redid the entire SSL process outlined here: http://www.ispconfig.org/downloads/m..._src.htm#4_2_4

But I still get:
Secure Connection Failed

www.alohabroadband.com uses an invalid security certificate.

The certificate is not trusted because it is self signed.

(Error code: sec_error_ca_cert_invalid)

In Firefox, when I click to add exception and view the certificate, it is not the one I installed from GoDaddy. Is it pulling the certificate from a different place? The cert in my /ssl directory matches exactly the cert from Godaddy.
Hmm... any help is appreciated.
Reply With Quote
  #9  
Old 12th August 2008, 18:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Did you install the cert as described here? http://www.howtoforge.com/faq/14_49_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 12th August 2008, 20:44
cephlon cephlon is offline
Junior Member
 
Join Date: Aug 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Did you install the cert as described here? http://www.howtoforge.com/faq/14_49_en.html
That link says the exact same thing as the link I posted above.
http://www.ispconfig.org/downloads/m..._src.htm#4_2_4
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL "connection interrupted" apache not listening on 443 yuro Installation/Configuration 10 28th October 2008 14:42
The classic MySQL connect error swggy Installation/Configuration 13 10th April 2008 21:45
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 20:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.