Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2006, 23:14
ollu ollu is offline
Junior Member
 
Join Date: Feb 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default make fails to run (cache.c:336/340)

When I try to run the make command I get the following errors:

cache.c:336: error: invalid lvalue in assignment
cache.c:340: error: invalid lvalue in assignment

I've attached the complete output file.

thanks in advance!
Attached Files
File Type: txt make_errors.txt (3.0 KB, 504 views)
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2006, 09:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please try to install MyDNS version 1.1.0 instead of 1.0.0.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th February 2006, 10:50
ollu ollu is offline
Junior Member
 
Join Date: Feb 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, now the installation worked. Thanks!

I'm curious though, when I first started mydns it hanged, that is I didn't get back my promt. What's up eith the group/user nobody? This is my output:

root@bowie:/etc/init.d# mydns start
mydns: Extraneous command-line arguments ignored
mydns[5012]: error loading gid for group `nobody'
mydns[5012]: using gid 65534 from user `nobody'
mydns[5012]: mydns 1.1.0 started Tue Feb 14 10:28:29 2006 (listening on 3 addresses)
mydns[5012]: bowie up 2m20s (140s) 0 questions (0/s) NOERROR=0 SERVFAIL=0 NXDOMAIN=0 NOTIMP=0 REFUSED=0
mydns[5012]: interrupted
root@bowie:/etc/init.d# cd /
root@bowie:/# /etc/init.d/mydns stop
Stopping DNS server: mydns.
root@bowie:/# /etc/init.d/mydns start
Starting DNS server: mydnsmydns[5052]: error loading gid for group `nobody'
mydns[5052]: using gid 65534 from user `nobody'
.
root@bowie:/#


I'll continue the rest of the howto tonight. Thanks for your active interest!!
Reply With Quote
  #4  
Old 14th February 2006, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,006
Thanks: 826
Thanked 5,377 Times in 4,224 Posts
Default

Maybe you dont have a group nobody, on some linux systems the group is named nogroup instead.

I think it is ok that MyDNS uses the group of the nobody user instead, so dont worry
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th February 2006, 11:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by ollu
mydns[5012]: error loading gid for group `nobody'
mydns[5012]: using gid 65534 from user `nobody'
You must change the group in /etc/mydns.conf:

Code:
group = nogroup
This is described on page 1 of the MyDNS tutorial: http://www.howtoforge.com/mydns_name_server
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cpan> install DB_File make error Nu2Linux HOWTO-Related Questions 6 13th April 2012 22:06
Can't find 'make' on new Ubuntu install Arachne Kernel Questions 10 10th August 2006 21:32
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Could not make PHP Error... tohidetheworld Installation/Configuration 2 19th November 2005 00:51
FC3 Perfect Installation Make Errors solderboy HOWTO-Related Questions 3 2nd October 2005 16:55


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.