#1  
Old 2nd August 2008, 22:44
CubAfull CubAfull is offline
Junior Member
 
Join Date: Jun 2008
Location: Cuba
Posts: 24
Thanks: 11
Thanked 3 Times in 2 Posts
Default Protect directory BUG .htpasswd

After creating a protected directory in ISPConfig 2.2.24 Web-FTP to enter my joomla administration I get an 500 Error after login to the .htaccess window.

in my /var/www/web1/log/error.log i found...

Code:
[Sat Aug 02 15:50:57 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
[Sat Aug 02 15:51:08 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
[Sat Aug 02 15:51:18 2008] [error] [client xxx.xxx.xxx.xxx] (2)No such file or directory: Could not open password file: /var/www/web1/administrator/.htpasswd
The problem is that the script does not include the web directory in .htaccess

After replacing manually in .htaccess
Code:
AuthUserFile /var/www/web1/administrator/.htpasswd

to

AuthUserFile /var/www/web1/web/administrator/.htpasswd
everything worked perfectly
__________________
-------------
>> CUBA <<

-------------
Reply With Quote
Sponsored Links
  #2  
Old 3rd August 2008, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

We will check this.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th August 2008, 06:22
CubAfull CubAfull is offline
Junior Member
 
Join Date: Jun 2008
Location: Cuba
Posts: 24
Thanks: 11
Thanked 3 Times in 2 Posts
Default

Thanks falko

Maybe this happens when you change the default FTP directory ?. I changed mine to
Code:
DefaultRoot ~/web
__________________
-------------
>> CUBA <<

-------------

Last edited by CubAfull; 4th August 2008 at 06:44.
Reply With Quote
  #4  
Old 4th August 2008, 10:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

In your proftpd.conf? No, this doesn't have any effect on ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
update failed loge Installation/Configuration 6 1st December 2007 17:53
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 19:37
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.