Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd August 2008, 14:44
AlfredNoob AlfredNoob is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default VMware Won't Start On Ubuntu Hardy

Hello....i followed falko's guide on "How to install vmware server (version 1.0.6) on an ubuntu 8.04 desktop" and run the code:
sudo ln -sf /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1

i can see the "vmware console" in "system tools" but when i click on it, it won't start???????

how can i remedy this?

(p.s. when i installed vmware i was never asked about the 20-digit registration number and "inetd" nor "xinetd" can't be found in my kernel...are these the reasons why vmware console won't start?)
Reply With Quote
Sponsored Links
  #2  
Old 3rd August 2008, 13:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please run
Code:
vmware
in a terminal. Do you get any errors?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th August 2008, 13:46
AlfredNoob AlfredNoob is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi Falko i'm sorry it took me a while to reply....

when i invoke "vmware" in terminal i get the message that

"vmware is installed but not properly configured" so i run the /usr/bin/vmware-config.pl.

however, i always end-up with,
"Unable to find any instance of the super-server "inetd" or "xinetd". It is
possible that you do not have one of these packages installed on this machine.
Please install "inetd" or "xinetd".

If you do have "inetd" or "xinetd" installed, make sure that /etc/inetd.conf or
/etc/xinetd.d exists."

i am quite sure that inetd daemon is in my system but i cannot understand why it cannot be detected by the installer....

pls. point me to the right direction.....
Reply With Quote
  #4  
Old 5th August 2008, 15:01
AlfredNoob AlfredNoob is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi again!

i've finally solved it!

it seems that vmware only runs if the daemon installed is xinetd not inetd.

after i installed xinetd with the command,
sudo apt-get install linux-headers- `uname -r` build-essential xinetd
everything went on smoothly...

in fact, i have attached a screenshot of my desktop showing the vmware console with windowz xp as guest OS....

thanks for the very nice how to's of Mr. Falko Timme.....you may not know it but you surely are helping a lot of people out there.....

oh yeah, before i forget....does anyone know how i could remedy a problem wherein everytime my vmware console iis running with a guest OS, my keyboards become unusable in my desktop...

everytime a key is pressed in my keyboard, any application that is open in my desktop suddenly closes....

is this a bug in vmware running in ubuntu as host?
Attached Images
 
Reply With Quote
  #5  
Old 5th August 2008, 15:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by AlfredNoob View Post
oh yeah, before i forget....does anyone know how i could remedy a problem wherein everytime my vmware console iis running with a guest OS, my keyboards become unusable in my desktop...

everytime a key is pressed in my keyboard, any application that is open in my desktop suddenly closes....

is this a bug in vmware running in ubuntu as host?
Not sure if this helps, but you could install VMware Tools.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 5th August 2008, 16:02
AlfredNoob AlfredNoob is offline
Junior Member
 
Join Date: Aug 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Not sure if this helps, but you could install VMware Tools.
thanks again mr. falko for that prompt reply....actually now i just resolved it by adjusting it in 'edit' tab and then 'preferences' and then 'input' tab, selecting 'grab mouse and keyboard on input by key press' will do the trick....


long live open source............

thanks mr. falko........
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VMware, LTSP and Ubuntu 8.04 bobwdn HOWTO-Related Questions 2 20th August 2008 00:50
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 21:58
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01
VMWare Server Howto and Ubuntu Questions crudolphy HOWTO-Related Questions 11 25th July 2006 20:11


All times are GMT +2. The time now is 04:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.