Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st July 2008, 13:25
schmidtedv schmidtedv is offline
Senior Member
 
Join Date: Jun 2006
Location: Germany, Kaarst
Posts: 152
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via MSN to schmidtedv Send a message via Skype™ to schmidtedv
Default Standardcoding utf-8 with a fresh install?

I put back on my forum (phpbb) after server-install and with
Code:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
in header I suppose it should show up correct right away. ISPConfig (php or apache with perfect debian etch setup) shows this coded as utf-8 in browser, so umlauts are not readable anymore...

Any idea where to look or what to change to get it show up the right way? Just put generally iso-8859-1 into apache and php-config can not be the usual/right way i guess.

EDIT: Probably found it.../etc/apache2/conf.d/charset tells apache to use "AddDefaultCharset UTF-8" and this overrides my meta for the phpbb-forum. Is there a special reason for this charset-conf so that i just can change it into iso-8859-1 or is just my forum-header not working the right way...even with default-charset, the browser should notice the header...or not????

Last edited by schmidtedv; 31st July 2008 at 13:33.
Reply With Quote
Sponsored Links
  #2  
Old 1st August 2008, 12:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

You can change the charset to iso-8859-1, utf-8 is just the debian default.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st August 2008, 15:16
schmidtedv schmidtedv is offline
Senior Member
 
Join Date: Jun 2006
Location: Germany, Kaarst
Posts: 152
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via MSN to schmidtedv Send a message via Skype™ to schmidtedv
 
Default

...i thought something like this, however it would probably a nicer way to leave it empty...i wonder why myforum does show up wrong although it has an iso metatag in the header....maybe the debian default cannot be overwritten manually in php as it should like in normal html-files (do i need another php mod for this that it checks header of files?)?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 5.2 Install line 888 fresh install webcave Installation/Configuration 10 6th August 2008 22:29
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 11:46
ubuntu 7.04 fresh install. mrwasabi Installation/Configuration 3 6th June 2007 17:02
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 17:14
Fresh Install of FC4 using Perfect Install HowTo latcarf HOWTO-Related Questions 21 10th August 2005 23:55


All times are GMT +2. The time now is 15:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.