#1  
Old 31st July 2008, 00:00
juliyana juliyana is offline
Junior Member
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default SASL and PAM

Hello,

I am using SASL and PAM on Redhat 5.0. I saw your posting on the net. But every time I run testsaslauthd I get the following error
Jul 30 13:59:13 vernal saslauthd[5379]: do_auth : auth failure: [user=test1] [service=smtp] [realm=] [mech=pam] [reason=PAM auth error]
Please help.

My /etc/pam.d/smtp
#%PAM-1.0
auth required /lib/security/pam_stack.so service=system-auth
account required /lib/security/pam_stack.so service=system-auth
session required /lib/security/pam_stack.so service=system-auth
auth required /lib/security/pam_afs.so
account required /lib/security/pam_afs.so
session required /lib/security/pam_afs.so


Thx Juliyana
Reply With Quote
Sponsored Links
  #2  
Old 31st July 2008, 18:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

How did you set up your email accounts? Which email server (Postfix/Sendmail/...) are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st July 2008, 19:23
juliyana juliyana is offline
Junior Member
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default SASL and PAM

Hi,
We have sendmail running on this server only as a relay server.

Juliyana
Reply With Quote
  #4  
Old 1st August 2008, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's the output of
Code:
updatedb
locate smtpd.conf
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 1st August 2008, 22:15
juliyana juliyana is offline
Junior Member
 
Join Date: Jul 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default PLEASE HELP with SASL and PAM

Hi falko,

my /etc/pam.d/smtp looks like this

#%PAM-1.0
auth required /lib/security/pam_afs.so
account required /lib/security/pam_afs.so

But when I run testsaslauthd,I still get the following error.
auth failure: [user=test1] [service=smtp] [realm=] [mech=pam] [reason=PAM auth error]

Thanks for all your help.
Juliyana
Reply With Quote
  #6  
Old 2nd August 2008, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Is there no smptd.conf on your server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
smtpd, SASL authentication failure: Steve_P Installation/Configuration 4 6th February 2009 16:26
SASL - SMTP Auth - authdaemond - Berkeley db /etc/sasldb2 nightmare digumo Server Operation 0 24th November 2007 20:36
Postfix & SASL GreXXL HOWTO-Related Questions 3 13th October 2007 14:39
smtp auth w/ sasl. marsvin HOWTO-Related Questions 6 19th September 2007 22:45
Ubuntu 7.04 + SASL Auth + MySQL nablaodel HOWTO-Related Questions 2 19th June 2007 19:55


All times are GMT +2. The time now is 01:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.