Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th July 2008, 10:03
pg001 pg001 is offline
Member
 
Join Date: Jan 2008
Posts: 67
Thanks: 8
Thanked 2 Times in 1 Post
Default DKIM With dkim-milter & Domainkeys In Postfix Using dk-milter

Iam running Cento 5.2 perfect server with ISPConfig, with Domainkeys In Postfix Using dk-milter. Everything is running well and perfect, the emails are being signed, thanks for the howto's. I'm just wondering though, can I also implement Postfix DKIM With dkim-milter?

I want to know if it is possible to implement them both and what adjustments I would need to do. Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 29th July 2008, 13:52
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

You can do both, there are tutorials on doing both here on howtoforge
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 29th July 2008, 16:28
pg001 pg001 is offline
Member
 
Join Date: Jan 2008
Posts: 67
Thanks: 8
Thanked 2 Times in 1 Post
Default

wow! that's cool, thanks. can you please point me to a link where I could find it?
Reply With Quote
  #4  
Old 30th July 2008, 10:13
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

http://www.howtoforge.com/postfix-dk...lter-centos5.1
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
pg001 (30th July 2008)
  #5  
Old 30th July 2008, 12:06
pg001 pg001 is offline
Member
 
Join Date: Jan 2008
Posts: 67
Thanks: 8
Thanked 2 Times in 1 Post
Default

I followed the how to and I got no errors until on the "Configure Postfix " section I got stucked, here are my concerns:

1. "Append to the existing milters if you have other milters already configured. " -how do I exactly do this?

2. Since I did not know what to do, I added the this code:
Code:
smtpd_milters = unix:/var/run/dkim-milter/dkim.sock
non_smtpd_milters = unix:/var/run/dkim-milter/dkim.sock
to the bottom of /etc/postfix/main.cf file. Is this the right way to do it?

3. When I did #2 and started dkim-milter I got this error:
Code:
Starting DKIM milter (dkim-filter #0): dkim-filter: smfi_opensocket() failed
                                                           [FAILED]
thanks in advance... sorry for the bugging, I'm just a linux newbie trying to learn how to setup good email delivery.
Reply With Quote
  #6  
Old 30th July 2008, 12:09
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

1. Append means add to what is already there.
3. Check the permissions on the socket file.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 30th July 2008, 12:19
pg001 pg001 is offline
Member
 
Join Date: Jan 2008
Posts: 67
Thanks: 8
Thanked 2 Times in 1 Post
Default

this is what I get:

Code:
[root@server1 /]# ls -la /var/run/dkim-milter/dkim.sock
srwxrwx--- 1 dkim-milt mail 0 Jul 30 17:20 /var/run/dkim-milter/dkim.sock
is it correct?
Reply With Quote
  #8  
Old 30th July 2008, 12:22
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Try restarting the dkim-milter and see if u get the error again are you running with selinux enabled ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #9  
Old 30th July 2008, 12:44
pg001 pg001 is offline
Member
 
Join Date: Jan 2008
Posts: 67
Thanks: 8
Thanked 2 Times in 1 Post
Default

the restart did the trick! No I did not have selinux enabled, it was disabled from the start. Here's the restart result:
Code:
[root@server1 /]# service dkim-milter restart
Shutting down all DKIM milter (dkim-filter):               [  OK  ]
Cleanup for DKIM milter (dkim-filter #0):
Starting DKIM milter (dkim-filter #0):                     [  OK  ]
I tried sending email to my gmail account but I don't see "Signed by: ..." on the headers, here's how my headers look,



it does not look the same with what's on the howto.

plus when I send email to yahoo I get this errorr on my mail que
Code:
postqueue -p
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
E7DFB78C4BB      812 Wed Jul 30 18:34:42  web1_user@oneXXXXXs.us
(host b.mx.mail.yahoo.com[66.196.97.250] refused to talk to me: 421 Message from (xxx.92.28.183) temporarily deferred - 4.16.50. Please refer to http://help.yahoo.com/help/us/mail/defer/defer-06.html)
                                         xxxxxx@yahoo.com

Last edited by pg001; 30th July 2008 at 12:49.
Reply With Quote
  #10  
Old 30th July 2008, 12:54
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

May be the signing is not taking place look at the original message in gmail and see the headers

To do that click the arror on the reply button.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner,Mailwatch CentOS 5.2 tecstream HOWTO-Related Questions 3 16th July 2008 22:10
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 10:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.