Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th February 2006, 10:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by PsiTrax
no i didnt :\
a fresh clean install without any changes

the only thing that was not done as described in the howto,
i compiled a new 2.6er kernel and mysql 5, php 5.1.2 but ISPconf comes with its own apache so it could be a problem right?
It doesn't matter how you compile your main Apache. The Apache coming with ISPConfig is running on port 81 and therefore totally independent from your main Apache - it serves just the ISPConfig web interface.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 17th February 2006, 12:25
PsiTrax PsiTrax is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i know ...

but now im knowing a little bit more
the bug is anywhere in serializing the go_info array

In the SessionTbl the datas ends with:
Code:
...k";s:11:"doubleField";s:12:"W
but s:12 stands for String with 12 Chars
thiswhile the unserialisation fails and the $go_info array is empty

but i dont know why the serialisation fails
Reply With Quote
  #13  
Old 17th February 2006, 15:59
PsiTrax PsiTrax is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Haaaa i got it!

It was caused by different Character Sets php<->mysql
MySQL cuts the Serialized string at special chars ("Whrung")

Ive added in the ispconfig_db_mysql.lib.php
PHP Code:
mysql_query("SET character_set_client = 'latin1'");
mysql_query("SET character_set_results = latin1");
mysql_query("SET character_set_connection = utf8"); 
after the mysql_connect to tell mysqld the right character sets and now ... its running like a charm
Reply With Quote
  #14  
Old 30th March 2006, 14:36
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

I'm having the same issue here. I changed mysql to utf-8 from latin1, and now ispconfig is quite dead. I checked some of the tables, and there are some strange characters in them. What should I do? I messed it up badly I guess...
Reply With Quote
  #15  
Old 30th March 2006, 14:48
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

I'm getting this errors:

Code:
Warning: include(/go_info.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 220

Warning: include() [function.include]: Failed opening '/go_info.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 220

Warning: include(/web//lib/module.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 241

Warning: include() [function.include]: Failed opening '/web//lib/module.inc.php' for inclusion (include_path='.:') in /home/admispconfig/ispconfig/lib/session.inc.php on line 241
I tried uploading an sql dump I had from yesterday, and the strange characters are gone... but still ispconfig is dead.

EDIT: Is utf-8 not supported?

Last edited by danf.1979; 30th March 2006 at 15:13.
Reply With Quote
  #16  
Old 30th March 2006, 15:24
PsiTrax PsiTrax is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

how do you import the sql dump?
with phpmyadmin or with mysql cmdline tool?

if you use the cmdline tool you have to set the character set to latin1.

and remember, if you set the values in my.cnf - the root account of mysqld DON'T use it cause he have the "super" flag.
Reply With Quote
  #17  
Old 30th March 2006, 15:47
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

I imported it from SQL option in phpmyadmin. It's working now. I added the lines you proposed in the constructor:

Code:
                // constructor

                function db_mysql()

                {



                        global $go_info;

                        $this->dbHost = $go_info["server"]["db_host"];

                        $this->dbName = $go_info["server"]["db_name"];

                        $this->dbUser = $go_info["server"]["db_user"];

                        $this->dbPass = $go_info["server"]["db_password"];

                        $this->connect();
			mysql_query("SET character_set_client = 'latin1'");
			mysql_query("SET character_set_results = latin1");
			mysql_query("SET character_set_connection = utf8"); 
                }
It works ok...
Reply With Quote
  #18  
Old 6th May 2006, 09:28
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 416
Thanks: 13
Thanked 5 Times in 5 Posts
Default

same issue here:
(after changing character set to utf-8; strange enough it was not happening on FedoraCore4, it's happening on Debian Sarge, probably because older version of MySql used in default instalation of Debian Sarge)

Warning: include(/go_info.inc.php) [function.include]: failed to open stream: No such file or directory in /home/admispconfig/ispconfig/lib/session.inc.php on line 220

@PsiTrax

Where did you exactly added those lines?
In
/home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php

or

/root/ispconfig/scripts/lib/classes/ispconfig_db_mysql.lib.php

and exactly where in ispconfig_db_mysql.lib.php file?
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
  #19  
Old 6th May 2006, 09:48
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 416
Thanks: 13
Thanked 5 Times in 5 Posts
Default

I changed in both files and it works now.

I really think that "Pefect Debian Install" should include mysql 4.1 (as many programs needs various character set encoding) as well as this hack to enable different character set encoding
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
  #20  
Old 7th January 2008, 14:14
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default same probleme here

i have the same problem on 1 of my older servers running on debian sarge. Just for the record - the workaround described above doesnt work for me!

Regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 17:05
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 17:14
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 19:07
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 11:50
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 5th October 2005 00:53


All times are GMT +2. The time now is 22:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.