Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th July 2008, 21:13
physdude physdude is offline
Junior Member
 
Join Date: Jul 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Question Encrypted root volume - possible goof up on my part!

I went through most of the instructions on the encrypted root volume howto as I wanted to add a physical volume to my volume group and also ultimately extend my root logical volume (by booting into the live-cd so that the root filesystem is not mounted). While following the encrypted-lvm-howto, I was editing the /etc/initramfs-tools/conf.d/cryptroot file and I ended up first copying the original cryptroot by mistake and then appending the line I wanted rather than just including the line I wanted to add. Well, the upshot is that I have a cryptroot on the initramfs which duplicates the original cryptroot twice and adds the new line. IOW, the new cryptroot is this (/dev/sdc1 is the new encrypted partition):

target=sda5_crypt,source=/dev/disk/by-uuid/3fb738d0-e025-4280-a045-bc5d48272605,key=none
target=sdb1_crypt,source=/dev/disk/by-uuid/84d75f76-0204-494e-806a-cda376ead5ae,key=none,lvm=UUID=35cdabba-23d7-4872-b4a3-6dbfa6901d8c
target=sda5_crypt,source=/dev/disk/by-uuid/3fb738d0-e025-4280-a045-bc5d48272605,key=none,lvm=mainlynas-swap
target=sdc1_crypt,source=/dev/disk/by-uuid/f54450d9-fe21-4a7f-bbfc-a7d63f710bb3,key=none
target=sda5_crypt,source=/dev/disk/by-uuid/3fb738d0-e025-4280-a045-bc5d48272605,key=none
target=sdb1_crypt,source=/dev/disk/by-uuid/84d75f76-0204-494e-806a-cda376ead5ae,key=none,lvm=UUID=35cdabba-23d7-4872-b4a3-6dbfa6901d8c
target=sda5_crypt,source=/dev/disk/by-uuid/3fb738d0-e025-4280-a045-bc5d48272605,key=none,lvm=mainlynas-swap

My first question is whether this will cause a problem or not and secondly how do I go about editing the files in initramfs in general? Thanks in advance!

Last edited by physdude; 21st July 2008 at 00:15.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Email dayjahone General 7 30th June 2008 16:29
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 15:36
i am having some problem ? cobro Installation/Configuration 20 30th April 2008 17:26
Add Webmin to the system sushestvo Installation/Configuration 44 21st August 2007 17:52
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 20:52


All times are GMT +2. The time now is 10:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.