Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th November 2010, 13:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

/etc/courier/authmysqlrc must look as follows:

Code:
MYSQL_SERVER localhost
MYSQL_USERNAME mail_admin
MYSQL_PASSWORD mail_admin_password
MYSQL_PORT 0
MYSQL_DATABASE mail
MYSQL_USER_TABLE users
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD "/home/vmail"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 5th December 2010, 11:48
giannileggio giannileggio is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello, i have the same problem of the first post of this thread.
Postfix is running, my tail /var/log/maillog in empty

Code:
telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Code:
netstat -anp | grep 'LISTEN ' | grep :25
tcp        0      0 0.0.0.0:25                  0.0.0.0:*                   LISTEN      3734/master         
tcp        0      0 :::25                       :::*                        LISTEN      3734/master
Code:
nmap localhost

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2010-12-05 07:51 EST
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1670 closed ports
PORT     STATE SERVICE
25/tcp   open  smtp
53/tcp   open  domain
80/tcp   open  http
110/tcp  open  pop3
143/tcp  open  imap
783/tcp  open  spamassassin
953/tcp  open  rndc
993/tcp  open  imaps
995/tcp  open  pop3s
3306/tcp open  mysql
Can you help me, please? Thank you
Reply With Quote
  #13  
Old 5th December 2010, 11:52
jetfix jetfix is offline
Junior Member
 
Join Date: Nov 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Postfix doesn't use /var/log/maillog .. instead take a look at these:

/var/log/mail.log
/var/log/mail.info
/var/log/mail.err
Reply With Quote
  #14  
Old 5th December 2010, 11:57
giannileggio giannileggio is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't have these files on my server
(i searched in /var/log and with 'locate' command)
Reply With Quote
  #15  
Old 5th December 2010, 12:02
jetfix jetfix is offline
Junior Member
 
Join Date: Nov 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

???? I don't know why.... authdaemonrc file find and set next parametr value:

DEBUG_LOGIN=2

... this will give you detailed repost .. may be nothing hapends and that's why no files are being created ... also after making this setting take a look at /var/log/syslog .. it may also hold some information... go&conquer)))
Reply With Quote
  #16  
Old 5th December 2010, 12:03
jetfix jetfix is offline
Junior Member
 
Join Date: Nov 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

and another one..that I'm thinking of ...you may have a mistake in your mysql_virtual ... files .. check if everything (especialy username for mysql) correct in these files.
Reply With Quote
  #17  
Old 5th December 2010, 12:08
giannileggio giannileggio is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your help
My log files are still empty, all of them (i setted the debug_login = 2)

Now i'll go to check mysql configurations files
Reply With Quote
  #18  
Old 5th December 2010, 17:12
giannileggio giannileggio is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I checked mysql configurations and are right.
Reply With Quote
  #19  
Old 5th December 2010, 17:13
jetfix jetfix is offline
Junior Member
 
Join Date: Nov 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So .. is it working now ?
Reply With Quote
  #20  
Old 5th December 2010, 17:16
giannileggio giannileggio is offline
Junior Member
 
Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

No, I'm still at the same point.

I can telnet pop3 and imap but i can't reach postfix on port 25
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 05:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.