Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st August 2008, 12:59
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Great thing, saw it the first time... but login via email as username is not possible, right?
Reply With Quote
Sponsored Links
  #12  
Old 1st August 2008, 19:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Fixed this in svn.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following 2 Users Say Thank You to till For This Useful Post:
Hans (1st August 2008), Snowman (4th August 2008)
  #13  
Old 1st August 2008, 23:29
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

I replaced the file user.table.php with the new version from SVN and i want you to know that is works. This means, changing passwords for clients is possible again.

Thanks for the fix!
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #14  
Old 4th August 2008, 13:27
bolero bolero is offline
Senior Member
 
Join Date: Apr 2008
Posts: 114
Thanks: 2
Thanked 6 Times in 6 Posts
Default

Unfortunately, it stopped working for me. It worked with the change in code I made last week, but this week the user changes are not carried over to /etc/passwd, /etc/shadow, although I used the original files in /root (config.lib.php and ispconfig_system.lib.php). It seems that $mod->system->updateuser fails silently. I wanted to check against svn, but the log tells me last revision is July 9. I checked out svn://svn.ispconfig.org/ispconfig/trunk/ What should I check out instead?
Reply With Quote
  #15  
Old 4th August 2008, 13:47
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

@Bolero,
I have used the one from SVN stable.
It is attached to this message. It works for me.
Attached Files
File Type: zip user.table.zip (2.1 KB, 185 views)
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #16  
Old 4th August 2008, 14:02
bolero bolero is offline
Senior Member
 
Join Date: Apr 2008
Posts: 114
Thanks: 2
Thanked 6 Times in 6 Posts
Default

Yes, I made a stupid mistake. After having fixed it, I added a logging line in updateuser() and didn't test again. That line didn't work without access to the global $mod array. It's now working again. Thanks for the file, but I would rather check it out myself. The svn path I mentioned checks out 2.2.24. What's the path for HEAD code?
Reply With Quote
  #17  
Old 4th August 2008, 14:08
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Please have a look here.
So use svn://svn.ispconfig.org/ispconfig/branches/ISPConfig-2.2.stable
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
The Following User Says Thank You to Hans For This Useful Post:
bolero (4th August 2008)
  #18  
Old 4th August 2008, 14:30
bolero bolero is offline
Senior Member
 
Join Date: Apr 2008
Posts: 114
Thanks: 2
Thanked 6 Times in 6 Posts
Default

Thanks, I wasn't aware of this. I was using what http://www.ispconfig.org/downloads.htm tells.
Reply With Quote
  #19  
Old 4th August 2008, 14:34
bolero bolero is offline
Senior Member
 
Join Date: Apr 2008
Posts: 114
Thanks: 2
Thanked 6 Times in 6 Posts
Default

Till, you may want to correct the small typo in it as well:
Name contains invalid charcters. ->
Name contains invalid characters.
I think there is also a problem with picking this error message up. I didn't check the code more thoroughly, so I don't know if there is an intention to display it. At least at the moment it doesn't display, so nobody knows that it fails silently.
Reply With Quote
  #20  
Old 4th August 2008, 15:18
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
 
Default

@Bolero,

I've corrected the "charcters" typo on line 73 of the file and saved it to SVN.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.18 to ISPConfig 2.2.19 bug ? sygram General 2 11th January 2008 11:35
ISPConfig 2.2.13 released till General 35 23rd July 2007 16:28
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
Can`t I access to mailUser ISPConfig leeeonardo Server Operation 1 19th April 2007 03:58
Bug in ispconfig 2.1.1 Bruce General 4 19th November 2005 15:00


All times are GMT +2. The time now is 18:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.