Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st September 2010, 13:51
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Question

Hi Falco, I did that.

Was a while since I attempted this tutorial, from first seeing it.

But this is the error I get when I updated the various development languages:

Quote:
[root@server1 portsentry_beta]# make linux
SYSTYPE=linux
Making
cc -O -Wall -DLINUX -DSUPPORT_STEALTH -o ./portsentry ./portsentry.c \
./portsentry_io.c ./portsentry_util.c
./portsentry.c: In function `Usage':
./portsentry.c:1584: error: missing terminating " character
./portsentry.c:1585: error: `sourceforget' undeclared (first use in this function)
./portsentry.c:1585: error: (Each undeclared identifier is reported only once
./portsentry.c:1585: error: for each function it appears in.)
./portsentry.c:1585: error: syntax error before "dot"
./portsentry.c:1585: error: stray '\' in program
./portsentry.c:1585: error: missing terminating " character
make: *** [linux] Error 1
Any ideas?

Thanks in advance,
Jeremy
Reply With Quote
Sponsored Links
  #12  
Old 7th September 2010, 13:23
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
 
Lightbulb Solved!

Actually its some problem with the code.

Not sure why they didnt sort this out, or havent yet, but this is the offending line in 'portsentry.c' file:

Quote:
printf ("Copyright 1997-2003 Craig H. Rowland <craigrowland at users dot

sourceforget dot net>\n");
Just this is on 2 lines, you cant have this in c programming so, I just removed the line and it works now, not sure why they havent picked up on this yet but hey!

Might try and find a contact and ask them to do this to allow other users who dont know C very well to work with this.
Reply With Quote
The Following User Says Thank You to j.smith1981 For This Useful Post:
falko (8th September 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To Install MySQL 4.1 And PHP4 On Debian Etch Problem djc_2008 HOWTO-Related Questions 1 13th February 2008 19:04
Setup problem ? affecting Joomla 1.5 install luoto Installation/Configuration 9 11th January 2008 10:38
Install error on Opensuse 10.2 64 bit (SSL problem) klaus++ Installation/Configuration 2 24th September 2007 13:47
install problem on FC5 PortMan Installation/Configuration 2 27th June 2006 13:07
MySQL problem on install badben Installation/Configuration 12 20th December 2005 13:59


All times are GMT +2. The time now is 16:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.