#1  
Old 13th July 2008, 19:32
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default webmail question

I have a problem with using webmail in ISPconfig..

originally someone set the server's hostname to be www.abcdef.com (domain does not exist) during the installation of the linux -- a Fedora Core 6. After that we installed the ISPconfig and webmail, etc...

Later we determined to use www.accoladedns.com as the hostname. We changed the /etc/hosts and /etc/sysconfig/network to update the hostname, then reboot --- everything works fine and the hostname now becomes www.accoladedns.com. However when we use the webmail by visiting http://www.accoladedns.com:81/webmail, it will automatically "jump" to http://www.abcdef.com:81/webmail

since www.abcdef.com does not exist.. of course the browser will return an error.

Can someone tell me in what way can I tell the webmail (or is it actually postfix?) that the hostname has been updated?

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 14th July 2008, 08:50
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Default

Have you configured ISPConfig to use the new domain?
Can you login to the Conrol Panel?
Reply With Quote
  #3  
Old 14th July 2008, 08:57
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default

Yes I have configuraed ISPconfig to use the new name, and can login to the Control panel too.

The problem only occurs in webmail. For your information, if people type http://www.accoladedns.com:81/webmail/ (with the ending slash), then there will be no jump problem.

But if they type http://www.accoladedns.com:81/webmail (without the ending slash), then it will jump to jump to http://www.abcdef.com:81/webmail
(strange behaviour...)

>>Have you configured ISPConfig to use the new domain?
>>Can you login to the Conrol Panel?
Reply With Quote
  #4  
Old 15th July 2008, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please make sure that the value of ServerName is set to www.accoladedns.com in /root/ispconfig/httpd/conf/httpd.conf. Restart ISPConfig afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th July 2008, 00:40
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
 
Default

Thanks a million !!! Problem solved.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about accessing webmail... twgray Installation/Configuration 2 13th June 2008 16:35
Question - Webmail mlsys Tips/Tricks/Mods 6 22nd May 2008 00:10
website and webmail with same URL hvrossum Installation/Configuration 1 1st January 2008 20:43
Redirect question {SERVERNAME} for webmail Herbert Installation/Configuration 15 15th January 2007 14:05
question with sending mail from webmail paulley Server Operation 4 28th June 2006 00:04


All times are GMT +2. The time now is 18:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.