#1  
Old 11th July 2008, 06:59
cruz cruz is offline
Senior Member
 
Join Date: Apr 2007
Posts: 365
Thanks: 51
Thanked 2 Times in 2 Posts
Default apache not starting

I noticed in ispconfig, under managment services that web server is offline. themn I tried to restart it and get this
HTML Code:
server1:~# /etc/init.d/apache restart
Forcing reload of web server (apache2)...grep: /etc/apache2/mods-enabled/php4.lo                         ad: No such file or directory
grep: /etc/apache2/mods-enabled/php4.conf: No such file or directory
grep: /etc/apache2/mods-enabled/php4.load: No such file or directory
grep: /etc/apache2/mods-enabled/php4.conf: No such file or directory
apache2: Syntax error on line 185 of /etc/apache2/apache2.conf: Could not open c                         onfiguration file /etc/apache2/mods-enabled/php4.load: No such file or directory
 failed!
I went into the mod-enabled file and I see two files php4 conf and load, but they have red marks on them. Can some one please help me with this?
Reply With Quote
Sponsored Links
  #2  
Old 11th July 2008, 12:14
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Those are dead links, use ls -l to find there they are supposed to point.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 12th July 2008, 00:41
cruz cruz is offline
Senior Member
 
Join Date: Apr 2007
Posts: 365
Thanks: 51
Thanked 2 Times in 2 Posts
Default thanks

Thanks Topdog. I reloaded the server. That happened once before. What makes the links become dead? it was working just fine. I know there was more than that going on. When I went into ispconfig it was taking a long time to load. sometimes I would have to hit the stop on the browser for the icons to show up on the screen. I just figured I would reload the server because of both of those issues.
Reply With Quote
  #4  
Old 12th July 2008, 12:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
ls -la /etc/apache2/mods-available
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th July 2008, 20:49
cruz cruz is offline
Senior Member
 
Join Date: Apr 2007
Posts: 365
Thanks: 51
Thanked 2 Times in 2 Posts
 
Default reloaded

I ended up reloading the server. Thanks for the reply
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 21:58
Apache is not starting at boot LeoLinux Installation/Configuration 3 13th August 2007 13:08
Perfect Setup OpenSuse 10.2 Guide, Problem with starting Apache, Please help! Jerry HOWTO-Related Questions 1 31st July 2007 10:45
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 01:45


All times are GMT +2. The time now is 03:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.