Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2008, 20:22
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default PHP Upload Timesout?

Users are having timeout issues when uploading files via Gallery 2.0's PHP upload scripts. Files smaller than 500K were working fine. I changed the PHP.INI limits and now they cannot upload one image of 2.5MB or multiple for that matter. It gives a timeout (white page) and doesn't complete the process on multiple images. Anyidea how to perfect the PHP.INI/HTTPD setup to allow for much more uploading? The average upstream if 40K/s. It also may be well to know that aside from these settings I have kept the files as default from the ISPConfig installations.

Current setting:
max_execution_time = 400 ; Maximum execution time of each script, in
seconds
max_input_time = 400 ; Maximum amount of time each script may spend parsing
request data
memory_limit = 30M ; Maximum amount of memory a script may consume
post_max_size = 30M ; Maximum size of POST data that PHP will accept.
upload_tmp_dir = /tmp/ ; Temporary directory for HTTP uploaded files.

Also, check the http://www.duwahaven.com/test.php for the PHP-INFO output...

It's worth noting that the PHP Upload Script will work properly for 1.2MB files and multiple 800KB files.

Last edited by crypted; 23rd April 2008 at 20:30.
Reply With Quote
Sponsored Links
  #2  
Old 23rd April 2008, 20:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,482
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Which php.ini file did you edit?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd April 2008, 21:54
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

/etc/php.ini
Reply With Quote
  #4  
Old 24th April 2008, 11:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,482
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

The settings looks ok so far. I have no idea what may cause this at the moment.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th September 2008, 19:28
denebstar denebstar is offline
Junior Member
 
Join Date: Apr 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

I am facing exactly the same problem :

max_execution_time = 300
max_input_time = 600
memory_limit = 64M
file_uploads = On
upload_max_filesize = 100M
default_socket_timeout = 60

But for files of more than 2M the upload fails ??????????
__________________
http://www.pangeesoft.com
Reply With Quote
  #6  
Old 26th September 2008, 15:28
denebstar denebstar is offline
Junior Member
 
Join Date: Apr 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In the following forum :

http://www.radinks.com/upload/config.php

I see that comment :
Additonal Comments
Apache Settings
The apache webserver has a LimitRequestBody configuration directive that restricts the size of all POST data regardless of the web scripting language in use. Some RPM installations sets limit request body to 512Kb. You will need to change this to a larger value or remove the entry altogether.


But it doesn"'t say where I should change that "LimitRequestBody"
Any Idea ?

Regards,
Deneb
__________________
http://www.pangeesoft.com
Reply With Quote
  #7  
Old 26th September 2008, 15:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,482
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Most likely you edited the wrong php.ini file. Please crete a file containing:

<?php
phpinfo();
?>

and upload it to your webspace. Open the file in a browser and search in the content which php.ini is used for this script. Then edit this php.ini file.

Aditionally, you seem not to have set post_max_size to a lerger sire in the php.ini.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 26th September 2008, 16:29
denebstar denebstar is offline
Junior Member
 
Join Date: Apr 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till
I edited the /etc/php.ini file
When I tried to upload directly from the server (to the server) it worked for a 41Mo file

Now that I try from a different location it just seems to time out

How can I send you the result of the php command ?

regards,
__________________
http://www.pangeesoft.com
Reply With Quote
  #9  
Old 26th September 2008, 16:38
denebstar denebstar is offline
Junior Member
 
Join Date: Apr 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here are some of the PHP values
I have removed those that seemed totally un interresting for that problem


max_execution_time 600 600
max_input_nesting_level 64 64
max_input_time 600 600
memory_limit 250M 250M
open_basedir no value no value
output_buffering 4096 4096
output_handler no value no value
post_max_size 200M 200M
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv Off Off
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
safe_mode Off On
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
upload_max_filesize 100M 100M
upload_tmp_dir no value no value

First value is local value, second value is Master value (Only safe_mode seem to differ)
regards
__________________
http://www.pangeesoft.com
Reply With Quote
  #10  
Old 27th September 2008, 13:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

You can try
PHP Code:
set_time_limit(0); 
at the beginning of the upload script. If you have a slow connection, it might be a timeout problem.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
ISPConfig virtual web pages not working mike_phi Installation/Configuration 8 7th May 2008 16:51
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 08:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.