Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th June 2008, 02:45
Counterculture Counterculture is offline
Junior Member
 
Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig Installation problems ubuntu 8.04

I follow the perfect setup and I'm getting a error on install . which reads as so

Checking for program httpd...
/usr/bin/httpd
OK
Checking the syntax of the httpd.conf...
httpd: bad user name ${APACHE_RUN_USER}
ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!

not sure what is wrong . Thanks
Reply With Quote
Sponsored Links
  #2  
Old 26th June 2008, 16:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do you use the latest ISPConfig version?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th June 2008, 19:34
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by Counterculture View Post
httpd: bad user name ${APACHE_RUN_USER}
Since you're installing under ubuntu I'd say make sure you're doing every single command as sudo, or do sudo -i to have persistant sudo.

I went to debian etch simply because of having to type in sudo over and over and over on ubuntu. And with the perfect server setup for debian etch I was able to copy and paste every command from this site and it worked perfectly without incident.
Reply With Quote
  #4  
Old 27th June 2008, 21:37
kolipoki kolipoki is offline
Junior Member
 
Join Date: Jun 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig installation in Ubuntu 8.04

Quote:
Originally Posted by biobrew View Post
Since you're installing under ubuntu I'd say make sure you're doing every single command as sudo, or do sudo -i to have persistant sudo.
Bio, the how-to was described as done with the root user, therefore removing the sudo command. If I'm wrong some one please correct me.

BTW, Im a total noob, can't find the install_ispconfig directory to delete for restarting installation procedure. Can some one point me to it? Or, what's the command line for deleting it? Thanks in advance...

Last edited by kolipoki; 27th June 2008 at 21:41.
Reply With Quote
  #5  
Old 28th June 2008, 01:29
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Try this, it seems to be the same problem

http://ubuntuforums.org/showthread.php?t=804436

I think above from what you posted you're trying to run apache not as sudo or not as root. Maybe you rebooted your machine and then tried to run the command (not as root the way the perfect server set up does it in the beginning)

Does it help to run the same command(s) as sudo? Or is it the same?

For me on ubuntu machines I find it easier to just sudo -i right when I login if I know I'm going to be doing something administrative.
Reply With Quote
  #6  
Old 6th July 2008, 23:35
tensor tensor is offline
Member
 
Join Date: Jul 2007
Posts: 51
Thanks: 11
Thanked 9 Times in 6 Posts
Default

This may be an exact problem
http://www.howtoforge.com/forums/showthread.php?t=20437
Reply With Quote
  #7  
Old 9th July 2008, 04:26
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
 
Default

I have temporarily given up on 8.04, just too many problems, especially as a VM. I am sticking with 7.10 for now.

-J
__________________
Ubuntu 14.04 - The Perfect Setup
ISPConfig 3.0.5
http://www.vmsources.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.4 Beta Released till General 54 4th March 2009 09:55
Dell doesn't support Ubuntu 8.04 yet! nopedx Installation/Configuration 2 23rd June 2008 22:45
ISPConfig install problems: iptables/ipchains/ipfw not found bjarne-j Installation/Configuration 1 3rd April 2008 18:11
ISPconfig on Ubuntu: Upgrading Breezy to Dapper Clogboy General 6 22nd February 2007 21:32
Problems with domain and host name ispconfig 2.1.1 grantdutoit Installation/Configuration 8 6th April 2006 21:53


All times are GMT +2. The time now is 16:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.