Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th July 2008, 15:45
zeeman zeeman is offline
Junior Member
 
Join Date: Feb 2007
Posts: 22
Thanks: 7
Thanked 2 Times in 2 Posts
Send a message via ICQ to zeeman
Default Manual update doesn't work anymore

Hi!

We use ISPconfig (always the current version) and have build something simmilar to DynDNS/DynAlias.

A scirpt updates the database entry of an host in isp_dns_isp and creates the .run-file.

This doesn't work any more (can't say when exactly).
The .run-file is still deleted, but the 'u' remains in the database and the bind-file isn't recreated.

Our script (shortend):
Code:
mysql -u USER -pPASSWORD db_ispconfig << ENDOFMYSQL
UPDATE dns_a SET ip_adresse='$1' WHERE doc_id=9 AND doctype_id=1018 AND host='MYHOST';
UPDATE dns_isp_dns SET status='u' WHERE doc_id=5 AND doctype_id=1016 AND dns_soa='DOMAIN.TLD';
ENDOFMYSQL

#Notify ISPconfig
touch /home/admispconfig/ispconfig/.run
Do I have to add an 'u' somehere else?
I guess ISPconfig's behavoir changed after an update, because it worked some time ago...

Regards,
Sebastian
Reply With Quote
Sponsored Links
  #2  
Old 7th July 2008, 18:13
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,380
Thanks: 833
Thanked 5,480 Times in 4,314 Posts
Default

The behaviour of ISPConfig has not been changed. I guess that there is a config problem with bind on your server. E.g. when you install a bind update, some linux distributions mess up the bind directory permissions which causes ISPConfig to fail after the bind update.

Please check that the permissions of the bind config directory are the same then described in the perfect setup guide for your linux distribution and that the path to the bind config files is correct in ispconfig under management > server > settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th July 2008, 19:19
zeeman zeeman is offline
Junior Member
 
Join Date: Feb 2007
Posts: 22
Thanks: 7
Thanked 2 Times in 2 Posts
Send a message via ICQ to zeeman
 
Default

Thanks till!

Just for the archive: (Problem occurs on two different CentOS 4.5 servers)
  • /var/named/* were screwed up
  • The paths at management > server > settings were wrong. The correct values have to be /var/named/chroot/etc/named.conf and /var/named/chroot/var/named
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trashfolder in ISP Manager doesnt work grafzahl Installation/Configuration 3 24th March 2008 12:49
will Awstats work after Update? luchs3 General 2 7th October 2007 14:10
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Setting new apache directives doesn't work anymore Dennuz666 Installation/Configuration 1 22nd March 2007 11:25
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 15:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.