Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 7th July 2008, 19:34
c0mrade c0mrade is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Here is some of last entries .. whole file is too big to paste
Code:
Jul  7 09:08:51 emir imap[23932]: badlogin: localhost.localdomain [127.0.0.1] plaintext alma@mail.panel.komentari.info SASL(-13): authenticat
ion failure: checkpass failed
Jul  7 09:08:57 emir last message repeated 2 times
Jul  7 09:09:18 emir update_sanesecurity.sh[7849]: None of '/var/clamav/daily.inc', '/var/clamav/main.inc',
Jul  7 09:09:18 emir update_sanesecurity.sh[7855]: '/var/clamav/main.cvd' found in your database directory. Either '/var/clamav' is NOT
Jul  7 09:09:18 emir update_sanesecurity.sh[7861]: the correct database path or there is something wrong with your
Jul  7 09:09:18 emir update_sanesecurity.sh[7869]: ClamAV installation. This path came from your '/usr/bin/clamscan' so I would guess
Jul  7 09:09:18 emir update_sanesecurity.sh[7875]: you need to check your clamd.conf file and/or '/var/clamav'
Jul  7 09:09:18 emir update_sanesecurity.sh[7881]: Exiting.
Jul  7 09:10:32 emir master[28135]: process 23932 exited, status 0
Jul  7 09:11:25 emir master[11944]: about to exec /usr/lib/cyrus-imapd/ctl_cyrusdb
Jul  7 09:11:25 emir master[11945]: about to exec /usr/lib/cyrus-imapd/squatter
Jul  7 09:11:25 emir squatter[11945]: indexing mailboxes
Jul  7 09:11:25 emir squatter[11945]: done indexing mailboxes
Jul  7 09:11:25 emir ctl_cyrusdb[11944]: checkpointing cyrus databases
Jul  7 09:11:25 emir ctl_cyrusdb[11944]: archiving database file: /var/lib/imap/annotations.db
Jul  7 09:11:25 emir ctl_cyrusdb[11944]: archiving database file: /var/lib/imap/mailboxes.db
Jul  7 09:11:25 emir ctl_cyrusdb[11944]: done checkpointing cyrus databases
Jul  7 09:11:25 emir master[28135]: process 11945 exited, status 0
Jul  7 09:11:25 emir master[28135]: process 11944 exited, status 0
Jul  7 09:13:51 emir imap[7669]: accepted connection
Jul  7 09:13:51 emir master[13659]: about to exec /usr/lib/cyrus-imapd/imapd
Jul  7 09:13:51 emir imap[13659]: executed
Jul  7 09:13:51 emir imap[7669]: badlogin: localhost.localdomain [127.0.0.1] plaintext alma@mail.panel.komentari.info SASL(-13): authenticati
on failure: checkpass failed
Jul  7 09:13:57 emir last message repeated 2 times
Jul  7 09:15:25 emir master[28135]: process 7669 exited, status 0
Jul  7 09:23:51 emir imap[13659]: accepted connection
Jul  7 09:23:51 emir master[24083]: about to exec /usr/lib/cyrus-imapd/imapd
Jul  7 09:23:51 emir imap[24083]: executed
Jul  7 09:23:51 emir imap[13659]: badlogin: localhost.localdomain [127.0.0.1] plaintext alma@mail.panel.komentari.info SASL(-13): authenticat
ion failure: checkpass failed
Jul  7 09:23:57 emir last message repeated 2 times
Jul  7 09:25:03 emir master[28135]: process 13659 exited, status 0
Reply With Quote
Sponsored Links
  #12  
Old 7th July 2008, 19:40
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Yes your sasl authentication is failing make sure that the details you used for the pam_mysql configuration is correct and can actually connect to the database using them.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #13  
Old 7th July 2008, 21:49
c0mrade c0mrade is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi, sorry I forget to update pam_mysql password from hordepassword to acctual horde password .. anyway I get the same error as in previous screen shots just different things in horde.log now .. what did I miss now ?
Code:
Jul 07 11:28:02 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:28:04 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:29:00 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as alma@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:33:28 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:34:01 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as alma@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:34:01 HORDE [error] [horde] Error writing session data: MySQL server has gone away [on line 147 of "/usr/share/horde/lib/Horde/SessionHandler/mysql.php"]
Jul 07 11:38:26 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:39:01 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as alma@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:44:04 HORDE [notice] [horde] Login success for emir@mail.panel.komentari.info [77.77.197.68] to Horde [on line 90 of "/usr/share/horde/login.php"]
Jul 07 11:44:16 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Jul 07 11:44:17 HORDE [error] [imp] FAILED LOGIN 77.77.197.68 to localhost:143[imap/notls] as emir@mail.panel.komentari.info [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
Reply With Quote
  #14  
Old 8th July 2008, 07:00
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

I suggest that you run through the tutorial with the defaults on a testbox first, then do the modifications for your environment later.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #15  
Old 8th July 2008, 16:29
c0mrade c0mrade is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

thank you for your replies, by default you mean same values you used ?
Reply With Quote
  #16  
Old 12th July 2008, 19:18
shernand shernand is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default sieve problem

i'm getting this error in the maillog while i login the first time with a new account :

Jul 12 12:05:19 whiskey imap[15489]: autocreate_sieve: Unable to open sieve script /etc/default_sieve. Check permissions
Jul 12 12:05:19 whiskey imap[15489]: autocreate_sieve: User testx1@whiskey.xxx.com, default sieve script creation failed
Jul 12 12:05:19 whiskey imap[15517]: accepted connection

Due to this i'm missing the sent-mail, draft, spam, trash on imp. The folders are created as you can see below, but the user can't access them.

Jul 12 12:05:19 whiskey imap[15489]: autocreateinbox: User testx1@whiskey.xxx.com, subfolder INBOX.sent-mail creation succeeded.
Jul 12 12:05:19 whiskey imap[15489]: autocreateinbox: User testx1@whiskey.xxx.com, subscription to INBOX.sent-mail succeeded
...etc

This seems to be related with this on imapd.conf :

autocreate_sieve_script: /etc/default_sieve
autocreate_sieve_compiledscript: /etc/default_sieve_script.bc

i tryed changing this to another directory and chowned it as cyrus:mail, i even tryied with 777 permissions but still i'm getting this message.

What could be causing this?

Thanks

-- Shernand
Reply With Quote
  #17  
Old 13th July 2008, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's the output of
Code:
ls -la /etc/default_sieve
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 13th July 2008, 15:25
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

you only have to enable those options if you want to use the default scripts.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #19  
Old 16th July 2008, 16:37
shernand shernand is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

topdog - you are correct, the sieve script issue seems not to be related with the mailbox issue, but i still only can access the inbox with any account. I can't access drafts, sent-mail,etc. Do you have any idea why it's creating the folders and not allowing any users to access them?.

falko - no such file/directory

Thanks

--Shernand
Reply With Quote
  #20  
Old 16th July 2008, 16:41
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
 
Default

That is possibly because due to the sieve scripts not existing the auto subscription part did not work.

Make sure that the auto subscription option in your config has the correct directories, then create a new email address and access it or send a mail to it and see if the subscription does work.

For the existing accounts you can use cm to subscribe the user to the mailboxes.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL problem satimis Server Operation 5 25th June 2008 16:41
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 09:29
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 16:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.