Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2006, 12:26
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default Help understanding how mail server should be setup

Hi all!

I spent couple of hours reading thru whole forum trying to figure out what are steps to get it running, but no joy,
I have VPS (virtual private server) with Fedora 4 installed on it, I installed webmin, apache2, mysql, php and they're working fine,
now Dovecot IMAP/POP3 Server is giving me headache,
can someone give me a list of required modules to get mail working.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2006, 14:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Have a look at this tutorial: http://www.howtoforge.com/perfect_setup_fedora_core_4

In the tutorial I install the package imap; leave it out as you have installed Dovecot. You should then add these steps after the Postfix configuration because Dovecot uses Maildir:

Code:
postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart
If you want to install ISPConfig afterwards, you can create your mailboxes with the ISPConfig web interface; if you want to create your mailboxes manually, have a look here: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th January 2006, 05:30
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

Thanks for the reply falko!

so in putty I should run this code bellow ?
Code:
postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart
and since my VPS has only 128MB of ram I think I shouldn't install ISPConfig,
or I can install it but not run on a boot ?

Last edited by micko_escalade; 29th January 2006 at 08:17.
Reply With Quote
  #4  
Old 29th January 2006, 09:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by micko_escalade
so in putty I should run this code bellow ?
Code:
postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart
Yes.

Quote:
Originally Posted by micko_escalade
and since my VPS has only 128MB of ram I think I shouldn't install ISPConfig,
or I can install it but not run on a boot ?
It depends on how much RAM is eaten up by your other applications.
You can install it and then remove the system startup links so that it doesn't get started at boot time.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th January 2006, 09:47
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

I run the code and everrything went ok, with no errors,

but when I send test email from yahoo.com to my VPS it newer gets there,
outlook shows this error screenshot when I try to send email from outlook
www.dnsstuff.com gives this error link
also www.dnsreport.com at the buttom gives gives error for MX record link

I have 3 virtual domains, maybe that's causing problems?

Last edited by micko_escalade; 13th November 2006 at 02:50.
Reply With Quote
  #6  
Old 29th January 2006, 10:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Is 207.210.228.31 your server's IP address, or does it belong to another server?
Is your server connected directly to the internet, or is it behind a router?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 29th January 2006, 10:40
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

That ip is my VPS (virtual private server) ip, which is located somewhere in the US, and from what I've read looks like the problem is with Reverse DNS not set up for that ip.
Reply With Quote
  #8  
Old 29th January 2006, 19:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by micko_escalade
and from what I've read looks like the problem is with Reverse DNS not set up for that ip.
That is likely. You can ask your ISP/hoster to set up a reverse record for that IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 29th January 2006, 20:23
micko_escalade micko_escalade is offline
Senior Member
 
Join Date: Jan 2006
Posts: 123
Thanks: 7
Thanked 3 Times in 3 Posts
Default

Ok, I asked my provider and they set reverse dns, but still can't get it to work,
this is error log from Webmin: System > System Logs > /var/log/maillog > View Logfile
Code:
Jan 29 10:11:13 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:18 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:18 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:23 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:23 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:28 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:28 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:33 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:33 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:38 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:38 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:43 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:43 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:48 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:48 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
and www.dnsreport.com
still says Mail Fail ERROR: I could not complete a connection to any of your mailservers!
Reply With Quote
  #10  
Old 29th January 2006, 22:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by micko_escalade
Ok, I asked my provider and they set reverse dns, but still can't get it to work,
It might take up to 72 hours until the changes propagate.

Quote:
Originally Posted by micko_escalade
this is error log from Webmin: System > System Logs > /var/log/maillog > View Logfile
Code:
Jan 29 10:11:13 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:18 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:18 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:23 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:23 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:28 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:28 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:33 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:33 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:38 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:38 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:43 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:43 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:48 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:48 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: daemon MTA: problem creating SMTP socket
Jan 29 10:11:53 m5-fedora4-04 sendmail[1652]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
You seem to have Sendmail installed. The things I posted above are for Postfix... Now which Mail server is really installed on your system?

Also, please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Server Setup Behind a Router/Firewall/Cable Modem kisong Installation/Configuration 2 1st August 2010 18:05
configure as a secondary mail server xma General 6 15th February 2006 14:46
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
Mail server jas_esp Server Operation 1 7th December 2005 19:17
Can't get MX for external mail server to work semmelbroesel Installation/Configuration 4 25th November 2005 18:48


All times are GMT +2. The time now is 04:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.