Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th March 2008, 14:04
mpitanga mpitanga is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamassasin Configuration in Virtual Users And Domains With Postfix, MailScanner, ...

I can't find the files bayes_toks and bayes_seen in the directory /var/spool/MailScanner/spamassassin.

When I need to modify the directory permissions one message error return to me.

Regards,
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2008, 13:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mpitanga
When I need to modify the directory permissions one message error return to me.

Regards,
What exactly are you trying to do, and what's the exact error message?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th March 2008, 19:32
mpitanga mpitanga is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

HI, I solved the problem...

Thks
Reply With Quote
  #4  
Old 20th May 2008, 23:11
Al3x Al3x is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello.

Same problem here.

The problem exactly is in step 7.6:

http://www.howtoforge.com/virtual-us...h-centos5.1-p2

-------------------------------------------
-------------------------------------------
And modify the directory permissions:

Code:
chown postfix:apache /var/spool/MailScanner/spamassassin/ /var/spool/MailScanner/spamassassin/bayes_*
chmod g+rws /var/spool/MailScanner/spamassassin/
chmod g+rw /var/spool/MailScanner/spamassassin/bayes_*
-------------------------------------------
-------------------------------------------

Folder /var/spool/MailScanner/spamassassin/ is empty, no bayes_* files on server.
Spammassasin installed by cpan.

Thanks in advance.
Reply With Quote
  #5  
Old 20th May 2008, 23:19
Al3x Al3x is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

I've seen this in the README:

Code:
Copy the existing bayes databases and set the permissions:

# cp /root/.spamassassin/bayes_* /etc/MailScanner/bayes
# chown root:apache /etc/MailScanner/bayes/bayes_*
# chmod g+rw /etc/MailScanner/bayes/bayes_*
But /root/.spamassassin/ is also an empty folder.

Regards
Reply With Quote
  #6  
Old 21st May 2008, 14:31
Al3x Al3x is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

Solved.

Here you can find bayes files:

http://www.fsl.com/support/index.html

Best regards
Reply With Quote
The Following User Says Thank You to Al3x For This Useful Post:
falko (22nd May 2008)
  #7  
Old 11th July 2008, 18:16
corillon corillon is offline
Junior Member
 
Join Date: Jul 2008
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I had the same issue, but decided to continue to the next steps and finish the How To. Once it was up and running I found this forum post. I went back to "fix" the step and the files that were previously missing were now present.

I have no idea what step filled them in but they were there and everything seems to running smoothly both before and after. Overall everything went pretty smoothly there were just one or two steps that seemed to be out of order like this one and the /var/www/html/mailscanner step where you need to chmod some files before you have made the directory.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Virtual Users And Domains With Postfix, Courier And MySQL [+ procmail ?] immobilia HOWTO-Related Questions 5 29th June 2006 23:20
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 07:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.