#1  
Old 30th June 2008, 15:10
onik onik is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Strange postfix problem.

I have a strange problem..

I have few domains hosted on my server. On one of the domains I am able to have SMTP plain Text authentication and on other domains I am not able to provide. I get "Pam auth error" message.

I am using Centos 4.6 with Postfix 2.5.2

Pl help. Thanks a million!

Onik
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2008, 22:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the exact error messages from the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd July 2008, 10:25
onik onik is offline
Junior Member
 
Join Date: Jun 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hello,

smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

However I have found some problem as under:
------------------------------------------
#postconf -a
dovecot
cyrus

I have installed dovecot imap server. But....

[root@] # dovecot -n | head -1
Error: Error in configuration file /usr/local/etc/dovecot.conf line 1: Expecting '='
Fatal: Invalid configuration in /usr/local/etc/dovecot.conf

/usr/local/etc/dovecot.conf is as under:
-------------------------------------------------------------------
# Basic Configuration
base_dir = /var/run/dovecot/
protocols = imap pop3
listen = *
disable_plaintext_auth = no
# Logging
log_path = /var/log/dovecot.log
info_log_path = /var/log/dovecot-info.log
# SSL
ssl_disable = yes
ssl_listen =
# Login Processes
login_dir = /var/run/dovecot/login
login_chroot = yes
login_process_size = 64
login_process_per_connection = yes
login_processes_count = 3
login_max_processes_count = 128
login_max_connections = 256
login_greeting = Dovecot ready
# Mailbox locations
mail_location = mbox:~/mail:INBOX=/var/mail/%u
# mail_location = maildir:~/Maildir
# mbox (Traditional)
mbox_read_locks = fcntl
mbox_write_locks = fcntl
# maildir (Latest)

# Mail Processes
max_mail_processes = 1024
mail_process_size = 256
mail_max_keyword_length = 50
# IMAP Specific Settings
protocol imap {
login_executable = /usr/libexec/dovecot/imap-login
mail_executable = /usr/libexec/dovecot/imap
mail_plugins =
mail_plugin_dir = /usr/lib/dovecot/imap
}
# POP3 specific settings
protocol pop3 {
login_executable = /usr/libexec/dovecot/pop3-login
mail_executable = /usr/libexec/dovecot/pop3
mail_executable = /usr/libexec/dovecot/pop3
}
# Authentication processes
auth_executable = /usr/libexec/dovecot/dovecot-auth
auth_process_size = 256
auth_realms =
auth_username_chars = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWX YZ01234567890.-_@
auth default {
mechanisms = plain login
passdb pam {
}
userdb passwd {
}
socket listen {
client {
# Assuming the default Postfix $queue_directory setting
path = /var/spool/postfix/private/auth
mode = 0660
# Assuming the default Postfix user and group
user = postfix
group = postfix
}
}
}

-----------
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Postfix: connection refused error tosin Server Operation 1 30th October 2007 17:30
ISPConfig with postfix problem Chrisssssss General 30 20th January 2007 23:34
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs k1piee HOWTO-Related Questions 14 1st October 2006 13:46
postfix - myhostname, mydoman problem adam Server Operation 14 26th September 2006 07:57


All times are GMT +2. The time now is 02:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.