Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st July 2008, 23:25
antun antun is offline
Member
 
Join Date: Oct 2006
Location: San Francisco, CA
Posts: 38
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Hi Falko,

I'm not sure how this happened, but I had already responded to a different thread. I received an email notification that someone had responded to a thread I was subscribed to, and I clicked the link in the email, and posted my reply there. I had never posted on that other thread (entitled "After adding "Include vhosts/Vhosts_ispconfig.conf" httpd won;t startup"), and I don't remember ever reading it, let alone subscribing to it. Does Till have the ability to subscribe me to another thread?

Anyway, here are the results from doing the following:

Code:
1) Rename Vhosts_ispconfig.conf to Vhosts_ispconfig.conf.bak
2) Rename Vhosts_ispconfig.conf_30-06-08_10-27-34 to Vhosts_ispconfig.conf
3) Run:

httpd -t
I ran the http -t command like you said (thanks for the pointer, by the way) and it gave the following error:

Syntax error on line 323 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
AllowOverride not allowed here

There was an AllowOverride All on line 323. I removed it, ran httpd -t again, then got a Syntax OK message.

What's the right next step here - should I reinstall ISPConfig, leaving the current vhost file in place, or can I just edit that vhost file?

BTW, how would the AllowOverride All get into that file - is it possible that it was added there because I added it to the Apache Directives section of the particular site in ISPConfig?

My main question now is: what should I do now? If I remove the offending line (AllowOverride All), then what triggers ISPConfig to reset? Do I have to reinstall it?

Thanks,

Antun
Reply With Quote
Sponsored Links
  #12  
Old 2nd July 2008, 18:34
antun antun is offline
Member
 
Join Date: Oct 2006
Location: San Francisco, CA
Posts: 38
Thanks: 7
Thanked 0 Times in 0 Posts
 
Default

Thanks all for your help. I got this resolved, but the discussion's on another thread, so here's the link:

http://www.howtoforge.com/forums/sho...d=1#post133865

Oh, and as a temporary workaround I had created a file called antun-ruby in /etc/apache2/conf.d with the following settings to "force" the mod_ruby option for that site:

Code:
<IfModule mod_ruby.c>
  <Directory /var/www/web9/web>
    Options +ExecCGI
  </Directory>
  RubyRequire apache/ruby-run
  #RubySafeLevel 0
  <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
  </Files>
  <Files *.rbx>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
  </Files>
</IfModule>
-Antun
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ruby and autosignup Gimly Installation/Configuration 3 14th March 2008 17:17
ISPConfig 2.2.20 released till General 31 13th February 2008 17:17
ISPConfig 2.2.20 Beta 1 available for testing till Developers' Forum 7 9th February 2008 19:48
Change Document Root for Ruby on Rails vhost Delphinus General 12 8th September 2007 12:31
Ruby on Ispconfig? city General 2 22nd March 2006 03:09


All times are GMT +2. The time now is 01:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.