#1  
Old 30th June 2008, 20:18
dean_za dean_za is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamsnake Wailwatch Problem

I have followed this great guide , many thanks to the author , being a qmail admin for 8 years this is my first dab at postfix. I was really eager to use the mailwatch web page to manage things. Unfortunately something must be wrong and I am not to sure what to check. I can access the mailwatch page and I can see when messages are in the mailq. I can click on them and it shows the messages but does ot give me any options or actions.

Also none of the stats change on the right hand side and if I click messages I get o results from table. I am assuming that mailscanner is not interacting with mysql properly. The mail.log shows

Jun 30 20:17:24 oss01 MailScanner[32416]: MailScanner E-Mail Virus Scanner version 4.68.8 starting...
Jun 30 20:17:25 oss01 MailScanner[32416]: Read 817 hostnames from the phishing whitelist
Jun 30 20:17:25 oss01 MailScanner[32416]: Read 5141 hostnames from the phishing blacklist
Jun 30 20:17:25 oss01 MailScanner[32416]: Config: calling custom init function SQLBlacklist
Jun 30 20:17:25 oss01 MailScanner[32416]: Starting up SQL Blacklist
Jun 30 20:17:26 oss01 MailScanner[32416]: Read 0 blacklist entries
Jun 30 20:17:26 oss01 MailScanner[32416]: Config: calling custom init function SQLWhitelist
Jun 30 20:17:26 oss01 MailScanner[32416]: Starting up SQL Whitelist
Jun 30 20:17:26 oss01 MailScanner[32416]: Read 1 whitelist entries
Jun 30 20:17:27 oss01 MailScanner[32416]: SpamAssassin temporary working directory is /var/spool/MailScanner/incoming/SpamAssassin-Temp
Jun 30 20:17:27 oss01 MailScanner[32416]: Using SpamAssassin results cache
Jun 30 20:17:27 oss01 MailScanner[32416]: Connected to SpamAssassin cache database
Jun 30 20:17:28 oss01 MailScanner[32416]: Expired 3 records from the SpamAssassin cache
Jun 30 20:17:28 oss01 MailScanner[32416]: Enabling SpamAssassin auto-whitelist functionality...
Jun 30 20:17:36 oss01 MailScanner[32416]: ClamAV scanner using unrar command /usr/bin/unrar
Jun 30 20:17:36 oss01 MailScanner[32416]: Using locktype = flock

so I don't see any errors

Can anyone recommend what I need to check ?

Regards
Dean
Reply With Quote
Sponsored Links
  #2  
Old 2nd July 2008, 04:18
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Dean,

Glad to hear that you've given the Spamsnake a shot. You must be having permission issues. I would redo the following and reboot your server.

Code:
 
chown -R postfix:www-data /var/spool/MailScanner
chown -R postfix:www-data /var/lib/MailScanner
chown -R postfix:www-data /var/run/MailScanner
chown -R postfix:www-data /var/lock/subsys/MailScanner
chown -R postfix:www-data /var/spool/postfix/hold
chmod -R ug+rwx /var/spool/postfix/hold
chmod -R u+rwx,g+rx /var/spool/MailScanner/quarantine
Let me know if that works for you.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #3  
Old 2nd July 2008, 08:03
dean_za dean_za is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

chown -R postfix:www-data /var/run/MailScanner
chown: cannot access `/var/run/MailScanner': No such file or directory



ls -l /var/lock/subsys/
total 0
-rw-r--r-- 1 root root 0 2008-07-01 16:25 httpd.vmware
-rw-r--r-- 1 root root 0 2008-07-01 16:25 mailscanner
drwxr-xr-x 2 postfix www-data 60 2008-07-02 07:10 MailScanner
-rw-r--r-- 1 root root 0 2008-07-01 16:25 vmware

I do believe the system is working but it is not logging to the mysql database which is obviously where mailwatch(mailscaner webpage) is searching for info. If I "select * from maillog;" inside the mysql database I get no results , so that tells me nothing is going in. I do have data inside the geoip tables which tells me the database is setup and the usernames/passwordds are correct. So all I an assume is that mailscanner is not setup to log to the sql database . I have the sql settings in mailwatch.pm inside the CustomFunctions directory.

I am guessing the problem is in this area.

thanks for your help rocky.

regards
dean
Reply With Quote
  #4  
Old 2nd July 2008, 08:04
dean_za dean_za is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was thingking , how can I enable more verbose logging so I can see what mailscanner is sending to the database ?
Reply With Quote
  #5  
Old 2nd July 2008, 22:10
dean_za dean_za is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Fixed

Always Looked Up Last = &MailWatchLogging

so simple

Thanks again for a great setup
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
SpamSnake SpamAssassin not working? getrav HOWTO-Related Questions 5 23rd June 2008 23:02
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06


All times are GMT +2. The time now is 07:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.