Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2008, 03:09
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default noobie email questions with ispconfig and debian 4 etch

I'm having all sorts of email problems. I can't seem to send email to anyone, not from inside the network or outside the network, except I can send mail from inside the network to myself (root@server1.safetytg.com).

I can telnet to port 25
and then
ehlo localhost
and I get the proper output.

The username I'm using is web1_mark with the email address of mark@safetytg.com

When I'm on the box and type:

sendmail -v mark@safetytg.com
test
ctrl + d

I get the output sent to root which I can check in /var/mail/nobody (which is kind of weird that the root mail is going to nobody)

The output is this:

Code:
<web1_mark@server1.safetytg.com> (expanded from <mark@safetytg.com>): delivery
    via local: forwarded as 9D403180C54C

--99527180C54E.1214609960/server1.safetytg.com
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; server1.safetytg.com
X-Postfix-Queue-ID: 99527180C54E
X-Postfix-Sender: rfc822; root@server1.safetytg.com
Arrival-Date: Fri, 27 Jun 2008 16:39:18 -0700 (PDT)

Final-Recipient: rfc822; web1_mark@server1.safetytg.com
Original-Recipient: rfc822; mark@safetytg.com
Action: relayed
Status: 2.0.0
Diagnostic-Code: X-Postfix; delivery via local: forwarded as 9D403180C54C
The mail users seem to be:

Code:
server1:/var/mail# ls
admispconfig  nobody  web1_mark  web2_mark
But after sending mail to mark@safetytg.com there is no mail for that user and nothing inside the file web1_mark

I'll be the first to admit that I'm not exactly sure what I'm doing with setting up email accounts using ispconfig.

in /var/log/mail.log I'm not getting anything at all after sending mail as root to mark@safetytg.com

That's just internal mail so far. Any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 28th June 2008, 03:16
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

I'm not sure if this has anything to do with it but I'm getting these messages in my mail logs / warnings / errors:

Jun 26 02:35:34 server1 freshclam[19806]: Current functionality level = 29, recommended = 31
Jun 26 04:59:34 server1 freshclam[19806]: Your ClamAV installation is OUTDATED!
Jun 26 04:59:34 server1 freshclam[19806]: Local version: 0.93 Recommended version: 0.93.1

How do I update ClamAV to newest version?
Reply With Quote
  #3  
Old 29th June 2008, 01:17
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Just got off the phone with my ISP and they assured me port 25 was open for my account and on my router with a static ip address... oi. So far the email thing as been the most difficult to get working. Nothing I seem to do makes it send mail out to the real world. And I still can't seem to send mail from inside the network. And doing sendmail -v someemail@somedomain.com sends the report not to root but to /var/mail/nobody

Anyone know what's going on?
Reply With Quote
  #4  
Old 29th June 2008, 01:46
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Okay so apparently the person I talked to at AT&T was dumber than me.

AT&T digital line subscribers (dsl customers) can no longer relay through port 25, they have to do it through smtp.att.yahoo.com on port 465 using ssl email.

So my next question is...

How can I ensure all emai sent out is over that port and secure so that AT&T will route my email?
Reply With Quote
  #5  
Old 29th June 2008, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

These links might help:
http://ubuntuforums.org/archive/index.php/t-487843.html
http://forum.webfaction.com/viewtopic.php?pid=4184
http://www.eglug.org/book/export/html/1923
http://prantran.blogspot.com/2007/01...untu-with.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
biobrew (1st July 2008)
  #6  
Old 1st July 2008, 06:23
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Awesome. Still not working 100% but now I'm getting very specific authentication errors which is definitely a step in the right direction.

I don't really have a deadline on this so I haven't been on it like I should but when I get it working I'll post my entire main.cf file from and anything else I changed to make it work with port 587 and TLS..
Reply With Quote
  #7  
Old 3rd July 2008, 04:45
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

Okay I'm able to send out emails now using TLS and using something along the lines of:

sendmail -f "my_real_at&t_email_address@att.net" whoever@whereever.com

But... I still can't seem to send mail from me@mydomain.com

How can I make it so that I send emails from the right domain without having to send it from my username? This is kind of AT&T specific I guess, but before I started sending out emails with that "from" address, I was getting error 553 relaying denied from AT&T servers.

Is there a way to fudge the servers where I can send out a from address that doesn't get denied that's from my own domain?
Reply With Quote
  #8  
Old 3rd July 2008, 10:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,994
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

This might help you:

http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 3rd July 2008, 12:17
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
Default

I have it set up like that to a tee which is why I'm able to send out emails now, but I have to set the "from" option to my actual email from att.net that I get for having them as my ISP.

If I change the from option to anything else I get a 553 relay denied message.

so this works:

sendmail -f "my_real_email_from_my_isp_which_is_att@att.ne t" someone@somedomain.com

and this does not

sendmail -f "any_ol_made_up_email@any_ol_domain.com" someone@somewhere.com

AT&T's smtp authentication mechanism seems to be making me send a verified "From" with any relayed mail, regardless of having my username and password sent with the email using postfix's sasl_passwd method.

Am I just doing something really retarded? Shouldn't I be able to relay from any name/email address once I authenticate with them using the sasl_passwd method?
Reply With Quote
  #10  
Old 3rd July 2008, 12:44
biobrew biobrew is offline
Member
 
Join Date: Jun 2008
Posts: 34
Thanks: 5
Thanked 2 Times in 2 Posts
 
Default

Okay phew WOW this has been a learning adventure.

If you have AT&T and are having trouble relaying than this thread is for you:

So I've been on and off the phone with my ISP AT&T for days now at this...

I got this email not too long ago from them, this is the email verbatim:

Quote:
Dear AT&T Internet Services Member,

We have received questions regarding the following error message which is received by customers when they send e-mail using a non-verified e-mail address:

“Unable to send the message. Please verify the e-mail address in your account properties. The server responded: 553 From: address not verified.”

If you have received this error message, you will continue to receive it for emails sent with a non-verified address until you verify your Yahoo! email address or any other non AT&T email addresses (e.g., name@company.com, name@college.com, name@yahoo.com, etc.). Verification instructions are available on the AT&T Help site http://helpme.att.net/article.php?item=11646. If you have already verified your non AT&T email address and are no longer receiving the 553 error message, please disregard this email.

Thank you for your attention to this matter as we work to improve your Internet service. Our goal continues to be to make you a very satisfied customer. If you are experiencing any issues and would like to speak to a customer support representative, please contact us at 1-877-722-3755.

Sincerely,
AT&T Internet Services



Yahoo! is a registered trademark of Yahoo! Inc.
© 2008 AT&T Intellectual Property. All Rights Reserved. AT&T and the AT&T logo are trademarks of AT&T Intellectual Property.

If you visit the site that they link to in the email, it gives detailed instructions on how to set up a "verified" mail account by hand, one at a time, for each email address you would like to relay through their servers.

That part sucks. The fact that if I want to host websites at my house through my crappy DSL service, then every single email address I also want to host must be "verfieid" (they send you a verification code to the email address you register with them and you have to re-type it in their prompt).

So there it is, ISPConfig has worked great from the start, in fact, doing everything this site has told me has worked absolutely perfectly each time. The entire time emails were wonky because AT&T are absolute spam nazis.

I'd just like to give a big thanks to the guys here who write the tutorials and who answer these posts. you guys rule. You have completely renewed my interest in Linux. /sap
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ispconfig + awstats on debian etch Dennis Installation/Configuration 1 19th April 2008 23:57
Perfect setup Debian Etch ISPConfig - DNS Server kdclaver Installation/Configuration 16 28th December 2007 02:39
ISPCONFIG 2.2.14 Debian etch no email chrisrob301 Installation/Configuration 17 6th July 2007 17:52
Moving ISPConfig from Suse 10.1 to Debian Etch grasomega Installation/Configuration 3 27th April 2007 13:42
ISPconfig on debian ETCH provell Installation/Configuration 15 23rd January 2007 11:02


All times are GMT +2. The time now is 10:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.