Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th June 2008, 22:48
eume5mo eume5mo is offline
Junior Member
 
Join Date: Jun 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default site added not working, error Access forbidden!

I created user and added site on ispconfig.

user virtua
site web1
domain www.virtuawebhost.com.br


Locally the site opens, that message appears to change the file folder index of web,
ai good when someone attempts to access from outside, the Access forbidden! ...

vhost follows my file.

q be someone I pod of a light?


vhost_ispconfig.conf

Quote:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost www.virtuawebhost.com.br:80
<VirtualHost 201.1.19.37:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.virtuawebhost.com.br:80
######################################
#
#
<VirtualHost www.virtuawebhost.com.br:80>
SuexecUserGroup virtua web1
ServerName www.virtuawebhost.com.br:80
ServerAdmin admin@virtuawebhost.com.br
DocumentRoot /srv/www/web1/web
ServerAlias virtuawebhost.com.br
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
Alias /cgi-bin/ /srv/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /srv/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /srv/www/web1/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/web1/phptmp/
php_admin_value session.save_path /srv/www/web1/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/srv/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#
Reply With Quote
Sponsored Links
  #2  
Old 24th June 2008, 23:05
eume5mo eume5mo is offline
Junior Member
 
Join Date: Jun 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

lucaslinux:~ # /etc/init.d/apache2 restart
[Tue Jun 24 16:59:58 2008] [warn] NameVirtualHost www.virtuawebhost.com.br:80 has no VirtualHosts
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) [Tue Jun 24 16:59:59 2008] [warn] NameVirtualHost www.virtuawebhost.com.br:80 has no VirtualHosts
done


for reference, I do not know if this gives a mistake!
httpd.conf file in the entry to the file vhost
was.
/ etc/apache2/vhost.d
and not in
/ etc/apache2/vhost
as the ispconfig.

that will have some reference?
and note that when access the site www.virtuawebhost.com.br
No email from the webmaster
webmaster_virtuawebhost.com.br
but I setup in vhost
admin@virtuawebhost.com.br

not strange?


sorry my bad inglish, i am from Brazil
Reply With Quote
  #3  
Old 25th June 2008, 23:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

Your Vhosts_ispconfig.conf should look like this:

Code:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 201.1.19.37:80
<VirtualHost 201.1.19.37:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.virtuawebhost.com.br:80
######################################
#
#
<VirtualHost 201.1.19.37:80>
SuexecUserGroup virtua web1
ServerName www.virtuawebhost.com.br:80
ServerAdmin admin@virtuawebhost.com.br
DocumentRoot /srv/www/web1/web
ServerAlias virtuawebhost.com.br
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
Alias /cgi-bin/ /srv/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /srv/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /srv/www/web1/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /srv/www/web1/phptmp/
php_admin_value session.save_path /srv/www/web1/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/srv/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web1/user/$1/web/$3
</VirtualHost>
Is it possible that you listed www.virtuawebhost.com.br instead of an IP address under Management > Server > Settings?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
add web site serr57 Installation/Configuration 18 13th April 2008 12:40
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 15:22
ISPConfig 2.3.2-dev released till General 9 4th June 2007 11:46
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18
php script injections Grizzly General 21 18th July 2006 09:55


All times are GMT +2. The time now is 08:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.