Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th June 2008, 19:32
nucleide nucleide is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamsnake and local Maildir delivery

Hi,

I read the Spamsnake article, wich is very interesting, but if i fallow the procedure, i will have to put my email somewhere else.. i just have one server.

I fallow the Perfect Server 8.04 to have my email inside that server in Maildir, wich i access it in IMAP and i found that very cool... but the spamassassin side is poor, no much way to control the spam, compare to Spamsnake...

Is there any way to implement the SpamSnake over it and continue to have my email delivery the same way it as now?

Thanks.
Nucleide
Reply With Quote
Sponsored Links
  #2  
Old 23rd June 2008, 15:59
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hey,

You can use the Spamsnake as your mail gateway and it will sit infront of your mailserver. It will basically serve as a mailscanner for spam and viruses before relaying the mails to your mta. You can also set it up for outbound mails, but thats optional.

The Spamsnake will be seamless, as it will not affect your MTA at all.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #3  
Old 24th June 2008, 01:53
nucleide nucleide is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default i try it :(

Hi,

I decide to try it but it failed...

I'm no longer able to connect to my email in imap or pop3... and all my email as sent to /var/mail/{user} instead of Maildir/.

When i use webmin to see my email box, i saw the emails in Maildir/ but not the new emails.

I know that the spamsnake working, cause i see the new emails being filter bye spamassassin, but i cannot access it after! My postfix is configured to send the email to Maildir/... i think this is one of the component who don't return the mail to the Maildir/, perhaps Procmail!!!!

The problem is i use The Perfect server on my server and mix it wit The SpamSnake, but abviously i have a lot to learn from linux!

Tonight i will try to debug the problem and fallow the email process...

Thanks

Last edited by nucleide; 24th June 2008 at 03:04.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.