Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th February 2006, 23:30
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did Proftpd install removed vsftpd totally from system , and now i get this when trying to connect to ftp via isp .

Could not connect to localhost

Next >>

Any clue why?

Plus under services it says ftp is offline so how do i turn it online ?
cause this command give this :
Code:
[root@localhost /]# /etc/init.d/ispconfig_tcpserver start
-bash: /etc/init.d/ispconfig_tcpserver: No such file or directory
Reply With Quote
Sponsored Links
  #12  
Old 10th February 2006, 00:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Try
Code:
/etc/init.d/proftpd start
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 10th February 2006, 04:51
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got this Error :

[root@localhost ~]# /etc/init.d/proftpd start
-bash: /etc/init.d/proftpd: No such file or directory


So i tried this command :
[root@localhost ~]# /usr/local/sbin/proftpd start

Which initially gave error that group nogroup cannot be used it was present in the conf file of proftp so i edited it and made the group as daemon , and used above command (/usr/local/sbin/proftpd start) and it worked and ftp came online but when i created a client with ftp access enable and tried to login i could login isp panel for the user but not via ftp the ftp client kept saying wrong password and isp interface kept saying
Code:
	
Could not connect as user james

Next >>
Also i turned apache on , and when i tried visit my server using http://ip it showed this :

Code:
This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

For questions or problems please contact the server administrator.
and also the bind and pop3 server status in services shows offline .

So any clue how to fix all these errors? Oh there was no error i think while installing.
Reply With Quote
  #14  
Old 10th February 2006, 10:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by hosting
Got this Error :

[root@localhost ~]# /etc/init.d/proftpd start
-bash: /etc/init.d/proftpd: No such file or directory


So i tried this command :
[root@localhost ~]# /usr/local/sbin/proftpd start
What exactly did you do to install ProFTPd? Did you use your distribution's ProFTPd package?

Quote:
Originally Posted by hosting

Also i turned apache on , and when i tried visit my server using http://ip it showed this :

Code:
This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

For questions or problems please contact the server administrator.
If you create a web site www.example.com in ISPConfig, then you must use www.example.com in your browser's address bar, otherwise you see that Shared-IP page.

BTW, did you have a look at the "Perfect Setup" tutorials on HowtoForge? They prepare a distribution for the installation of ISPConfig so that ISPConfig works on them out of the box. I suggest that you have a look at these.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 11th February 2006, 00:57
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What exactly did you do to install ProFTPd? Did you use your distribution's ProFTPd package?


If you create a web site www.example.com in ISPConfig, then you must use www.example.com in your browser's address bar, otherwise you see that Shared-IP page.

BTW, did you have a look at the "Perfect Setup" tutorials on HowtoForge? They prepare a distribution for the installation of ISPConfig so that ISPConfig works on them out of the box. I suggest that you have a look at these.

To install Proftpd i did this :

Code:
Downloaded the latest stable source from proftpd.org (http://www.proftpd.org) and extracted. Then ran:
    # ./configure --with-modules=mod_sql:mod_sql_mysql:mod_quotatab:mod_quotatab_sql \
    --with-includes=/usr/include/mysql --with-libraries=/usr/lib/mysql \
    --sysconfdir=/etc --localstatedir=/var

    # make
    # make install.
And in the isp config i had put ip instead of domain , so shared ip i dunno understand u think putting more ip on server would solve it ?

And what is the link to perfect installation ?

But what about bind not working ? i tried using command the command and end up getting this error :

Code:
[root@localhost init.d]# ./named start
Starting named: /etc/named.conf:5: change directory to '/var/named/chroot/var/named' failed: file not found
/etc/named.conf:5: parsing failed

Feb 10 18:43:16.348 starting BIND 9.2.4 -g
Feb 10 18:43:16.349 using 2 CPUs
Feb 10 18:43:16.352 loading configuration from '/etc/named.conf'
Feb 10 18:43:16.352 listening on IPv4 interface lo, 127.0.0.1#53
Feb 10 18:43:16.353 listening on IPv4 interface eth0, 209.216.212.79#53
Feb 10 18:43:16.367 command channel listening on 127.0.0.1#953
Feb 10 18:43:16.367 command channel listening on ::1#953
Feb 10 18:43:16.367 ignoring config file logging statement due to -g option
Feb 10 18:43:16.367 couldn't open pid file '/var/named/chroot/var/run/named/named.pid': Permission denied
Feb 10 18:43:16.367 exiting (due to early fatal error)
Error in configuration file /etc/named.conf :              [FAILED]
[root@localhost init.d]#
Ok i removed bind from system and reinstalled it using yum install bind-chroot.i386 and now when i issue the command it says :
[root@localhost init.d]# ./named start
Starting named: [ OK ]
[root@localhost init.d]#

And shows online in isp. services menu as online, but pop3 still showing offline and ftp cannot be used . Do u have msn or yahoo falko?

Last edited by hosting; 11th February 2006 at 01:33.
Reply With Quote
  #16  
Old 11th February 2006, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by hosting
And in the isp config i had put ip instead of domain , so shared ip i dunno understand u think putting more ip on server would solve it ?
No, the amount of IP addresses has nothing to do with it. The Shared-IP page means that you must use the FQDN to access the web site, not the IP address.
If you host more than one web site on an IP address and just type in the IP address in your browser's address bar, how is Apache supposed to know which web site you want to see?

Quote:
Originally Posted by hosting
And what is the link to perfect installation ?
Fedora Core 3: http://www.howtoforge.com/perfect_setup_fedora_core_3
Fedora Core 4: http://www.howtoforge.com/perfect_setup_fedora_core_4

Quote:
Originally Posted by hosting
Do u have msn or yahoo falko?
No, I don't have any instant messengers.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 12th February 2006, 03:05
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok tried installing using that perfect install , but i didnt install fedora cause i dont want to pay my dc to do reload of os just for a control panel.

But when it finishes install it says these things and httpd it cannot start so when i try to start it fails :

Restarting some services...
httpd not running, trying to start
Shutting down sendmail: [ OK ]
Shutting down sm-client: [ OK ]
Starting sendmail: [ OK ]
Starting sm-client: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@localhost install_ispconfig]# service httpd start
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting httpd: [FAILED]
[root@localhost install_ispconfig]#

but when i try httpd -k start it turns apache on .
Reply With Quote
  #18  
Old 12th February 2006, 03:12
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

But u didnt tell me if i installed proftpd properly or not cause i cannot still login to ftp either using client or using isp itself , just keeps giving this error.
Code:
Response:	220 ProFTPD 1.2.10 Server (ProFTPD Default Installation) [someip]
Command:	USER james
Response:	331 Password required for james.
Command:	PASS ********
Response:	530 Login incorrect.
Error:	Unable to connect!
So any clue which file to edit or chmod or something to make ftp work atleast forget www , just ftp would be good enough for me . Under services these are the status of various services :

Code:
Web-Server:  	
Online
FTP-Server: 	
Online
SMTP-Server: 	
Online
POP3-Server: 	
Offline
BIND-Server: 	
Online
mySQL-Server: 	
Online
I can login to ftp using my older user account that i created mannually before doing the installation. But isp cannot create any user at all.
Reply With Quote
  #19  
Old 12th February 2006, 03:29
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just an update WWW works properly now as i can access sites using domain name . too bad no nameserver like ns1.mysite.com and ns2.mysite.com can be assigned , cause i dunno where to enter them . And cannot login to ftp maybe need to mannually for each user make ftp ?
Reply With Quote
  #20  
Old 12th February 2006, 06:21
hosting hosting is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hey here is the ftp output from command [root@localhost ~]# nano /etc/proftpd_ispconfig.conf

Code:

###################################
#
# ISPConfig proftpd Configuration File
#         Version 1.0
#
###################################
<VirtualHost someip>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>

And output from command [root@localhost ~]# nano /etc/proftpd.conf

Code:
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "ProFTPD Default Installation"
ServerType                      standalone
DefaultServer                   on

# Port 21 is the standard FTP port.
Port                            21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances                    30

# Set the user and group under which the server will run.
User                            ftp
Group                           ftp

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot ~

# Normally, we want files to be overwriteable.
AllowOverwrite          on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  DenyAll
</Limit>

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
  User                          ftp
  Group                         ftp

  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias                     anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients                    10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin                  welcome.msg
  DisplayFirstChdir             .message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>
</Anonymous>





Include /etc/proftpd_ispconfig.conf
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
eGroupWare Install crudolphy General 28 5th June 2007 19:09
Mandriva 2006 Install questions bersi Installation/Configuration 26 1st November 2006 16:52
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29


All times are GMT +2. The time now is 17:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.