Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th June 2008, 05:07
Forgott3n Forgott3n is offline
Junior Member
 
Join Date: Jun 2008
Posts: 3
Thanks: 4
Thanked 1 Time in 1 Post
Default BIND DNS + Webmin CentOS 5.1

Hello!

I installed BIND and configured via Webmin in the following manner:

Code:
$ttl 38400
sohipitmhz.com.	IN	SOA	ns1.sohipitmhz.com. justin\.bull.c3studios.ca. (
			1213586206
			10800
			3600
			604800
			38400 )

sohipitmhz.com. IN      NS      ns1.sohipitmhz.com.
sohipitmhz.com. IN      NS      ns2.sohipitmhz.com.

ns1.sohipitmhz.com.     IN      A       24.80.213.124
ns2.sohipitmhz.com.     IN      A       24.80.213.124

sohipitmhz.com.	IN	A	24.80.213.124

localhost.sohipitmhz.com.	IN	A	127.0.0.1

sohipitmhz.com.	IN	MX	0	sohipitmhz.com.

www	IN	CNAME	sohipitmhz.com.
mail	IN	CNAME	sohipitmhz.com.
bullbox	IN	A	24.80.213.124
and

Code:
options {
	directory "/etc";
	pid-file "/var/run/named/named.pid";
	};

zone "." {
	type hint;
	file "/etc/db.cache";
	};

zone "sohipitmhz.com" {
	type master;
	file "/var/named/sohipitmhz.com.hosts";
	};
I have BIND running with chroot (/var/named/chroot/) and LAMP. The Postfix hasn't been properly configured yet.

Here are the details:

Hostname: bullbox.sohipitmhz.com
IP Address: 24.80.213.124
Domain: sohipitmhz.com


So for some reason it doesn't work! Am I missing something in my configuration? Both nameservers are the same box.

Thank you!
Reply With Quote
Sponsored Links
  #2  
Old 20th June 2008, 13:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

You need a glue record for sohipitmhz.com: http://en.wikipedia.org/wiki/Domain_...d_glue_records
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th June 2008, 16:25
Forgott3n Forgott3n is offline
Junior Member
 
Join Date: Jun 2008
Posts: 3
Thanks: 4
Thanked 1 Time in 1 Post
Default

So the modified configuration would look like this?

Code:
$ttl 38400
sohipitmhz.com.	IN	SOA	ns1.sohipitmhz.com. justin\.bull.c3studios.ca. (
			1213586206
			10800
			3600
			604800
			38400 )

sohipitmhz.com. IN      NS      ns1.sohipitmhz.com.
sohipitmhz.com. IN      NS      ns2.sohipitmhz.com.

ns1.sohipitmhz.com.     IN      A       24.80.213.124
ns2.sohipitmhz.com.     IN      A       24.80.213.124

sohipitmhz.com.	IN	A	24.80.213.124

localhost.sohipitmhz.com.	IN	A	127.0.0.1

sohipitmhz.com.	IN	MX	0	sohipitmhz.com.

www	IN	CNAME	sohipitmhz.com.
mail	IN	CNAME	sohipitmhz.com.
bullbox	IN	A	24.80.213.124
ns1	IN	A	192.168.1.133	// LAN IP
ns2	IN	A	192.168.1.133	// LAN IP
Sorry, searching for definitive instructions of glue records has turned up mixed results.

Last edited by Forgott3n; 20th June 2008 at 16:33.
Reply With Quote
  #4  
Old 21st June 2008, 10:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

No, you must ask your registrar to set up glue records for your domain. That's nothing you can do yourself.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Google Apps dayjahone General 19 29th March 2008 17:25
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50
Webmin docs missing namit Server Operation 11 5th January 2006 09:51


All times are GMT +2. The time now is 20:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.