#1  
Old 30th April 2008, 05:55
tfunky tfunky is offline
Member
 
Join Date: Jan 2007
Posts: 85
Thanks: 4
Thanked 2 Times in 2 Posts
Default Mysql 5.1 on Etch

Hi All,

Has anyone installed 5.1 on Etch?

I followed the mysql5 cluster howto and judging by the info released on the mysql site, the additional speed and replication features seem to make it worth the upgrade...but I'm a whimp and I don't know how to do it/or if its worth doing.

Anyone want to weigh in?

Thanks!

Tfunky
Reply With Quote
Sponsored Links
  #2  
Old 1st May 2008, 20:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

I haven't tried this, but you could install the MySQL 5.1 package from experimental: http://packages.debian.org/experimen...sql-server-5.1
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd May 2008, 03:16
tfunky tfunky is offline
Member
 
Join Date: Jan 2007
Posts: 85
Thanks: 4
Thanked 2 Times in 2 Posts
Default

hmmm.....Experimental packages don't give me the warm fuzzies!

I'm may clone a copy of my server and give it a shot...I'll report back on what I find this weekend (hopefully)
Reply With Quote
  #4  
Old 6th June 2008, 00:19
petero petero is offline
Junior Member
 
Join Date: Jun 2008
Location: Poland
Posts: 4
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi tfunky
let me know how your 5.1 cluster is working i am running 5.1.24-rc made from sources.
I am still testing, i have some problems with connections.
Sometimes MySQL i saying that xxx user is denied by configuration and after retry it lets him connect. Permissions are OK, but i think it might be the problem with loadbalancers.

Peter
Reply With Quote
  #5  
Old 6th June 2008, 03:12
tfunky tfunky is offline
Member
 
Join Date: Jan 2007
Posts: 85
Thanks: 4
Thanked 2 Times in 2 Posts
Default

I'm not brave enough to build from source by my self, so I sort of gave up

I'm still running v5.

And actually I've run into so many problems w/ my homebuilt mysql server loadbalancer that I've downed the 2nd node and I'm just running off the one, main server until I get it worked out.

If you don't mind me asking, how did you get the load balancers configured to work correctly?

I tried using pound w/ setting the 3306 port and using tcp checks...and it forwards traffic correctly on the VIP to the main box. If I shut the main box down however, it does not redirect to the 2nd master

I'd love to hear how your progressing!!!~!

Thanks!

Tfunk
Reply With Quote
  #6  
Old 6th June 2008, 15:52
petero petero is offline
Junior Member
 
Join Date: Jun 2008
Location: Poland
Posts: 4
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Instead of my progress you will get full tutorial I am polishing some text to make it good.Let you know soon when it will be published.
Mysql Cluster 5.1 build from sources

Its way easier than you think
Peter
Reply With Quote
The Following User Says Thank You to petero For This Useful Post:
falko (7th June 2008)
  #7  
Old 7th June 2008, 03:03
tfunky tfunky is offline
Member
 
Join Date: Jan 2007
Posts: 85
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Can't wait to see it!!!
Reply With Quote
  #8  
Old 15th June 2008, 19:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

Here it is: http://www.howtoforge.com/setting-up...-with-mysql5.1
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
MySql Cluster on Etch Questions tfunky HOWTO-Related Questions 3 9th May 2007 06:08
Messed up ISPConfig-2.2.8 Upgrade Morons Installation/Configuration 4 29th November 2006 12:17
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 21:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.