Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 23rd June 2008, 17:14
lrider lrider is offline
Member
 
Join Date: Nov 2006
Posts: 70
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Hi again,

I figure out what happened here.

I am using the ISPConfig Remoting Framework 1.0 library to create the accounts from a web.

It just happens that an administrator used a file for a massive user creation and this file contained "line feeds" at the end of the name.

Causing this odd-look /etc/passwd and also affecting the proper functioning of the ispconfig update process.

I also find out that no check is done for a new user to have an email already asigned as an alias to another user.

The ISPConfig Remoting Framework library creates the user, all the process work's fine, but the sendmail fails because there are repeated entries in the /etc/mail/virtusertable file.

Also this lead to an incomplete updated configuration, so mail worked fine for old accounts but "rare" for some of the new ones.

Leaving the "email" server working in a rather "extrange" mode since the virtusertable.db file is old in respect to the rest of the configuration.

I cleaned the names of "unwanted" characters and erased the repeated aliases and everything went back to normal.

Thank's again and hope this information is good for you improve the ispconfig software.

Larry.
Reply With Quote
Sponsored Links
  #12  
Old 23rd June 2008, 17:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,009
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Good to know that you used the remoting framework. The ISPConfig interface is checking for line feeds and duplicate aliases, but the remoting framework just contains low level functions to access ispconfig, so the checks have to be done by the script that uses the remoting framework.

I will see if we can implement at least the line feed problem in the server part as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 23rd June 2008, 17:26
lrider lrider is offline
Member
 
Join Date: Nov 2006
Posts: 70
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

Thank's to you.

Keep up the good work.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally a working postfix server. But need a easy dns configuration mnewbegin Server Operation 5 17th October 2007 23:35
Bounce emails not working lapena Installation/Configuration 3 2nd July 2007 19:52
Few questions about Hostname and emails vladoportos Installation/Configuration 4 4th June 2007 15:20
emails not working andyreynolds Installation/Configuration 11 21st March 2007 16:57
Emails suddenly not working -- centos3 and ispconfig mxc General 5 16th November 2006 15:54


All times are GMT +2. The time now is 15:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.