Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 8th February 2006, 23:52
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
Default

here is what I got, also I have logged in as root

[root@server ~]# /root/.profile
bash: /root/.profile: No such file or directory
[root@server ~]# /etc/profile
bash: /etc/profile: Permission denied
[root@server ~]#

There is a Question!! am planning to try to deploy a web server using ISPConfig, but first am trying to meet perfect fedora core 4 setup, and I got a question about IP addresses, I got a public one but when creating eth0 and eth0:0 I got the public IP, but what about the :0 address.

I know that I need to run a firewall, and I got Astaro but I don't know how to configure it, so am stuck again there.

Thanks for advise.
__________________
Eli Acevedo

Last edited by cybereatl; 9th February 2006 at 00:12.
Reply With Quote
Sponsored Links
  #12  
Old 9th February 2006, 01:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by cybereatl
[root@server ~]# /etc/profile
bash: /etc/profile: Permission denied
[root@server ~]#
Try
Code:
cat /etc/profile
However, you can create /root/.profile with the following content:

Code:
# ~/.profile: executed by Bourne-compatible login shells.

if [ -f ~/.bashrc ]; then
  . ~/.bashrc
fi

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11
export PATH

mesg n
Then log out and log in as root again and run
Code:
echo $PATH
again and check if /sbin is in there now.

Quote:
Originally Posted by cybereatl
There is a Question!! am planning to try to deploy a web server using ISPConfig, but first am trying to meet perfect fedora core 4 setup, and I got a question about IP addresses, I got a public one but when creating eth0 and eth0:0 I got the public IP, but what about the :0 address.
The part about eth0:0 is totally optional, you don't need it. It's there to show you how you do it if you hae more than one IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 9th February 2006, 15:21
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
Default

I did follow your instructions and I got:

Create file .profile and paste it in /root the log out and get back in then run:
[root@morticia ~]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
[root@morticia ~]# quotacheck -avugm
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
[root@morticia ~]# quotaon -avug
[root@morticia ~]#

In the mean time I was following step to have Fedora up and running and then I found on:
[root@morticia ssl]# openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
that is asking me for:
[root@morticia ssl]# openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
180 semi-random bytes loaded
Generating RSA private key, 1024 bit long modulus
..................................++++++
.......++++++
e is 65537 (0x10001)
Enter pass phrase for smtpd.key:
and I typed the root password and then:
Verifying - Enter pass phrase for smtpd.key:
back again and typed root password.

Am doing it right or not?? later I filled out the certificate info.

Now I got this:
[root@morticia ssl]# chkconfig ipop3s on
error reading information on service ipop3s: No such file or directory
[root@morticia ssl]#
the other were just fine, just got that error

Then I went thru:

[root@morticia ssl]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
[root@morticia ssl]#

So not everything is fine!!!!
__________________
Eli Acevedo

Last edited by cybereatl; 9th February 2006 at 19:31.
Reply With Quote
  #14  
Old 9th February 2006, 22:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by cybereatl
I did follow your instructions and I got:

Create file .profile and paste it in /root the log out and get back in then run:
[root@morticia ~]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
[root@morticia ~]# quotacheck -avugm
quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
[root@morticia ~]# quotaon -avug
[root@morticia ~]#
Ok, your PATH is correct now. But you forgot to add
Code:
,userquota,groupquota
into /etc/fstab and remount the appropriate partition. Please have a look at the "Perfect Setup" tutorial for Fedora, it's shown there.

Quote:
Originally Posted by cybereatl
Enter pass phrase for smtpd.key:
and I typed the root password and then:
Verifying - Enter pass phrase for smtpd.key:
back again and typed root password.

Am doing it right or not?? later I filled out the certificate info.
It can be any password you want. It's not important.

[QUOTE=cybereatl]Now I got this:
[root@morticia ssl]# chkconfig ipop3s on
error reading information on service ipop3s: No such file or directory
[root@morticia ssl]#
the other were just fine, just got that error[/QUOTE[

It must be
Code:
chkconfig pop3s on
(without i).

Quote:
Originally Posted by cybereatl
Then I went thru:

[root@morticia ssl]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
[root@morticia ssl]#

So not everything is fine!!!!
Any errors in the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 10th February 2006, 00:13
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
Default

here is /etc/fstab content:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0

I did add it before!!!

Where to check ¿Any errors in the mail log?

Thanks
__________________
Eli Acevedo
Reply With Quote
  #16  
Old 10th February 2006, 00:39
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
Default

After a soft reboot I got quota working, please check if everything seems to be ok:

[root@morticia ssl]# touch /aquota.user
[root@morticia ssl]# touch /aquota.group
[root@morticia ssl]# chmod 600 /aquota.*
[root@morticia ssl]# mount -o remount /
[root@morticia ssl]# quotacheck -avugm
quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] done
quotacheck: Checked 8855 directories and 98024 files
[root@morticia ssl]# quotaon -avug
/dev/mapper/VolGroup00-LogVol00 [/]: group quotas turned on
/dev/mapper/VolGroup00-LogVol00 [/]: user quotas turned on
[root@morticia ssl]#

But

[root@morticia ssl]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
[root@morticia ssl]#

Where I can check mail logs??
__________________
Eli Acevedo
Reply With Quote
  #17  
Old 10th February 2006, 01:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by cybereatl
After a soft reboot I got quota working
Then you had forgotten before to remount /:
Code:
mount -o remount /
Quote:
Originally Posted by cybereatl
please check if everything seems to be ok:

[root@morticia ssl]# touch /aquota.user
[root@morticia ssl]# touch /aquota.group
[root@morticia ssl]# chmod 600 /aquota.*
[root@morticia ssl]# mount -o remount /
[root@morticia ssl]# quotacheck -avugm
quotacheck: WARNING - Quotafile //aquota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile //aquota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] done
quotacheck: Checked 8855 directories and 98024 files
[root@morticia ssl]# quotaon -avug
/dev/mapper/VolGroup00-LogVol00 [/]: group quotas turned on
/dev/mapper/VolGroup00-LogVol00 [/]: user quotas turned on
[root@morticia ssl]#
That's ok.

Quote:
Originally Posted by cybereatl
But

[root@morticia ssl]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
[root@morticia ssl]#

Where I can check mail logs??
The mail log is in the /var/log directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 10th February 2006, 02:24
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
Default

Thanks again, here is content for maillog

Feb 8 16:42:43 morticia sendmail[1999]: alias database /etc/aliases rebuilt by root
Feb 8 16:42:44 morticia sendmail[1999]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Feb 8 16:42:45 morticia sendmail[2004]: starting daemon (8.13.4): SMTP+queueing@01:00:00
Feb 8 16:42:46 morticia sm-msp-queue[2009]: starting daemon (8.13.4): queueing@01:00:00
Feb 8 17:48:21 morticia sendmail[3983]: k18MmK0K003983: from=root, size=814, class=0, nrcpts=1, msgid=<200602082248.k18MmK0K003983@morticia.educan dote.net>, relay=root@localhost
Feb 8 17:48:23 morticia sendmail[3985]: k18MmMw5003985: from=<root@morticia.educandote.net>, size=1126, class=0, nrcpts=1, msgid=<200602082248.k18MmK0K003983@morticia.educan dote.net>, proto=ESMTP, daemon=MTA, relay=morticia.educandote.net [127.0.0.1]
Feb 8 17:48:23 morticia sendmail[3983]: k18MmK0K003983: to=root, ctladdr=root (0/0), delay=00:00:03, xdelay=00:00:02, mailer=relay, pri=30814, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (k18MmMw5003985 Message accepted for delivery)
Feb 8 17:48:25 morticia sendmail[3986]: k18MmMw5003985: to=<root@morticia.educandote.net>, ctladdr=<root@morticia.educandote.net> (0/0), delay=00:00:02, xdelay=00:00:01, mailer=local, pri=31370, dsn=2.0.0, stat=Sent
Feb 9 07:48:13 morticia sendmail[2077]: alias database /etc/aliases rebuilt by root
Feb 9 07:48:13 morticia sendmail[2077]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
Feb 9 07:48:14 morticia sendmail[2081]: starting daemon (8.13.4): SMTP+queueing@01:00:00
Feb 9 07:48:14 morticia sm-msp-queue[2087]: starting daemon (8.13.4): queueing@01:00:00
Feb 9 08:53:39 morticia sendmail[3803]: k19DrcAC003803: from=root, size=6276, class=0, nrcpts=1, msgid=<200602091353.k19DrcAC003803@morticia.educan dote.net>, relay=root@localhost
Feb 9 08:53:39 morticia sendmail[3804]: k19Drdje003804: from=<root@morticia.educandote.net>, size=6588, class=0, nrcpts=1, msgid=<200602091353.k19DrcAC003803@morticia.educan dote.net>, proto=ESMTP, daemon=MTA, relay=morticia.educandote.net [127.0.0.1]
Feb 9 08:53:39 morticia sendmail[3803]: k19DrcAC003803: to=root, ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=36276, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (k19Drdje003804 Message accepted for delivery)
Feb 9 08:53:40 morticia sendmail[3806]: k19Drdje003804: to=<root@morticia.educandote.net>, ctladdr=<root@morticia.educandote.net> (0/0), delay=00:00:01, xdelay=00:00:01, mailer=local, pri=36832, dsn=2.0.0, stat=Sent
Feb 9 12:34:08 morticia postfix/postfix-script: starting the Postfix mail system
Feb 9 12:34:08 morticia postfix/master[32050]: daemon started -- version 2.2.2, configuration /etc/postfix
Feb 9 12:35:00 morticia postfix/smtpd[32083]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
Feb 9 12:35:01 morticia postfix/master[32050]: warning: process /usr/libexec/postfix/smtpd pid 32083 exit status 1
Feb 9 12:35:01 morticia postfix/master[32050]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Feb 9 16:59:20 morticia postfix/smtpd[1923]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
Feb 9 16:59:21 morticia postfix/master[32050]: warning: process /usr/libexec/postfix/smtpd pid 1923 exit status 1
Feb 9 16:59:21 morticia postfix/master[32050]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Feb 9 17:26:10 morticia postfix/postfix-script: starting the Postfix mail system
Feb 9 17:26:10 morticia postfix/master[2028]: daemon started -- version 2.2.2, configuration /etc/postfix
Feb 9 17:32:06 morticia postfix/smtpd[2702]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
Feb 9 17:32:07 morticia postfix/master[2028]: warning: process /usr/libexec/postfix/smtpd pid 2702 exit status 1
Feb 9 17:32:07 morticia postfix/master[2028]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Feb 9 17:33:39 morticia postfix/smtpd[2720]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
Feb 9 17:33:40 morticia postfix/master[2028]: warning: process /usr/libexec/postfix/smtpd pid 2720 exit status 1
Feb 9 17:33:40 morticia postfix/master[2028]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Feb 9 17:44:29 morticia postfix/smtpd[2876]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
Feb 9 17:44:30 morticia postfix/master[2028]: warning: process /usr/libexec/postfix/smtpd pid 2876 exit status 1
Feb 9 17:44:30 morticia postfix/master[2028]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Feb 9 19:17:59 morticia postfix/postfix-script: starting the Postfix mail system
Feb 9 19:17:59 morticia postfix/master[2028]: daemon started -- version 2.2.2, configuration /etc/postfix
__________________
Eli Acevedo
Reply With Quote
  #19  
Old 10th February 2006, 11:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by cybereatl
Feb 9 17:44:29 morticia postfix/smtpd[2876]: fatal: unknown smtpd_sasl_security_options value "noanonnymous" in "noanonnymous"
You made a typo in your /etc/postfix/main.cf. Please run
Code:
postconf -e 'smtpd_sasl_security_options = noanonymous'
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 10th February 2006, 16:19
cybereatl cybereatl is offline
Senior Member
 
Join Date: Jan 2006
Posts: 255
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to cybereatl
 
Exclamation

Thanks for your help!!

I did change error and typed:
It's works like a charm!!! now am moving on to next step thanks a lot.

Now i got some errors:
Those are in the perl.txt file!!!
It seems to be that every step got some to do!!
Attached Files
File Type: txt perl.txt (2.3 KB, 278 views)
__________________
Eli Acevedo

Last edited by cybereatl; 10th February 2006 at 17:23.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to perfect install SNMP and MRTG in Fedora Core 3??? fandi2000x Installation/Configuration 5 5th July 2006 22:48
Perfect Setup - Fedora Core 3 - saslauthd problem Median Installation/Configuration 28 29th January 2006 19:51
ISPCONFIG installation problem with Fedora Core 4 (64 bit) dchowdhu Installation/Configuration 5 25th January 2006 07:21
Fedora Core 4 - The Perfect Setup nandhu HOWTO-Related Questions 27 10th January 2006 13:23
Few questions about Fedora core 4 perfect setup + mantasman HOWTO-Related Questions 3 9th January 2006 23:22


All times are GMT +2. The time now is 13:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.