Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th June 2008, 17:31
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default how to access to personal web pages that uploaded in a ftp account?

Hi,

By using fireFTP, I login to various ftp accounts that has been created in ISPconfig and upload anything I want.
But how can I access to my personal page by browser?
I test "www.mydomain.com/~user1" and "www.mydomain.com/users/user1" but ISPconfig say "403 Error- Forbidden!"
where is the problem?

Thanks,
__________________
freesqrt
Reply With Quote
Sponsored Links
  #2  
Old 9th June 2008, 13:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Take a look at chapter 2.2.9 on http://ispconfig.org/downloads/manua...nde_en_src.htm

If it still doesn't work, are there any errors in Apache's error log? Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th June 2008, 13:23
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default

Dear Falko,

I cheched /var/log/httpd/error_log but nothing was there except "[error] an unknown filter was not added: PHP".
what should be there about this problem?
I use fedora core 8 (version 2.6.23) with ISPconfig 2.2.23.

Thank you for your attentions,

Edit:

I checked "/home/web2/log/error.log" and found the following error:

###################################
[Wed Jun 11 11:58:17 2008] [error] [client 80.0.0.27] Directory index forbidden by Options directive: /home/web2/user/user1/web/
###################################
permission for "web" folder of user1 is 775.
permission for its contents (index.html) is 664

what it meant?
__________________
freesqrt

Last edited by freesqrt; 11th June 2008 at 12:44.
Reply With Quote
  #4  
Old 11th June 2008, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

At the end of your Apache configuration you should see something like this:

Code:
<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
Change it to

Code:
<Directory /home/*/user/*/web>
    Options +Includes +Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
and restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 15th June 2008, 07:57
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default

It works!!!!!!!

Thank you very much Falko,
__________________
freesqrt
Reply With Quote
  #6  
Old 30th July 2008, 09:35
schmidtedv schmidtedv is offline
Senior Member
 
Join Date: Jun 2006
Location: Germany, Kaarst
Posts: 152
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via MSN to schmidtedv Send a message via Skype™ to schmidtedv
Default

if -indexes is standard here for ispconfig, is it ok to deactivate autoindex_mod for apache because its useless (if i do no changes in config)? Or will -indexes only work if autoindex is active?
Reply With Quote
  #7  
Old 31st July 2008, 19:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

I haven't tried this, but possibly you get a syntax error if you disable mod_autoindex.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 31st July 2008, 20:00
schmidtedv schmidtedv is offline
Senior Member
 
Join Date: Jun 2006
Location: Germany, Kaarst
Posts: 152
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via MSN to schmidtedv Send a message via Skype™ to schmidtedv
Default

so -indexes is implementing ispconfigs own function to disable autoindex for apache/web-dirs? I have tested now with reenabling autoindex and the -indexes does the job...right?

(would be a nice feature in web-administration to en/disable this for the admin maybe?)
Reply With Quote
  #9  
Old 1st August 2008, 14:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by schmidtedv View Post
so -indexes is implementing ispconfigs own function to disable autoindex for apache/web-dirs?
No, that's standard Apache syntax, nothing ISPConfig-specific.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 1st August 2008, 15:19
schmidtedv schmidtedv is offline
Senior Member
 
Join Date: Jun 2006
Location: Germany, Kaarst
Posts: 152
Thanks: 3
Thanked 0 Times in 0 Posts
Send a message via MSN to schmidtedv Send a message via Skype™ to schmidtedv
 
Default

ok, thx...well after postfix apache2 will be my next lecture... :-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 22:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 20:38
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 09:03
Website users? ctroyp General 25 6th January 2006 19:02
FTP access to web files in ISPConfig Rocky Installation/Configuration 14 9th November 2005 00:17


All times are GMT +2. The time now is 22:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.