Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th February 2006, 07:26
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's in /etc/postfix/main.cf?



# SOFT BOUNCE
#

#
#soft_bounce = no

# LOCAL PATHNAME INFORMATION
#

# The command_directory parameter specifies the location of all
# postXXX commands.
#
command_directory = /usr/sbin

# The daemon_directory parameter specifies the location of all Postfix

#
daemon_directory = /usr/lib/postfix

# QUEUE AND PROCESS OWNERSHIP
.

#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#

#
myhostname =$mydomain
#myhostname = virtual.domain.tld


#
mydomain =cosmoforge.com

# SENDING MAIL
#

#
myorigin = $myhostname
#myorigin = mail.cosmoforge.com

# RECEIVING MAIL


inet_interfaces = all
#inet_interfaces = $myhostname, localhost

# The proxy_interfaces parameter specifies the network interface

#
#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# The #mydestination parameter specifies the list of domains that this


# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = /etc/postfix/local-host-names
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
# mail.$mydomain, www.$mydomain, ftp.$mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
#

#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify a bare username, an @domain.tld
# wild-card, or specify a user@domain.tld address.
#
local_recipient_maps = unixasswd.byname $alias_maps
#local_recipient_maps = proxy:unixasswd.byname $alias_maps
#local_recipient_maps =


# local_recipient_maps settings are OK.
#
unknown_local_recipient_reject_code = 550

# TRUST AND RELAY CONTROL


#

mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host

# Alternatively, you can specify the mynetworks list by hand, in
#
mynetworks = 168.100.189.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

# The relay_domains parameter restricts what destinations this system will

# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace. Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
#
#
relay_domains = $mydestination
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction description in postconf(5).
#

# INTERNET OR INTRANET


#relayhost = $mydomain
#relayhost = [cosmoforge.com]:25
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

# REJECTING UNKNOWN RELAY USERS
#

#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL
#
#
# Specify 0 to disable the feature. Valid delays are 0..10.
#
#in_flow_delay = 1s

# ADDRESS REWRITING
#
# The ADDRESS_REWRITING_README document gives information about
# address masquerading or other forms of address rewriting including
# username->Firstname.Lastname mapping.

# ADDRESS REDIRECTION (VIRTUAL DOMAIN)
#
# The VIRTUAL_README document gives information about the many forms
# of domain hosting that Postfix supports.

# "USER HAS MOVED" BOUNCE MESSAGES
#
# See the discussion in the ADDRESS_REWRITING_README document.

# TRANSPORT MAP
#
# See the discussion in the ADDRESS_REWRITING_README document.

# ALIAS DATABASE
#
#
#alias_maps = dbm:/etc/aliases
alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases


#alias_database = dbm:/etc/aliases
#alias_database = dbm:/etc/mail/aliases
alias_database = hash:/etc/aliases
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases

# ADDRESS EXTENSIONS (e.g., user+foo)
#recipient_delimiter = +

# DELIVERY TO MAILBOX
#

#
#home_mailbox = /var/mail
home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
mail_spool_directory = /var/spool/mail


mailbox_command =
#mailbox_command = /some/where/procmail -a "$EXTENSION"


#
#mailbox_transport = lmtp:unix:/file/name
#mailbox_transport = cyrus

# The fallback_transport specifies the optional transport in master.cf
# to use for recipients that are not found in the UNIX passwd database.
# This parameter has precedence over the luser_relay parameter.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf. The
# :nexthop part is optional. For more details see the samp

virtual_alias_domains = hash:/etc/postfix/virtual
#virtual_alias_maps = hash:/etc/postfix/virtual
transport_maps = hash:/etc/postfix/transport
smtpd_sasl_local_domain =$myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous


#
setgid_group = mail
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
Reply With Quote
Sponsored Links
  #12  
Old 10th February 2006, 04:33
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default /etc/postfix/main.cf are here with

Quote:
Originally Posted by gimhan90
# SOFT BOUNCE
#

#
#soft_bounce = no

# LOCAL PATHNAME INFORMATION
#

# The command_directory parameter specifies the location of all
# postXXX commands.
#
command_directory = /usr/sbin

# The daemon_directory parameter specifies the location of all Postfix

#
daemon_directory = /usr/lib/postfix

# QUEUE AND PROCESS OWNERSHIP
.

#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#

#
myhostname =$mydomain
#myhostname = virtual.domain.tld


#
mydomain =cosmoforge.com

# SENDING MAIL
#

#
myorigin = $myhostname
#myorigin = mail.cosmoforge.com

# RECEIVING MAIL


inet_interfaces = all
#inet_interfaces = $myhostname, localhost

# The proxy_interfaces parameter specifies the network interface

#
#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# The #mydestination parameter specifies the list of domains that this


# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
#mydestination = /etc/postfix/local-host-names
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
# mail.$mydomain, www.$mydomain, ftp.$mydomain

# REJECTING MAIL FOR UNKNOWN LOCAL USERS
#

#
# The right-hand side of the lookup tables is conveniently ignored.
# In the left-hand side, specify a bare username, an @domain.tld
# wild-card, or specify a user@domain.tld address.
#
local_recipient_maps = unixasswd.byname $alias_maps
#local_recipient_maps = proxy:unixasswd.byname $alias_maps
#local_recipient_maps =


# local_recipient_maps settings are OK.
#
unknown_local_recipient_reject_code = 550

# TRUST AND RELAY CONTROL


#

mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host

# Alternatively, you can specify the mynetworks list by hand, in
#
mynetworks = 168.100.189.0/28, 127.0.0.0/8
#mynetworks = $config_directory/mynetworks
#mynetworks = hash:/etc/postfix/network_table

# The relay_domains parameter restricts what destinations this system will

# Specify a list of hosts or domains, /file/name patterns or type:name
# lookup tables, separated by commas and/or whitespace. Continue
# long lines by starting the next line with whitespace. A file name
# is replaced by its contents; a type:name table is matched when a
# (parent) domain appears as lookup key.
#
#
#
relay_domains = $mydestination
# NOTE: Postfix will not automatically forward mail for domains that
# list this system as their primary or backup MX host. See the
# permit_mx_backup restriction description in postconf(5).
#

# INTERNET OR INTRANET


#relayhost = $mydomain
#relayhost = [cosmoforge.com]:25
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

# REJECTING UNKNOWN RELAY USERS
#

#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL
#
#
# Specify 0 to disable the feature. Valid delays are 0..10.
#
#in_flow_delay = 1s

# ADDRESS REWRITING
#
# The ADDRESS_REWRITING_README document gives information about
# address masquerading or other forms of address rewriting including
# username->Firstname.Lastname mapping.

# ADDRESS REDIRECTION (VIRTUAL DOMAIN)
#
# The VIRTUAL_README document gives information about the many forms
# of domain hosting that Postfix supports.

# "USER HAS MOVED" BOUNCE MESSAGES
#
# See the discussion in the ADDRESS_REWRITING_README document.

# TRANSPORT MAP
#
# See the discussion in the ADDRESS_REWRITING_README document.

# ALIAS DATABASE
#
#
#alias_maps = dbm:/etc/aliases
alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases


#alias_database = dbm:/etc/aliases
#alias_database = dbm:/etc/mail/aliases
alias_database = hash:/etc/aliases
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases

# ADDRESS EXTENSIONS (e.g., user+foo)
#recipient_delimiter = +

# DELIVERY TO MAILBOX
#

#
#home_mailbox = /var/mail
home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
mail_spool_directory = /var/spool/mail


mailbox_command =
#mailbox_command = /some/where/procmail -a "$EXTENSION"


#
#mailbox_transport = lmtp:unix:/file/name
#mailbox_transport = cyrus

# The fallback_transport specifies the optional transport in master.cf
# to use for recipients that are not found in the UNIX passwd database.
# This parameter has precedence over the luser_relay parameter.
#
# Specify a string of the form transport:nexthop, where transport is
# the name of a mail delivery transport defined in master.cf. The
# :nexthop part is optional. For more details see the samp

virtual_alias_domains = hash:/etc/postfix/virtual
#virtual_alias_maps = hash:/etc/postfix/virtual
transport_maps = hash:/etc/postfix/transport
smtpd_sasl_local_domain =$myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous


#
setgid_group = mail
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

above i have attched the main.cf .

Reply With Quote
  #13  
Old 13th February 2006, 07:12
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gimhan90
above i have attched the main.cf .

Herewith i have attched the main.cf . Please look at this and help me to solve the problem .
thx
Reply With Quote
  #14  
Old 13th February 2006, 09:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Hm, I can't find anything wrong in it. You can try to comment out this line:

Code:
virtual_alias_domains = hash:/etc/postfix/virtual
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 13th February 2006, 12:35
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Hm, I can't find anything wrong in it. You can try to comment out this line:

Code:
virtual_alias_domains = hash:/etc/postfix/virtual
and restart Postfix.

additionaly ,

mynetworks = 168.100.189.0/28, 127.0.0.0/8
do i need to put the ip of postfix server runs here ?
Reply With Quote
  #16  
Old 13th February 2006, 17:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by gimhan90
additionaly ,

mynetworks = 168.100.189.0/28, 127.0.0.0/8
do i need to put the ip of postfix server runs here ?
No, it's already in there (127.0.0.0/8).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 14th February 2006, 05:33
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Hm, I can't find anything wrong in it. You can try to comment out this line:

Code:
virtual_alias_domains = hash:/etc/postfix/virtual
and restart Postfix.

I tried as u mentioned above , But got the same error again, .Any hints to resolve the issue sir?

Delivery to the following recipient failed permanently:

lasitha@cosmoforge.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <xproxy.gmail.com[66.249.82.205]>: Client host rejected: Access denied

----- Original message -----

Received: by 10.70.8.11 with SMTP id 11mr3198198wxh;
Mon, 13 Feb 2006 20:30:23 -0800 (PST)
Received: by 10.70.130.18 with HTTP; Mon, 13 Feb 2006 20:30:23 -0800 (PST)
Message-ID: <4b237c5b0602132030j68768155i2c9b0f5facd685e3@mail .gmail.com>
Date: Tue, 14 Feb 2006 10:30:23 +0600
From: G i m h a n <gimhan@gmail.com>
To: lasitha@cosmoforge.com
Subject: test
MIME-Version: 1.0
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0KCiAgLS0tLS0tLS0tbzAwby0tKF8pLS1vMDBvLS0tLS0tLS 0tLS0tLS0tLS0KICAgR2ltaGFu
IFByaXlhbnRoYS9UZWFtIFZpcnR1c2GZCi0tLS0tLW9vbzAtLS 0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tCiAgICAoICAgKSAgICAgMG9vbwogICAgIFwgKC AgICAgICggICApCiAgICAgIFxf
KSAgICAgICkgLwogICAgICAgICAgICAgIChfLwo=
Reply With Quote
  #18  
Old 14th February 2006, 21:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I've just done a telnet:

Code:
~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
The problem might be that su93254144.aspadmin.net doesn't exist in DNS:

Code:
~# dig su93254144.aspadmin.net

; <<>> DiG 9.2.4 <<>> su93254144.aspadmin.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61140
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;su93254144.aspadmin.net.       IN      A

;; AUTHORITY SECTION:
aspadmin.net.           3600    IN      SOA     ns1.aspadmin.com. domain_control.aspadmin.net. 1138989342 43200 7200 1209600 43200

;; Query time: 153 msec
;; SERVER: 145.253.2.75#53(145.253.2.75)
;; WHEN: Tue Feb 14 19:49:29 2006
;; MSG SIZE  rcvd: 108
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 15th February 2006, 07:06
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
I've just done a telnet:

Code:
~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 su93254144.cosmoforge.com ESMTP Postfix
ehlo localhost
250-su93254144.cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
The problem might be that su93254144.aspadmin.net doesn't exist in DNS:

Code:
~# dig su93254144.aspadmin.net

; <<>> DiG 9.2.4 <<>> su93254144.aspadmin.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61140
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;su93254144.aspadmin.net.       IN      A

;; AUTHORITY SECTION:
aspadmin.net.           3600    IN      SOA     ns1.aspadmin.com. domain_control.aspadmin.net. 1138989342 43200 7200 1209600 43200

;; Query time: 153 msec
;; SERVER: 145.253.2.75#53(145.253.2.75)
;; WHEN: Tue Feb 14 19:49:29 2006
;; MSG SIZE  rcvd: 108




su93254144:/etc/postfix # telnet mail.cosmoforge.com 25
Trying 66.240.254.14
Connected to mail.cosmoforge.com.
Escape character is '^]'.
220 cosmoforge.com ESMTP Postfix
ehlo localhost
250-cosmoforge.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.



In my main.cf i put like below,

myhostname = su93254144.$mydomain
mydomain =cosmoforge.com

su93254144 is the machine name that they provided.

( Last login: Mon Feb 13 22:15:20 2006 from 220.247.234.159
Have a lot of fun...
su93254144:~ #
)

Are those configurations wrong or ..? ( mydomain & myhostname)
or is it enough to put $mydoian for myhostname ( i.e myhostname = $mydomain
I am getting dns service from a DNS service provider .

Last edited by gimhan90; 15th February 2006 at 07:14.
Reply With Quote
  #20  
Old 15th February 2006, 09:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Now I'm seeing this:

Code:
~# telnet mail.cosmoforge.com 25
Trying 66.240.254.144...
Connected to su93254144.aspadmin.net.
Escape character is '^]'.
220 Server2.local ESMTP Postfix
ehlo localhost
250-Server2.local
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
which can't be correct.

Please run

Code:
postconf -e 'myhostname = mail.$mydomain'
postconf -e 'mydomain =cosmoforge.com'
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pop3 service alone is failed in "The Perfect Setup - Debian Sarge (3.1)" nandhu HOWTO-Related Questions 60 5th August 2008 15:15
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 18:11
pop3 login stefanr Installation/Configuration 10 2nd January 2006 10:08
authdaemon LOGIN: REJECT dgradzik Tips/Tricks/Mods 2 22nd September 2005 00:09
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 11:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.