Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2006, 14:03
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default POP3 login error /Suse perfect set up 9.3

Hi folks,

Please have a look at this error.This was happend when i did the following thing ?

# telnet cosmoforge.com pop3
Trying 66.240.aaa.xxx...
Connected to cosmoforge.com.
Escape character is '^]'.
+OK Hello there.
user web3_lasitha
+OK Password required.
pass lcg123
-ERR Maildir: No such file or directory
Connection closed by foreign host.

Thx,
gim

[
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2006, 14:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

You have to send an email to the account before you can fetch emails with pop3. The maildir is created when the first email arrives.

Dont forget to check the maildir checkbox in ISPConfig under management > server > settings on the mail tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th February 2006, 14:34
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default POP3 access

Sorry i can't send the mail

Feb 5 22:28:13 linux postfix/smtpd[18625]: NOQUEUE: reject: RCPT from unknown[220.247.234.159]: 554 <unknown[220.247.234.159]>: Client host rejected: Access denied; from=<lasitha@cosmoforge.com> to=<lasitha@codegen.net> proto=SMTP helo=<shyamal>

This is the error given by outlook.Result is same for telnet.
Reply With Quote
  #4  
Old 6th February 2006, 16:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Have you created awebsite www.codegen.net in ISPConfig with a co-domain codegen.net (host field of the co-domain is empty) and created an email user with the email address: lasitha@codegen.net ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th February 2006, 10:41
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you created awebsite www.codegen.net in ISPConfig with a co-domain codegen.net (host field of the co-domain is empty) and created an email user with the email address: lasitha@codegen.net ?
I tried to send a mail to lasitha@cosmoforge.com from my gmail account (gimhan@gmail.com)

(Cretaed user through ISP - lasitha@cosmoforge.com
www.cosmoforge.com - registered domin through DNS service provider
.)

This is an automatically generated Delivery Status Notification
Delivery to the following recipient failed permanently:

Here is the Result
Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <xproxy.gmail.com[66.249.82.201]>: Client host rejected: Access denied
----- Original message -----

Received: by 10.70.18.12 with SMTP id 12mr6837401wxr;
Mon, 06 Feb 2006 19:58:51 -0800 (PST)
Received: by 10.70.130.18 with HTTP; Mon, 6 Feb 2006 19:58:51 -0800 (PST)
Message-ID: <4b237c5b0602061958j2f62f90fw8e0a89cc0a9c8d81@mail .gmail.com>
Date: Tue, 7 Feb 2006 09:58:51 +0600
From: G i m h a n <gimhan@gmail.com>
To: lasitha@cosmoforge.com
Subject: test
MIME-Version: 1.0
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0KCiAgLS0tLS0tLS0tbzAwby0tKF8pLS1vMDBvLS0tLS0tLS 0tLS0tLS0tLS0KICAgR2ltaGFu
IFByaXlhbnRoYS9UZWFtIFZpcnR1c2GZCi0tLS0tLW9vbzAtLS 0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tCiAgICAoICAgKSAgICAgMG9vbwogICAgIFwgKC AgICAgICggICApCiAgICAgIFxf
KSAgICAgICkgLwogICAgICAgICAgICAgIChfLwo=
Reply With Quote
  #6  
Old 7th February 2006, 11:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You have an MX record for cosmoforge.com, but the MX record has no A record:

Code:
~# dig mx cosmoforge.com

; <<>> DiG 9.2.1 <<>> mx cosmoforge.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12794
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;cosmoforge.com.                        IN      MX

;; ANSWER SECTION:
cosmoforge.com.         600     IN      MX      10 q0.cosmoforge.com.

;; AUTHORITY SECTION:
cosmoforge.com.         600     IN      NS      ns2.netfirms.com.
cosmoforge.com.         600     IN      NS      ns1.netfirms.com.

;; ADDITIONAL SECTION:
ns1.netfirms.com.       85551   IN      A       64.34.74.221

;; Query time: 253 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb  7 11:56:39 2006
;; MSG SIZE  rcvd: 112

mh1:~# dig q0.cosmoforge.com

; <<>> DiG 9.2.1 <<>> q0.cosmoforge.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26855
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;q0.cosmoforge.com.             IN      A

;; AUTHORITY SECTION:
cosmoforge.com.         2560    IN      SOA     ns1.netfirms.com. hostmaster.cosmoforge.com. 1139305407 16384 2048 1048576 2560

;; Query time: 137 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb  7 11:57:05 2006
;; MSG SIZE  rcvd: 95
Mail for cosmoforge.com goes to q0.cosmoforge.com, but q0.cosmoforge.com doesn't exist. It has no A record which means mails can't be delivered!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 7th February 2006, 12:56
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

HI falko
Thanks.I'l fix it and give you a feedback
Reply With Quote
  #8  
Old 8th February 2006, 13:03
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
You have an MX record for cosmoforge.com, but the MX record has no A record:

Code:
~# dig mx cosmoforge.com

; <<>> DiG 9.2.1 <<>> mx cosmoforge.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12794
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;cosmoforge.com.                        IN      MX

;; ANSWER SECTION:
cosmoforge.com.         600     IN      MX      10 q0.cosmoforge.com.

;; AUTHORITY SECTION:
cosmoforge.com.         600     IN      NS      ns2.netfirms.com.
cosmoforge.com.         600     IN      NS      ns1.netfirms.com.

;; ADDITIONAL SECTION:
ns1.netfirms.com.       85551   IN      A       64.34.74.221

;; Query time: 253 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb  7 11:56:39 2006
;; MSG SIZE  rcvd: 112

mh1:~# dig q0.cosmoforge.com

; <<>> DiG 9.2.1 <<>> q0.cosmoforge.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26855
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;q0.cosmoforge.com.             IN      A

;; AUTHORITY SECTION:
cosmoforge.com.         2560    IN      SOA     ns1.netfirms.com. hostmaster.cosmoforge.com. 1139305407 16384 2048 1048576 2560

;; Query time: 137 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Tue Feb  7 11:57:05 2006
;; MSG SIZE  rcvd: 95
Mail for cosmoforge.com goes to q0.cosmoforge.com, but q0.cosmoforge.com doesn't exist. It has no A record which means mails can't be delivered!



I replaced the q0.cosmoforge.com with A recoed . Still can't send a mail to lasitha@cosmoforge.com . same error ....
Reply With Quote
  #9  
Old 8th February 2006, 13:39
gimhan90 gimhan90 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 139
Thanks: 2
Thanked 0 Times in 0 Posts
Default Sending first email to postfix

HI...
I tried to send an email to the account.Here i got from postmaster

Failed address: lasitha@cosmoforge.com

--- Session Transcript ---
Wed 2006-02-08 12:28:28: Parsing Message <xxxxxxxxxxxxxxxxxx\pd50001261254.msg>
Wed 2006-02-08 12:28:28: From: lasitha@codegen.net
Wed 2006-02-08 12:28:28: To: lasitha@cosmoforge.com
Wed 2006-02-08 12:28:28: Subject: TEST
Wed 2006-02-08 12:28:28: Message-ID: <op.s4nmabx5hhhxqy@shyamal>
Wed 2006-02-08 12:28:28: MX-record resolution of [cosmoforge.com] in progress (DNS Server:
161.76.9.1)...
Wed 2006-02-08 12:28:28: * P=010 D=cosmoforge.com TTL=(0) MX=[mail.cosmoforge.com]
{66.240.254.144}
Wed 2006-02-08 12:28:28: Attempting MX: P=010 D=cosmoforge.com TTL=(0) MX=[mail.cosmoforge.com]
{66.240.254.144}
Wed 2006-02-08 12:28:28: Attempting SMTP connection to [66.240.254.144 : 25]
Wed 2006-02-08 12:28:28: Waiting for socket connection...
Wed 2006-02-08 12:28:28: Socket connection established (161.76.28.49 : 3720 -> 66.240.254.144 :
25)
Wed 2006-02-08 12:28:28: Waiting for protocol initiation...
Wed 2006-02-08 12:28:29: <-- 220 ****************************
Wed 2006-02-08 12:28:29: --> EHLO mail.codegen.it
Wed 2006-02-08 12:28:29: <-- 250-cosmoforge.com
Wed 2006-02-08 12:28:29: <-- 250-PIPELINING
Wed 2006-02-08 12:28:29: <-- 250-SIZE 10240000
Wed 2006-02-08 12:28:29: <-- 250-VRFY
Wed 2006-02-08 12:28:29: <-- 250-ETRN
Wed 2006-02-08 12:28:29: <-- 250-XXXXXXXA
Wed 2006-02-08 12:28:29: <-- 250-AUTH PLAIN LOGIN
Wed 2006-02-08 12:28:29: <-- 250 8BITMIME
Wed 2006-02-08 12:28:29: --> MAIL From:<lasitha@codegen.net> SIZE=1544
Wed 2006-02-08 12:28:30: <-- 250 Ok
Wed 2006-02-08 12:28:30: --> RCPT To:<lasitha@cosmoforge.com>
Wed 2006-02-08 12:28:30: <-- 554 <mail.codegen.it[161.76.28.49]>: Client host rejected: Access
denied

What is happening here?
Reply With Quote
  #10  
Old 8th February 2006, 16:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pop3 service alone is failed in "The Perfect Setup - Debian Sarge (3.1)" nandhu HOWTO-Related Questions 60 5th August 2008 15:15
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 18:11
pop3 login stefanr Installation/Configuration 10 2nd January 2006 10:08
authdaemon LOGIN: REJECT dgradzik Tips/Tricks/Mods 2 22nd September 2005 00:09
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 08:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.