Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #31  
Old 11th February 2006, 20:49
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
Default

ok Im going to start installing ispconfig again

EDIT it didnt work it had the same mysql problem as before saying that my password is wrong, is there anyway to login to mysql and do database stuff without having ispconfig installed? maybe we can find the problem and fix it...
btw do either of you have msn or yahoo or something that i could chat with you on?

EDIT again this thing doesnt seem to like me i ran ispconfig install again after changing the mysql password the ispconfig install was going well oe atleast it seemed to be going well until it came to the mysql part:
Quote:
Please enter your MySQL server: localhost
Please enter your MySQL user: root
Please enter your MySQL password:
it didnt like the password i gave it then the install quits, so I started it again(I know i shouldnt have but i just keep forgetting that i need to remove stuff before it will work properly) and it gives me this message at the end of the install:
Quote:
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
but i still cant login to it.
click here to see the installation(whats left in the terminal)
__________________
My Server Stats:
No servers currently working.

Last edited by Jrdgames; 12th February 2006 at 03:46.
Sponsored Links
  #32  
Old 12th February 2006, 10:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Jrdgames
btw do either of you have msn or yahoo or something that i could chat with you on?
I don't use any messengers.

Quote:
Originally Posted by Jrdgames
EDIT again this thing doesnt seem to like me i ran ispconfig install again after changing the mysql password the ispconfig install was going well oe atleast it seemed to be going well until it came to the mysql part:
How did you change the MySQL password?


Quote:
Originally Posted by Jrdgames
it didnt like the password i gave it then the install quits, so I started it again(I know i shouldnt have but i just keep forgetting that i need to remove stuff before it will work properly) and it gives me this message at the end of the install:

but i still cant login to it.
You should have removed the old, faulty ISPConfig installation first.
Run
Code:
rm -fr /root/ispconfig
rm -fr /home/admispconfig
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #33  
Old 12th February 2006, 19:02
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Quote:
I don't use any messengers.
oh ok

Quote:
How did you change the MySQL password?
I followed the guide on the mysql site:
Quote:
In a Unix environment, the procedure for resetting the root password is as follows:

1.

Log on to your system as either the Unix root user or as the same user that the mysqld server runs as.
2.

Locate the .pid file that contains the server's process ID. The exact location and name of this file depend on your distribution, hostname, and configuration. Common locations are /var/lib/mysql/, /var/run/mysqld/, and /usr/local/mysql/data/. Generally, the filename has the extension of .pid and begins with either mysqld or your system's hostname.

You can stop the MySQL server by sending a normal kill (not kill -9) to the mysqld process, using the pathname of the .pid file in the following command:

shell> kill `cat /mysql-data-directory/host_name.pid`

Note the use of backticks rather than forward quotes with the cat command; these cause the output of cat to be substituted into the kill command.
3.

Create a text file and place the following command within it on a single line:

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('MyNewPassword');

Save the file with any name. For this example the file will be ~/mysql-init.
4.

Restart the MySQL server with the special --init-file=~/mysql-init option:

shell> mysqld_safe --init-file=~/mysql-init &

The contents of the init-file are executed at server startup, changing the root password. After the server has started successfully you should delete ~/mysql-init.
5.

You should be able to connect using the new password.
It look like we need to get this mysql issue resolved for it to work.
__________________
My Server Stats:
No servers currently working.
  #34  
Old 12th February 2006, 21:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Now that you've reset your MySQL password, can you log in to MySQL? Try
Code:
mysql -u root -p
and see if you get in.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #35  
Old 13th February 2006, 00:00
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
Default

its not working
__________________
My Server Stats:
No servers currently working.
  #36  
Old 13th February 2006, 09:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Then resetting your password did not work. You should reinstall the whole system.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #37  
Old 13th February 2006, 17:45
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
Default

so I will need to wipe the whole drive again?
EDIT could i use files from a server that was working properly instead of redoing the whole thing?

EDIT can I change the mysql password by editing a file? or does it have to be done by running a command or using the guide on the mysql page?
what does the code in mysql's(var/run/mysqld/mysqld.pid) .pid file stand for?

EDIT Again: I think I found where mysql keeps the password: /etc/mysql/debian.cnf now if only we knew how to decode it then we could manually reset it. Anyone know how to decode mysql password in this file?
__________________
My Server Stats:
No servers currently working.

Last edited by Jrdgames; 13th February 2006 at 18:56.
  #38  
Old 13th February 2006, 22:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I think you're wasting your time. You should try a clean reinstall, and try to stick as close as possible to the "Perfect Setup" on HowtoForge. I don't think you can somehow recover your password or trick MySQL.

Quote:
what does the code in mysql's(var/run/mysqld/mysqld.pid) .pid file stand for?
That's the process ID of the MySQL process.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #39  
Old 14th February 2006, 00:11
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
Default

ok I will start reinstalling the entire os if i need any help during the install I will be posting from my windows box, I hope it all installs fine.

EDIT ok linux is running again and things seem to be running again, although when I ran apt-get install ssh i got the following:
Quote:
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
openssh-server
Suggested packages:
rssh
The following NEW packages will be installed:
openssh-server ssh
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/196kB of archives.
After unpacking 557kB of additional disk space will be used.
Do you want to continue [Y/n]? y
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/main Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/restricted Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/universe Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_universe_binary-i386_Packages) - stat (2 No such file or directory)W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/multiverse Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_multiverse_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/restricted Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/universe Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_universe_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/main Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/restricted Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/universe Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_universe_binary-i386_Packages) - stat (2 No such file or directory)W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/multiverse Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_multiverse_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/restricted Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/universe Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_universe_binary-i386_Packages) - stat (2 No such file or directory)

Preconfiguring packages ...
Selecting previously deselected package openssh-server.
(Reading database ... 61028 files and directories currently installed.)
Unpacking openssh-server (from .../openssh-server_1%3a4.1p1-7ubuntu4_i386.deb) ...
Selecting previously deselected package ssh.
Unpacking ssh (from .../ssh_1%3a4.1p1-7ubuntu4_all.deb) ...
Setting up openssh-server (4.1p1-7ubuntu4) ...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
* Restarting OpenBSD Secure Shell server... [ ok ]

Setting up ssh (4.1p1-7ubuntu4) ...

W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/main Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/restricted Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/universe Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_universe_binary-i386_Packages) - stat (2 No such file or directory)W: Couldn't stat source package list http://us.archive.ubuntu.com breezy-backports/multiverse Packages (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_breezy-backports_multiverse_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/restricted Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_restricted_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://security.ubuntu.com breezy-security/universe Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_breezy-security_universe_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
I know the first 12 lines are normal and then the block further down but the other parts look like theres something wrong with the repositories or something like that I have run apt-get update and I will continue following the guide: http://www.howtoforge.com/perfect_setup_ubuntu_5.04_p3

EDIT could not find ncftp and it is not in my synaptic package manager I need to know how to get this package/where to get.
Quote:
apt-get install ncftp
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package ncftp
EDIT can't find file inetd in /etc/init.d/ so i can't reload it, proceeding to quota
Quote:
/etc/init.d/inetd reload
bash: /etc/init.d/inetd: No such file or directory
im thinking these warnings probably came up because the quota files probably didnt exist before this, right?
Quote:
quotacheck -avugm
quotacheck: WARNING - Quotafile //quota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile //quota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/hdd3 [/] done
quotacheck: Checked 7093 directories and 67355 files
quotacheck: WARNING - Quotafile /var/quota.user was probably truncated. Can't save quota settings...
quotacheck: WARNING - Quotafile /var/quota.group was probably truncated. Can't save quota settings...
quotacheck: Scanning /dev/hdd4 [/var] done
quotacheck: Checked 219 directories and 6254 files
Code:
what am I doing wrong here?
Quote:
/etc/postfix/ssl# openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024 258 semi-random bytes loaded Generating RSA private key, 1024 bit long modulus ....................................++++++ .....++++++ e is 65537 (0x10001) Enter pass phrase for smtpd.key: Verifying - Enter pass phrase for smtpd.key: Verify failure User interface error 12251:error:0906906F:PEM routines:PEM_ASN1_write_bio:read key:pem_lib.c:329:
it says verify failure user interface error so is this an error on my part or its part? im sure im typing the passphrase the same each time
^-- never mind about that got it working.
__________________
My Server Stats:
No servers currently working.

Last edited by Jrdgames; 14th February 2006 at 18:29.
  #40  
Old 14th February 2006, 18:30
Jrdgames Jrdgames is offline
Member
 
Join Date: Feb 2006
Location: USA East Coast
Posts: 71
Thanks: 11
Thanked 0 Times in 0 Posts
 
Default

Sorry about the double post ran out of space in the last one.

I know have some errors that MUST be fixed before I can continue with instalation: when i ran: apt-get install autoconf automake1.4 autotools-dev libapache2-mod-php4 libkrb53 php4 php4-common php4-dev php4-imagick php4-mcrypt php4-rrdtool php4-sqlite php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt
I got the error: E: Couldn't find package php4-imagick
so i started installing them one at a time and I have a list of other packages that must be installed:
  • libapache2-mod-php4=E: Broken packages
    PHP4=E: Broken packages
    php4-domxml=E: Broken packages
    php4-gd=E: Broken packages
    php4-xslt=E: Broken packages
    php4-ldap=E: Broken packages
    php4-mcal=E: Broken packages
    php4-mhash=E: Broken packages
    php4-mysql=E: Broken packages
    php4-odbc=E: Broken packages
    php4-pear=E: Broken packages
    php4-rrdtool=E: Couldn't find package
    php4-sqlite=E: Couldn't find package
    php4-imagick=E: Couldn't find package
    php4-imap=E: Couldn't find package

here are some screenshots whebn i try it in synaptic:



by the way should i be trying to use php5 instead of 4? even though the guide says 4 http://www.howtoforge.com/perfect_setup_ubuntu_5.04_p5
__________________
My Server Stats:
No servers currently working.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config Installation on Suse 9.3 gimhan90 Installation/Configuration 5 20th January 2006 10:24
The config of webmail/pop3 make me crazy!!! :( Spektro Installation/Configuration 7 14th December 2005 14:33
Can't access System config / Settings section Spektro Installation/Configuration 1 9th December 2005 15:31
DNS Config Problem bolinux Installation/Configuration 27 20th August 2005 16:12
Config file templates till Developers' Forum 0 30th July 2005 23:10


All times are GMT +2. The time now is 20:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.