Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2006, 00:39
Drek Drek is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Basic Proftpd/MySQL configuration

I'm trying to set up proftpd-mysql on Debian Sarge. I followed the tutorial on this site to a t, but it's still not working. I can get my client (FileZilla) to connect to the server, but it stalls at "waiting for welcome message". I don't have iptables, or any firewall installed on the server, it isn't live yet, I'm just trying to install and configure everything, get it working, and then secure it. I'm accessing it from within the lan. Is there another tutorial for setting up proftpd-mysql somewhere? I've done a ton of reading today, and my head hurts, and I can't see straight - do I sound like I'm whining?
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2006, 11:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Have you tried both active and passive mode in your FTP client?
Please post the output of
Code:
netstat -tap
Do you see any errors in the logs in /var/log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th February 2006, 15:29
Drek Drek is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     1993/mysqld
tcp        0      0 *:www                   *:*                     LISTEN     2172/apache2
tcp        0      0 *:ftp                   *:*                     LISTEN     2073/proftpd: (acce
tcp        0      0 server.cc-lan:666       *:*                     LISTEN     2058/sshd
tcp        0      0 *:https                 *:*                     LISTEN     2172/apache2
tcp        0      0 *:3551                  *:*                     LISTEN     1869/apcupsd
tcp        0    296 server.cc-lan:666       owen.cc-lan:1155        ESTABLISHED2590/0
As for logs, is there supposed to be a proftpd log? I looked for one in /var/log and couldn't see one. The only mention I could find of proftpd was in daemon.log.

Quote:
Feb 6 09:18:29 localhost proftpd[2602]: localhost.localdomain (owen.cc-lan[192.168.0.102]) - FTP session closed.
As I said, this seems to indicate that I've at least connected.

And yes, I've tried both active and passive mode.

edit: Actually, I'm thinking maybe its a permissions problem. I haven't got any of that sorted out yet. I've got the right owership on the folder, but I'm not sure I've got the permissions right.

Last edited by Drek; 6th February 2006 at 17:15.
Reply With Quote
  #4  
Old 6th February 2006, 19:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by Drek
As for logs, is there supposed to be a proftpd log? I looked for one in /var/log and couldn't see one. The only mention I could find of proftpd was in daemon.log.
Have a look at /var/log/xferlog, /var/log/syslog, /var/log/messages.

Have you double-checked all your configuration files that they look like the ones from the tutorial?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th February 2006, 22:19
Drek Drek is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I moved on to finish my configuration of PHP and MySQL. I completely uninstalled ProFTPD. I'll try installing it again and get back here with any results. I'm just happy to get my website back up and running. At this point the FTP is secondary.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind chroot configuration Toffee Installation/Configuration 6 13th March 2009 16:51
Loading configuration file lance Kernel Questions 2 28th February 2007 21:40
Nameserver configuration teleriddler Installation/Configuration 14 28th January 2006 17:13
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 15:01
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 11:53


All times are GMT +2. The time now is 03:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.