Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2008, 23:25
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default Fedora 9 Network Manager asking for keyring password

OK, so I recently upgraded my wife's desktop from Fedora 8 to Fedora 9 using the Preupgrade walkthrough. Following the upgrade, I had some problems with ndiswrapper and my wireless adapter, so I had to do some YUM trickery but have it working now. However, the annoying thing is that EVERY TIME we log her in, the GUI comes up and then it immediately asks for her keyring password (which is the same as her login password). Once we put in the keyring password, it connects to the wireless network. Without the keyring password, it will not connect to the wireless network.

How do we get rid of the annoying query for the keyring password. Interestingly, nothing else has asked for the keyring password. BTW, I read somewhere that the GDM login is supposed to be tied to the keyring. Is that true? If so, why the issues.

I have pam_keyring and gnome-keyring-manager installed.
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2008, 23:28
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default

BTW, before the upgrade, this did not happen in Fedora 8. I set up Fedora 8 using the "Perfect Desktop" howto.
Reply With Quote
  #3  
Old 7th June 2008, 18:44
dalewilcox dalewilcox is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default keyring

Open .gnome2/keyrings and delete login.keyring. When you log back in you will be prompted for a new password.

That should fix you problem.
Reply With Quote
  #4  
Old 8th June 2008, 06:27
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by dalewilcox View Post
Open .gnome2/keyrings and delete login.keyring. When you log back in you will be prompted for a new password.

That should fix you problem.
In the terminal, I used <cd ~/.gnome2> and did a <dir> and there is no "keyrings" file there. Could this file be located somewhere else?
Reply With Quote
  #5  
Old 8th June 2008, 17:32
dalewilcox dalewilcox is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default keyring

The file is located in the /home dir of the user. Example /home/dale/.gnome2/keyrings

Dale
Reply With Quote
  #6  
Old 8th June 2008, 17:37
dalewilcox dalewilcox is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default keyring

Did not look at you message close.

at the command prompt type ls .gnome2/keyrings. Do not put anything in front of .gnome2 but the period.

Mind you this is in the /home directory for the user.
Reply With Quote
  #7  
Old 9th June 2008, 04:51
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default

I found the file. You were right; I was looking in the root directory, not in the user's home folder.

Unfortunately, I deleted the "login.keyring" file, rebooted, entered the password again, and then rebooted again and... still being prompted for the password right after logging in. Deleting the "login.keyring" file did not seem to change anything.
Reply With Quote
  #8  
Old 9th June 2008, 15:15
o.meyer o.meyer is offline
Senior Member
 
Join Date: Aug 2007
Posts: 167
Thanks: 2
Thanked 24 Times in 23 Posts
Default

Hi jkrell,

please delete -all- files in the keyring folder and log out and in again. Now, when you enter a password for the first time (Evolution, WLAN ...) you'll be asked for a new password for the default keyring - and if it shall be opened automatically after login - choose "Yes".

Best regards,

Olli
Reply With Quote
  #9  
Old 9th June 2008, 16:25
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default

OK, I will give that a try. As I recall, there were a couple other files in the keyring folder so I will delete them and reboot when I get home tonight.

I'll post the results here.
Reply With Quote
  #10  
Old 11th June 2008, 06:23
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by o.meyer View Post
please delete -all- files in the keyring folder and log out and in again. Now, when you enter a password for the first time (Evolution, WLAN ...) you'll be asked for a new password for the default keyring - and if it shall be opened automatically after login - choose "Yes".
No go. I tried this twice, and I do not get asked whether the keyring should be opened automatically after login. After I log in, I have to enter the WIFI WEP key again, and then it presents a dialog box telling me to choose a new password for the default keyring, and offers "DENY" or "OK" as the choices.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems setting up network printer in Fedora Core 8 jkrell Installation/Configuration 11 10th April 2008 23:56
Setting password Length in fedora nasril Installation/Configuration 4 30th July 2007 03:02
Fedora Core 6 server keeps dropping off network bugboy Server Operation 14 23rd March 2007 19:21
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 12:30


All times are GMT +2. The time now is 06:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.